Вход | Регистрация



запрос (помощь)

↓ [Волшебник, 19.03.18 - 15:36]
запрос (помощь)
Я
   serg-lom89
 
19.03.18 - 15:34
Добрый день
есть запрос он скажем тестовый.

ВЫБРАТЬ
    "Документы" КАК поле1,
    "ЗаказПокупателя" КАК поле2,
    "Товары" КАК поле3,
    ИСТИНА КАК Поле4
ПОМЕСТИТЬ ВТ
;

////////////////////////////////////////////////////////////////////////////////

ВЫБРАТЬ
    ВТ.поле1 КАК поле1,
    ВТ.поле2 КАК поле2,
    ВТ.поле3 КАК поле3,
    ВТ.Поле4 КАК Поле4
ИЗ
    ВТ КАК ВТ
ИТОГИ
    Поле4 КАК Поле4
ПО
    поле1,
    поле2,
    поле3,
    Поле4

как мне задать условие что бы  в колонке поля4,значение истина отображалась только как на скрине

https://ibb.co/g9pq0H

спасибо
 
 
   shuhard
 
1 - 19.03.18 - 15:35
(0)[значение истина отображалась только как на скрине ]
чё ?
   evorle145
 
2 - 19.03.18 - 15:35
(0) вместо "да" было пусто что ли? формат колонки в скд для этого есть.
   serg-lom89
 
3 - 19.03.18 - 15:36
(1) как на картинке,что в ссылке
   lodger
 
4 - 19.03.18 - 15:38
(3) на картинке зачеркнуты "Да" и в белый квадрат спрятано "Нет". так как надо то?
   serg-lom89
 
5 - 19.03.18 - 15:42
(4) сори что не написал на скрине..
где зачеркнуто там пусто.
А где квадрат значение ,которое будет задано
   Ёпрст
 
6 - 19.03.18 - 15:53
(0)

//    ИСТИНА КАК Поле4

"""" как Поле4
   lodger
 
7 - 19.03.18 - 15:53
(5) где квадрат это поле итогов. туда нельзя поместить значение не поместив его в строки данных.
   Fram
 
8 - 19.03.18 - 16:18
(4) выбор когда?
   Вафель
 
9 - 23.03.18 - 11:54

   Вафель
 
10 - 23.03.18 - 11:57
retewtrewt

 
 Рекламное место пустует
   Вафель
 
11 - 23.03.18 - 11:57
fggdgdf
   Вафель
 
12 - 23.03.18 - 11:57
dfsfsfd
   Вафель
 
13 - 23.03.18 - 11:58
bvdcgt
   Вафель
 
14 - 23.03.18 - 12:04
dfsfsfsd

   Вафель
 
15 - 27.03.18 - 17:28
1
   Вафель
 
16 - 27.03.18 - 18:18
2
   Вафель
 
17 - 27.03.18 - 18:20
3
   Вафель
 
18 - 27.03.18 - 18:20
4
   Вафель
 
19 - 27.03.18 - 18:21
5
   Вафель
 
20 - 27.03.18 - 18:31
gfhjfkjfkjfjgfgf
   Вафель
 
21 - 27.03.18 - 18:32
fgkjfgjfjgfgfg
   Вафель
 
22 - 27.03.18 - 19:09
111
   Вафель
 
23 - 28.03.18 - 10:36
1313121313
   Вафель
 
24 - 28.03.18 - 12:13
123
   Вафель
 
25 - 28.03.18 - 12:20
тест
   Вафель
 
26 - 28.03.18 - 12:25
тест2
   Вафель
 
27 - 28.03.18 - 12:27
1111
   Вафель
 
28 - 28.03.18 - 12:32
а этот
   Вафель
 
29 - 28.03.18 - 12:40
\u1090\u1077\u1089\u1090
   Вафель
 
30 - 28.03.18 - 12:45
тест
   Вафель
 
31 - 28.03.18 - 12:46
111
   Вафель
 
32 - 28.03.18 - 13:22
тест2222
   Вафель
 
33 - 28.03.18 - 13:23
&
 
 
   Вафель
 
34 - 28.03.18 - 13:25
тест & тест
   Вафель
 
35 - 28.03.18 - 13:26
тест ? тест
   Вафель
 
36 - 28.03.18 - 13:26
тест
тест
   Вафель
 
37 - 28.03.18 - 13:29
<Тест> \\
   Вафель
 
38 - 28.03.18 - 13:32
345
   Вафель
 
39 - 28.03.18 - 15:03
// Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры

   Вафель
 
40 - 28.03.18 - 15:34
(39)
   Вафель
 
41 - 28.03.18 - 15:40
(40) тест
   Вафель
 
42 - 28.03.18 - 16:57
текст
// Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры

текст
   Вафель
 
43 - 28.03.18 - 17:00
текст
// Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры

текст
// Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры

   Вафель
 
44 - 28.03.18 - 17:40

   Вафель
 
45 - 28.03.18 - 21:29
dfsfsfd

   Вафель
 
46 - 28.03.18 - 21:30
d = "
| dfsf
| dsgffsg";

   Вафель
 
47 - 29.03.18 - 10:54
/
/ Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры


a=1;

   Вафель
 
48 - 29.03.18 - 16:50
1
   Вафель
 
49 - 29.03.18 - 16:58
2
 
 Рекламное место пустует
   Вафель
 
50 - 29.03.18 - 18:03
(100)
   Вафель
 
51 - 25.04.18 - 16:42
тест
   Вафель
 
52 - 25.04.18 - 16:47
3242142
   Вафель
 
53 - 27.04.18 - 18:06
for i=1 to 5 do
enddo

   Вафель
 
54 - 16.05.18 - 16:31
   Вафель
 
55 - 28.05.18 - 16:52
   Вафель
 
56 - 29.05.18 - 15:12
тест
   Вафель
 
57 - 04.06.18 - 11:27
1+1
   Вафель
 
58 - 04.06.18 - 11:27
-&?
   Вафель
 
59 - 07.06.18 - 18:19
kjhklhkjhkljhkljhklhkj  kgghgfk yrtyf
   Вафель
 
60 - 14.06.18 - 16:59
   Вафель
 
61 - 03.07.18 - 11:12
// Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры
   Вафель
 
62 - 03.07.18 - 11:13
// Комментарий
Процедура Тест()
  а = 1;
КонецПроцедуры

   Вафель
 
63 - 12.07.18 - 11:50
   Вафель
 
64 - 12.07.18 - 15:10
тест
   Вафель
 
65 - 12.07.18 - 15:29
1
   Вафель
 
66 - 12.07.18 - 15:39
2
   Вафель
 
67 - 13.07.18 - 11:16
   Вафель
 
68 - 13.07.18 - 11:22
   Вафель
 
69 - 16.07.18 - 16:33
users.php?id=66400
   Вафель
 
70 - 16.07.18 - 16:33
/users.php?id=66400
   Вафель
 
71 - 31.07.18 - 14:06
1
   Вафель
 
72 - 18.10.18 - 17:24
   Вафель
 
73 - 18.10.18 - 17:27



Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует