Вход | Регистрация

1С:Предприятие ::

Метки: 

Проверяю ИНН на сайте nalog.ru ошибка

Я
   skupidom
 
14.06.18 - 15:31
Использую код: http://catalog.mista.ru/public/439808/
код:
&НаСервере
Процедура ПроверитьИНН(ТЗ)


    ОтветState = 0;
    
    Определение = Новый WSОпределения("http://npchk.nalog.ru/FNSNDSCAWS_2?wsdl";);
    Прокси = Новый WSПрокси(Определение, "http://ws.unisoft";, "FNSNDSCAWS2","FNSNDSCAWS2_Port");  
    Запрос = Прокси.ФабрикаXDTO.Создать(Прокси.ФабрикаXDTO.Тип("http://ws.unisoft/FNSNDSCAWS2/Request";, "NdsRequest2"));
    
    Для Каждого Стр Из ТЗ Цикл
        
        Данные = Стр.Ссылка;
        
        Если НЕ ЗначениеЗаполнено(Данные.ИНН) Тогда
            ОтветState = 9;
        КонецЕсли;
        
        Если ЗначениеЗаполнено(Данные.ИНН) Тогда
            
            Контрагент = Прокси.ФабрикаXDTO.Создать(Прокси.ФабрикаXDTO.Тип("http://ws.unisoft/FNSNDSCAWS2/Request";, "NdsRequest2_NP"));
            
            Контрагент.INN = Данные.ИНН;
            Контрагент.KPP = Данные.КПП;
            Контрагент.DT = Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy");
            Запрос.NP.Добавить(Контрагент);
            
            РезультатЗапроса = Прокси.NdsRequest2(Запрос);
            
            Для каждого ОтветДляКонтрагента из РезультатЗапроса.NP Цикл
                ОтветТекЭл = ОтветДляКонтрагента.State;                 
            КонецЦикла;
            
        КонецЕсли;
            
            ОбъектЭлБП = Стр.Ссылка.ПолучитьОбъект();
            Если ОтветТекЭл = "0" Тогда
                ОбъектЭлБП.ПризнакРабочегоИНН = Истина;
            Иначе
                ОбъектЭлБП.ПризнакРабочегоИНН = Ложь;
            КонецЕсли;
            
            ОбъектЭлБП.Записать();
            
    КонецЦикла;
          
КонецПроцедуры

Ошибка:
{ВнешняяОбработка.П_ОбработкаКонтрагентовДатареон.Форма.Форма.Форма(5111)}: Ошибка при вызове конструктора (WSОпределения)
    Определение = Новый WSОпределения("http://npchk.nalog.ru/FNSNDSCAWS_2?wsdl";);
по причине:
При вызове веб-сервиса произошла ошибка. При создании описания сервиса произошла ошибка. URL сервиса: http://npchk.nalog.ru/FNSNDSCAWS_2?wsdl
по причине:
Ошибка работы с Интернет:   Не могу установить соединение

коллеги,у кого есть код обработки с сайта,в чем ошибка ?
 
 
   novichok79
 
1 - 14.06.18 - 15:37
(0) шо, опять???
   lodger
 
2 - 14.06.18 - 15:38
(0)
зайдите под пользователем, из под которого запущена служба сервера 1С, видимо нет доступа в интернет у учетной записи сервера 1С © Гилёв Вячеслав

или посмотрите в сторону вашей прокси в интернет.
   LienXo
 
3 - 14.06.18 - 16:15
У налоговой вчера техработы шли, могут и сейчас продолжаться


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует