Вход | Регистрация



Почему odata не работает?

Почему odata не работает?
Я
   PR
 
11.01.19 - 06:19
4. Не умеешь готовить Апач, не берись50% (1)
8. Свое мнение50% (1)
1. Причина вот в чём...0% (0)
2. Нужен Апач 32х0% (0)
3. Выкинь Апач, возьми IIS0% (0)
5. Виновата платформа 1С0% (0)
6. Дело не в Апаче0% (0)
7. А я-то откуда знаю?0% (0)
Всего мнений: 2

8.3.14.1494
Апач 2.4 64х

Набираю в браузере http://site.ru/basename/odata/standard.odata/

Получаю что-то типа

1C:Enterprise 8 application error:
Невосстановимая ошибка
by reason:
Сеанс отсутствует или удален ID=1f51a981-364a-4934-9c2b-145f3290fde7, File=d:\jenkins\ci_builder2\windowsbuild2\platform\src\rserver\src\clusterdistribimpl.cpp(1439)

У другого клиента примерно то же, суть та же

1C:Enterprise 8 application error:
Невосстановимая ошибка
by reason:
Сеанс отсутствует или удален ID=9e9c0d50-bd22-4a9c-91d3-60fff0dd5bd4, File=src\ClusterDistribImpl.cpp(1436)

При этом веб-клиент пашет, не работает только odata
 
 
   Beduin
 
1 - 11.01.19 - 06:28
(0) Программа, которая отвечает за трансляцию данных из 1С в 80 порт не работает.
   мокасинчик
 
2 - 11.01.19 - 06:37
Печенюшка зачем ты каждый раз прикручиваешь тупую голосовалку когда обсираешься? Для тебя всегда нужен только один пункт кг/ам

8. Свое мнение
   PR
 
3 - 11.01.19 - 06:39
(2) Ой, Миша, а я думал, ты уже запил с безнадеги :))
   PR
 
4 - 11.01.19 - 06:40
(1) И что это значит? И как это, веб-клиент же работает?
   Beduin
 
5 - 11.01.19 - 06:45
(4) o.data это просто протокол. И то, что транслирует данные в Почему odata не работает?
записало о 503 ошибке
   PR
 
6 - 11.01.19 - 06:48
(5) А, ну вот, теперь все сразу стало понятно
   мокасинчик
 
7 - 11.01.19 - 06:52
(5) Чувак ты же ушел в жабу андроид, почему ты здесь?
   Beduin
 
10 - 11.01.19 - 07:01
(7) такой динамике как на мисте java форумам и не снилось
 
 Рекламное место пустует
   PR
 
12 - 11.01.19 - 07:05
(5) В ie, кстати, другой текст, нежели в firefox, говорит про ошибку 500
   PR
 
16 - 11.01.19 - 07:08
(13) Миша, дурачина, я как бы просто сообщил, что ошибка 500, а не 503 и то, что ошибки в разных браузерах разные, то есть текст ошибки генерится браузером, а не, допусти, берется от Апача, например
   Beduin
 
21 - 11.01.19 - 07:17
(14) Клиенты по 1С с прошлого остались. Вообще по 1С работы тьма. Ни разу объявление даже не давал. Прут и прут.
   PR
 
25 - 14.01.19 - 03:07
Так что, есть герои? :))
А то проблема все так же актуальна
Уже и Апач переставил и 1С и базу переопубликовал и права проверил, которые догадался
   духан пердушанский
 
26 - 14.01.19 - 03:20
(25) тебе уже ничего не поможет, смирись
   PR
 
27 - 14.01.19 - 03:41
(26) Что, Мишанька, не спится, по делу сказать нечего, а пукнуть хочется?
   PR
 
28 - 14.01.19 - 10:54
И снова (25) :))
   Мыш
 
29 - 14.01.19 - 11:08
(0) $metadata работает?
   PR
 
30 - 14.01.19 - 11:32
(29) Нет
Я же писал, даже уже /odata/standard.odata не работает
   духан пердушанский
 
31 - 14.01.19 - 11:34
Печенюшка ты долбоеб потому что
   Мыш
 
32 - 14.01.19 - 11:39
(30) А что в .vrd файле?
   PR
 
33 - 14.01.19 - 12:48
(32) Все по дефолту, вместо mybasename и myservername мои сервер и база
<?xml version="1.0" encoding="UTF-8"?>
<point xmlns="http://v8.1c.ru/8.2/virtual-resource-system";
        xmlns:xs="http://www.w3.org/2001/XMLSchema";
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
        base="/mybasename"
        ib="Srvr=&quot;myservername&quot;;Ref=&quot;mybasename&quot;;">
    <ws enable="false"/>
    <httpServices publishByDefault="false"/>
    <standardOdata enable="true"
            reuseSessions="autouse"
            sessionMaxAge="20"
            poolSize="10"
            poolTimeout="5"/>
</point>
 
 
   ДенисЧ
 
34 - 14.01.19 - 12:53
В логи http-сервера кто-нибудь уже советовал заглянуть?
   PR
 
35 - 14.01.19 - 12:54
(34) Заглядывал, ничего интересного
   PR
 
36 - 14.01.19 - 17:04
Ап?
   духан пердушанский
 
37 - 14.01.19 - 17:07
(36) Рома иди паси свиней, все равно руки из задницы у тебя и мосх куриный
   PR
 
38 - 14.01.19 - 17:09
(37) Миша, иди нахуй, задрал ты уже своим блевотным юмором
   духан пердушанский
 
39 - 14.01.19 - 17:10
(38) ко-ко-ко, кудах-кудах, давай еще поплачь
   духан пердушанский
 
40 - 14.01.19 - 17:13
Рома я тебе ответил еще в (31) а до тебя все не доходит
   PR
 
41 - 15.01.19 - 23:04
Хм, замена Апача на 32-х версию тоже ничего не дала
Что за чудеса в решете
Истина где-то рядом же, чую :))
   palsergeich
 
42 - 15.01.19 - 23:09
   PR
 
43 - 15.01.19 - 23:11
(42) Вообще ни разу
   PR
 
44 - 15.01.19 - 23:12
Кстати, перед выдачей ошибки не запрашивается логин пароль, что странно
   palsergeich
 
45 - 15.01.19 - 23:14
Ну ты все равно проверь права на папки
   PR
 
46 - 15.01.19 - 23:17
(45) Да даже всем всё разрешил
   Nyoko
 
47 - 15.01.19 - 23:21
14 платформу не ставил, ни каких проблем, разрядность тут не причем, если используешь 1с 64 юзай апач 64 ну и наоборот.

даже связка nginx - apache полёт нормальный. а, вот веб клиент уже глючит.  

после простоты apache тошнит от iis ...

4. Не умеешь готовить Апач, не берись
   palsergeich
 
48 - 15.01.19 - 23:22
Вот еще что пишут...
С большой вероятностью х32 процесс апача вылетает из-за большого массива информации - переполнение происходит.
Поставьте IIS. инструкция на инфостарте есть по установке и настройке для работы с 1с. И в настройках IIS увеличьте число рабочих процессов. Это делается в доп.параметрах DefaultAppPool.

Apache2.2 под windows не умеет "распределять" нагрузку между процессами.
   Nyoko
 
49 - 15.01.19 - 23:26
(47) апач всегда беру отсюда https://www.apachehaus.com/
 
 Рекламное место пустует
   PR
 
50 - 15.01.19 - 23:59
(47) Да я уже и платформу другую поставил, правда тоже 64-х
   PR
 
51 - 16.01.19 - 00:22
Странное дело, прописал в vrd-файл конкретные логин и пароль, работает
А почему сам браузер не запрашивает?
   PR
 
52 - 16.01.19 - 10:42
Есть еще идеи?
   PR
 
53 - 16.01.19 - 23:23
Мда, печалька
   palsergeich
 
54 - 16.01.19 - 23:26
(51) а такое было.
Или в адресной строке пишешь Логин:Пароль@адрес или в врд логин пароль прописываешь.
Как лечил не помню, что то было в настройках безопасности, но вылечил. Давненько было.
   PR
 
55 - 17.01.19 - 08:50
(54) У меня раньше давным-давно такое работало, пароль запрашивался
   PR
 
56 - 17.01.19 - 12:25
Я вот думаю, может дело в платформе?
Но проверять лень
   удовлетворяльщик
 
57 - 17.01.19 - 12:32
Дело в (31) можешь даже не проверять
   PR
 
58 - 22.01.19 - 01:27
(54) В этом случае говорит, что сайт типа не требует авторизации
Вот и вопрос, как включить авторизацию?
   PR
 
59 - 22.01.19 - 09:04
Ап


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует