Вход | Регистрация


Как в док. выбрать материал принадл. определенной группе справ?

Как в док. выбрать материал принадл. определенной группе справ?
Я
   Абрум
27.08.04 - 14:19
из табличной части документа как такое можно выбрать?
 
 
   Diter
 
1 - 27.08.04 - 14:20
После выбора проверя на "Родитель" выбранный элемент и ругаймя почём зря, если группа не та.:)
   Абрум
2 - 27.08.04 - 14:25
А можно простенький пример?
   SnarkHunter
 
3 - 27.08.04 - 14:27
Нельзя
   Абрум
4 - 27.08.04 - 14:29
(3)жаль :(
   Diter
 
5 - 27.08.04 - 14:30
Процедура ПроверкаНаГруппу()
Спр=СоздатьОбъект("Справочник.ТМЦ");
Спр.НайтиПоНаименованию("Разрешённая группа",0);
Родитель=Спр.ТекущийЭлемент();
Если ТМЦ.Родитель<>Родитель Тогда
Сообщить("Выбрали ТМЦ не из той группы");
СтатусВозврата(0);
ТМЦ=ПолучитьПустоеЗначение("Справочник.ТМЦ");
Возврат;
КонецПроцедуры

В поле ТМЦ табличной части документа в формулу ставишь ПроверкаНаГруппу()

Эта процедурка проверяет принадлежит ли выбранный ТМЦ группе "Разрешённые", если нет - то выдаётся сообщение и поле очищается для нового выбора.

Предупреждение - писал навскидку и не проверял на работоспособность, но должно работать.
   kadr
 
6 - 27.08.04 - 14:30
ВыбратьСтроки()
Пока ПолучитьСтроку()=1 Цикл
Если РезвизитТабличнойЧасти.Родитель.Наименование <> "чччч" Тогда
    Сообщить("Не тот");
Иначе
    Сообщить("Тот");
КонецЕсли;
КонецЦикла
   Абрум
7 - 27.08.04 - 14:34
5,6 Спасибо
   427
 
8 - 27.08.04 - 14:34
Элементарно...
   Рупор абсурда
 
9 - 27.08.04 - 14:37
(5) А если ТМЦ.Родитель.Родитель.Родитель=Родитель всё равно нужно упрямо считать, что ТМЦ не в "Разрешённой группе"? ...
(6) Вас тоже касается ...
   Diter
 
10 - 27.08.04 - 14:40
(9) Да нет конечно. В идеале нужно сравнивать полный код (или полное наименование) родителя выбранного элемента и нужной группы. Тогда всё будет ОК.
 
 Рекламное место пустует
   SnarkHunter
 
11 - 27.08.04 - 14:45
В идеале нужно использовать ПринадлежитГруппе
   Diter
 
12 - 27.08.04 - 14:48
(11) Логично, я почему то думал, что ПринадлежитГруппе() можно использовать только для объектов созданных через СоздатьОбъект(). Был неправ оказывается.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует