Вход | Регистрация
 

Добавление в структуру подчиненности нового доокумента

Добавление в структуру подчиненности нового доокумента
Я
   Vvvvv
 
15.03.19 - 09:47
Создал новый документ. К критерии отбора "Связанные документы" в Типе - указал новый документ, в Составе указал по каким реквизитам в документе, документ должен выводиться в структуре подчиненности.

В модуле менеджера добавлена процедура для описания добавляемой команды
Процедура ДобавитьКомандыОтчетов(КомандыОтчетов, Параметры) Экспорт
    
    ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуСтруктураПодчиненности(КомандыОтчетов);
    
    
КонецПроцедуры

В форме списка документа добавил типовые процедуры
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    // СтандартныеПодсистемы.ПодключаемыеКоманды
    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры


// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды


В итоге вместо структуры подчиненности выводиться структура по движениям документам
 
 
   JeHer
 
1 - 15.03.19 - 10:21
(0) >>> указал по каким реквизитам в документе

и по каким же?
   Vvvvv
 
2 - 15.03.19 - 12:39
(1) В новом документе, есть ТЧ Документы поставки - тип документ приходный ордер на склад.
Поставил галку у этого реквизита в составе.
Структуру подчиненности настроил. Раньше уже приходилось настраивать
   Rema Dan
 
3 - 15.03.19 - 13:58
(0) Мало просто добавить процедуру в модуле менеджера. С какой стати БСП должна её дёргать? Для каких объектов применима вся эта подсистема подключаемых команд определяется в общем модуле ВариантыОтчетовПереопределяемый.ОпределитьОбъектыСКомандамиОтчетов(). И возможно, что нужно ещё обновить какую-нибудь внутреннюю кухню БСП через /c ЗапуститьОбновлениеИнформационнойБазы
   Vvvvv
 
4 - 15.03.19 - 17:53
(3) точно, спасибо. Процедура ОпределитьОбъектыСКомандамиОтчетов помогла

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует