Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КД - Заполнить "ВидКонтактнойИнформации" из ТИС в УНФ

КД - Заполнить "ВидКонтактнойИнформации" из ТИС в УНФ
Я
   serg999
 
11.02.19 - 16:09
Доброго всем времени суток.

ТИС 77 (Источник): СправочникСсылка.ЮрЛица
УНФ (Приемник):


Задача принудительно задать в зависимости от условия на стороне приемника значение поле "Вид" (СправочникСсылка.Контрагенты.КонтактнаяИнформация.Вид [тип СправочникСсылка.ВидыКонтактнойИнформации]):
Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Юр. адрес");
Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Факт. адрес");
но не могу сообразить как преобразовать пустое значение в значение справочника.
ПКГС для ТЧ сформировал, "Тип" и "Представление" адреса передал, но там перечисление и строка.

ПКГС_ЮрЛица_КонтактнаяИнформация_ПередОбработкойВыгрузки_8_6
============
ТЗКонтакты = СоздатьОбъект("ТаблицаЗначений");

ТЗКонтакты.НоваяКолонка("Вид");
ТЗКонтакты.НоваяКолонка("Представление");
ТЗКонтакты.НоваяКолонка("Тип");

ТЗКонтакты.НоваяСтрока();
ТЗКонтакты.Представление = Источник.ЮрАдрес;
ТЗКонтакты.Тип = "Адрес";

ТЗКонтакты.НоваяСтрока();
ТЗКонтакты.Представление = Источник.ФактАдрес;
ТЗКонтакты.Тип = "Адрес";

КоллекцияОбъектов = ТЗКонтакты;
==========
Идея была создать событие ПКО, "После загрузки", но тоже не взлетает из-за наличия ТЧ.

Буду признателен за любую помощь.
 
 
   serg999
 
1 - 11.02.19 - 16:35
Сделал через обработку события "ПослеЗагрузки" для ПКО, т.е. при выгрузке задал, а при загрузке поменял.
Может есть более корректный способ ?

=======
Для Каждого Строка Из Объект.КонтактнаяИнформация Цикл 
    
    Если Строка.Вид = "Юр. адрес" Тогда
        Строка.Вид =  Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Юр. адрес");
    КонецЕсли;
    
    Если Строка.Вид = "Факт. адрес" Тогда
        Строка.Вид =  Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Факт. адрес");
    КонецЕсли;
    
КонецЦикла;
=======
   Йохохо
 
2 - 11.02.19 - 16:43
можно сделать то же самое в источнике, передать строку имени, инициализировать входящие данные и из них установить наименование, этогруппа и поля поиска. но зачем, если работает

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует