Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Типовой обмен ЗУП3.1 и БП3.0 (УХ)

Типовой обмен ЗУП3.1 и БП3.0 (УХ)
Я
   dfs495
 
11.02.19 - 10:24
Необходимо настроить обмен чтобы из ЗУП в БП выгружались только один вид документа "Отражения зарплаты в бухучете", сводно по сотрудникам, но и ссылки на справочники (организации, подразделения, способы отражения)

Обмен настроен типовой по двум организациям. Сводно. Правила регистрации поправлены, чтобы выгружались только документы "Отражение зп в бу"
Сопоставление организации и подразделений - произвел при первом обмене.

Но при обмене справочники Организации, подразделения -  перезаписываются.

Например, до обмена в БП было "РОМАШКА ООО" - после стало как в ЗУПе ООО "Ромашка"
Также изменились наименования подразделений.

Как настроить обмен так, чтобы, если есть сопоставленный справочник, то  не перезаписывался в приемнике,  а если справочник новый, тогда создавался?
 
 
   dfs495
 
1 - 11.02.19 - 10:41
   dfs495
 
2 - 11.02.19 - 10:42
скриншот настройки правил регистрации
https://yadi.sk/i/SR_LYPhYEIN2tg
   dfs495
 
3 - 11.02.19 - 12:49
ап
   bolero
 
4 - 11.02.19 - 16:33
Имею вот такой кусок в CommonModules/ОбменДаннымиСобытия, решающий обратную задачу (т.е., всегда принимать обновления):

&Вместо("ПроверитьКоллизиюИзмененийДанных")
Процедура XXX_ПроверитьКоллизиюИзмененийДанных(ЭлементДанных, ПолучениеЭлемента, Знач Отправитель, Знач ЭтоПолучениеОтГлавного)
        Если ТипЗнч(ЭлементДанных) = Тип("СправочникОбъект.Номенклатура") Тогда
                Возврат;
        КонецЕсли;
        ПродолжитьВызов(ЭлементДанных, ПолучениеЭлемента, Отправитель, ЭтоПолучениеОтГлавного);
КонецПроцедуры


Предлагаю копать в эту процедуру.
   dfs495
 
5 - 11.02.19 - 16:38
(4) Спасибо.

Удалось решить через КД

В ПКО в справочниках Организации и ПодразделенияОрганизаций в событие ПослеЗагрузки вставил код:

Если ОбъектНайден Тогда
    Отказ = Истина;
КонецЕсли;

сохранил комплект правил в файл и загрузил через предприятия в нужные конфигурации.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует