Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УФ!!, передать объект в другую форму, и при нажатии на кнопку (клиент) обработать его?

УФ!!, передать объект в другую форму, и при нажатии на кнопку (клиент) обработать его?
Я
   SkillUp
 
11.02.19 - 09:56
Как передать объект в другую форму,и при нажатии на кнопку на другой форме (клиент), обработать его? Делаю так, не знаю насколько это правильно  ,может кто и подскажет как делать:

&НаКлиенте
Процедура Загрузить(Команда)
    
    АдресХранилища = ПоместитьДанныеФормыВХранилище();
    
    Пар = Новый Структура;
    Пар.Вставить("АдресХранилища",АдресХранилища);
    
    ОткрытьФорму("ОбщаяФорма.ЗагрузкаУФ",Пар,ЭтаФорма,,,,Новый ОписаниеОповещения("ОбработкаКомандыЗавершение",ЭтаФорма),РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
    
    
КонецПроцедуры

&НаСервере
Функция ПоместитьДанныеФормыВХранилище()
    
    ДокументОбъект = ДанныеФормыВЗначение(Объект, Тип("ДокументОбъект.ПоступлениеТоваровУслуг"));
    Возврат ПоместитьВоВременноеХранилище(ДокументОбъект, УникальныйИдентификатор);
    
КонецФункции

Тут ошибка: Переданное значение не может быть помещено во временное хранилище ,а как тогда передавать объект в другую форму? Для ее обработки и потом отобразить на клиенте изменения...

В другой форме:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Если Параметры.Свойство("АдресХранилища") тогда
        ДокЗагрузки = ПолучитьИзВременногоХранилища(Параметры.АдресХранилища);

    КонецЕсли;

Есть варианты еще, как в другой форме, обработать объект (документ поступления товаров и услуг) и отобр. изменения? Пардон, за возможно глупый вопрос...
 
 
   МимохожийОднако
 
1 - 11.02.19 - 10:00
Передать ссылку не пробовал?
   RomanYS
 
2 - 11.02.19 - 10:02
Открываемая форма имеет владельцем исходную в твоем случае. Весь контекст доступен (в том числе на изменение) через ВладелецФормы.Объект, ничего передавать дополнительно не надо
   SkillUp
 
3 - 11.02.19 - 10:06
(2) Блин, точно...
   SkillUp
 
4 - 11.02.19 - 10:15
(1) да.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует