Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КД. Выгрузка справочника по параметрам.

КД. Выгрузка справочника по параметрам.
Я
   Полька
 
14.01.19 - 15:38
Делаю правила конвертации для выгрузки из Документооборот 1.3 в Документооборот 2.1
Нужно выгрузить Справочники.ИсходящиеДокументы за январь 2019.
Создала правила обмена данными, объявила Парамеры ДатаНач и ДатаКон.
В правилах выгрузки данных для этого справочника в "Перед выгрузкой" написала
Если Объект.ДатаРегистрации<=Параметры.ДатаНач И Объект.ДатаРегистрации>=Параметры.ДатаКон Тогда
    Отказ=ИСТИНА;
КонецЕсли;    
При выгрузке задаю даты 01.01.2019 и 31.01.2019
Но выгружает почему-то все документы.
 
 
   Ёпрст
 
1 - 14.01.19 - 15:41
В ПВД ? Напиши это в ПКО
   Ёпрст
 
2 - 14.01.19 - 15:41
А ёпт.. условие то ... агонь!
   Ёпрст
 
3 - 14.01.19 - 15:42
оно никогда истинным не будет, если че..
   Ёпрст
 
4 - 14.01.19 - 15:43
ЗЫ: ИЛИ
   OldCondom
 
5 - 14.01.19 - 15:43
+ используй сообщить(), если с отладкой не дружишь. 


Сообщить(Объект.ДатаРегистрации<=Параметры.ДатаНач И Объект.ДатаРегистрации>=Параметры.ДатаКон);

Если Объект.ДатаРегистрации<=Параметры.ДатаНач И Объект.ДатаРегистрации>=Параметры.ДатаКон Тогда
    Отказ=ИСТИНА;
КонецЕсли;
   Полька
 
6 - 14.01.19 - 15:47
(2) ага :)))))))
вот что значит лень :))) скопировала условие и поправила
   Полька
 
7 - 14.01.19 - 16:20
Для другого справочника 
Если Объект.Недействителен=ИСТИНА Тогда
    Отказ=ИСТИНА;
КонецЕсли;    
пишет

    ОписаниеОшибки         =  Значение не является значением объектного типа (Недействителен)
Но такой реквизит у справочника есть, с типом Булево.
   OldCondom
 
8 - 14.01.19 - 16:24
Если Объект.Недействителен=ИСТИНА Тогда
    Отказ=ИСТИНА;
КонецЕсли; 

Можно сократить: Отказ = Объект.Недействителен;
Посмотри, что в переменной Объект лежит. Видимо не справочник.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует