Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Альфа-Авто: сбилась нумерация реализаций

Альфа-Авто: сбилась нумерация реализаций
Я
   Mikhail Volkov
 
13.01.19 - 09:05
С НГ пошла новая нумерация ИП00000001, ИП00000002... ИП00000010, а сегодня возник ИП00001740!? Хотя ИП00001739 от 31.07.2018. Вроде общих нумераторов нет. Куда копать?
 
 
   hhhh
 
1 - 13.01.19 - 09:08
(0) руки у пользователей проверить. Наиболее шаловливые поотрубать.
   Mikhail Volkov
 
2 - 13.01.19 - 09:41
(1) Номера сегодняшних исправил. Создаю новую реализацию, опять ИП00001740 присваивается?
   zak555
 
3 - 13.01.19 - 09:47
Обновить нумерацию
   Mikhail Volkov
 
4 - 13.01.19 - 09:57
(3) Как?
   Mikhail Volkov
 
5 - 13.01.19 - 10:00
Меняю Дату у нового, встает ИП00002018, возвращаю Дату на сегодня - встает ИП00001740?
   ДенисЧ
 
6 - 13.01.19 - 10:00
(4) ОбновитьНумерациюОбъектов() - напиши и Ctrl-f1 нажми на ней
   URAL
 
7 - 13.01.19 - 10:38
+(6) и смотри модули присваивания префиксов, там тоже своеобразно у раруса сделано, по организации, подразделению и т.д...

Функция дкПриУстановкеНовогоНомера(ЭтотОбъект, СтандартнаяОбработка, Префикс) Экспорт
    
    Результат = Истина;
    
    НовыйПрефикс = обПолучитьПрефиксОбъекта(ЭтотОбъект,Префикс);
    Если НовыйПрефикс = Неопределено Тогда
        СтандартнаяОбработка = Ложь;
    Иначе

                Префикс = НовыйПрефикс;

        КонецЕсли;
    КонецЕсли; 
    
    Возврат Результат;
    
КонецФункции// дкПриУстановкеНовогоНомера()


в свое время я обработкой в АА исправлял когда схожая ситуация сложилась и нумерация продолжилась с последнего номера...
   Mikhail Volkov
 
8 - 13.01.19 - 10:39
(6) Куда написать ОбновитьНумерациюОбъектов(), на чем нажать?
   URAL
 
9 - 13.01.19 - 10:40
(8) СП подразумевалось
   URAL
 
10 - 13.01.19 - 10:42
(8) Глобальный контекст (Global context)
ОбновитьНумерациюОбъектов (RefreshObjectsNumbering)
Синтаксис:

ОбновитьНумерациюОбъектов(<Метаданные>)
Параметры:

<Метаданные> (необязательный)

Тип: Массив; ОбъектМетаданных: Куб, ОбъектМетаданных: ТаблицаИзмерения, ОбъектМетаданных: ВнешнийИсточникДанных, ОбъектМетаданных: Поле, ОбъектМетаданных: Таблица, ОбъектМетаданных: HTTPСервис, ОбъектМетаданных: Функция, ОбъектМетаданных: ШаблонURLHTTPСервиса, ОбъектМетаданных: ОпределяемыйТип, ОбъектМетаданных: ПланВидовРасчета, ОбъектМетаданных: ПланСчетов, ОбъектМетаданных: БизнесПроцесс, ОбъектМетаданных: Документ, ОбъектМетаданных: ЖурналДокументов, ОбъектМетаданных: Задача, ОбъектМетаданных: ПланВидовХарактеристик, ОбъектМетаданных: ПланОбмена, ОбъектМетаданных: РегистрБухгалтерии, ОбъектМетаданных: РегистрНакопления, ОбъектМетаданных: РегистрРасчета, ОбъектМетаданных: РегистрСведений, ОбъектМетаданных: Справочник, ОбъектМетаданных: ФункциональнаяОпция, ОбъектМетаданных: ПараметрФункциональныхОпций, ОбъектМетаданных: Команда, ОбъектМетаданных: ГруппаКоманд, ОбъектМетаданных: ХранилищеНастроек, ОбъектМетаданных: ОбщаяКоманда, ОбъектМетаданных: WebСервис, ОбъектМетаданных: WSСсылка, ОбъектМетаданных: Интерфейс, ОбъектМетаданных: Константа, ОбъектМетаданных: КритерийОтбора, ОбъектМетаданных: Нумератор, ОбъектМетаданных: Обработка, ОбъектМетаданных: ОбщаяКартинка, ОбъектМетаданных: Макет, ОбъектМетаданных: ОбщийМодуль, ОбъектМетаданных: Форма , ОбъектМетаданных: Стиль, ОбъектМетаданных: Язык, ОбъектМетаданных: Отчет, ОбъектМетаданных: ПакетXDTO, ОбъектМетаданных: ПараметрСеанса, ОбъектМетаданных: Перечисление, ОбъектМетаданных: ПодпискаНаСобытие, ОбъектМетаданных: Подсистема, ОбъектМетаданных: Последовательность, ОбъектМетаданных: РегламентноеЗадание, ОбъектМетаданных: Роль, ОбъектМетаданных: ЭлементСтиля, ОбъектМетаданных: Графа, ОбъектМетаданных: Измерение, ОбъектМетаданных: ЗначениеПеречисления, ОбъектМетаданных: ОперацияWebСервиса, ОбъектМетаданных: Перерасчет, ОбъектМетаданных: ПараметрWebСервиса, ОбъектМетаданных: ПризнакУчетаПланаСчетов, ОбъектМетаданных: ПризнакУчетаСубконтоПланаСчетов, ОбъектМетаданных: Реквизит, ОбъектМетаданных: ТабличнаяЧасть, ОбъектМетаданных: Ресурс, ОбъектМетаданных: РеквизитАдресации, ОбъектМетаданных: ОбщийРеквизит. 
Объект метаданного или массив объектов метаданных, для объектов которого будет выполнено обновление. Если значение параметра не указано, то обновление будет выполнено для всех типов объектов. 
Описание:

Выполняет обновление номеров в соответствии с номерами, записанными в базе данных. После вызова данного метода все выданные, но незаписанные номера, становятся невалидными т.к. не гарантируется их уникальность. Данный метод разрешено вызывать только администратору системы.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
 
 Рекламное место пустует
   Mikhail Volkov
 
11 - 13.01.19 - 10:42
(7) Что-то в конфигураторе делать, что?
   ДенисЧ
 
12 - 13.01.19 - 10:45
(11) Да, в конфигураторе обработку из одной строчки.
Или взять портативные инструменты разработчика, там есть консоль кода...
   URAL
 
13 - 13.01.19 - 10:51
(11) для начала нужно ОбновитьНумерациюОбъектов
После проверить стоит нумерацию, все ли верно 

рекомендую:
как вариант дополнительно дописать проверку присваивания номера не мешало в ааа 4 на момент присваивания кода т.к. при динамическом обновлении  базы или когда субд логает бывает тоже проблема с нумерацией, не раз исправлял особенно проблема наблюдалась в ааа 4, в ааа 5 был только один случай с этой проблемой, это из опыта
   Mikhail Volkov
 
14 - 13.01.19 - 11:25
(12) Вроде помогло...
   ДенисЧ
 
15 - 13.01.19 - 11:32
(14) Это староновогоднее чудо...
   Mikhail Volkov
 
16 - 13.01.19 - 11:36
Старый Новый год!

Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует