Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Убрать информацию при запуске 1С

Убрать информацию при запуске 1С
Я
   dft2014
 
11.01.19 - 12:33
Добрый день!

Подскажите, как убрать (навсегда) информационную заставку при запуске 1С: https://c.radikal.ru/c10/1901/60/b26a500fac04.jpg

Ниже мой код, но он не помогает:

ДатаВБудущем = ТекущаяДата() + 1000 * 24 * 60 * 60;
ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ИнформацияПриЗапуске", "Показывать", Ложь);
        ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ИнформацияПриЗапуске", "ДатаБлижайшегоПоказа", ДатаВБудущем);
ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
        ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ИнтернетПоддержкаПользователей", "НеНапоминатьОбАвторизацииДо", ДатаВБудущем);
 
 
   RomakON
 
1 - 11.01.19 - 12:35
Убрать галочку "Показывать при начале работы"?
   dft2014
 
2 - 11.01.19 - 12:37
Также пробовала в Модуле управляемого приложения закомментировать строчку, не помогло:


Процедура ПередНачаломРаботыСистемы()
    
    // СтандартныеПодсистемы

    СтандартныеПодсистемыКлиент.ПередНачаломРаботыСистемы();
    // Конец СтандартныеПодсистемы

    
    // ИнтернетПоддержкаПользователей

    //ИнтернетПоддержкаПользователейКлиент.ПередНачаломРаботыСистемы();  //закомментировала

    // Конец ИнтернетПоддержкаПользователей

    
КонецПроцедуры
   Aleksey
 
3 - 11.01.19 - 12:37
   dft2014
 
4 - 11.01.19 - 12:38
(1) Это помогает только на некоторое время. К тому же, в случае подключения через веб-клиент, эта информация - излишняя.
   dft2014
 
5 - 11.01.19 - 12:44
(3) У нас ЗУП3, а обработка для БП от 2015года. Она еще актуальна?!
   Aleksey
 
6 - 11.01.19 - 13:14
(5) ну принцип понятный, там просто при создании этого окна прописан отказ
   Nyoko
 
7 - 11.01.19 - 13:21
найди эту общую форму, при открытии поставь отказ = истина
   Deon
 
8 - 11.01.19 - 13:22
(0) Посмотри, не хранится ли оно для каждого пользователя отдельно, а не общей настройкой
   dft2014
 
9 - 11.01.19 - 13:22
Вобщем, поборола я это в ЗУП3 следующим образом:

ОбщийМодуль.ИнформацияПриЗапуске

// Чтение сохраненного значения флажка "Показывать при начале работы".

Функция ПоказыватьПриНачалеРаботы() Экспорт
    Показывать = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнформацияПриЗапуске", "Показывать", Истина);
    Если Не Показывать Тогда
        ДатаБлижайшегоПоказа = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнформацияПриЗапуске", "ДатаБлижайшегоПоказа");
        Если ДатаБлижайшегоПоказа <> Неопределено
            И ДатаБлижайшегоПоказа > ТекущаяДатаСеанса() Тогда
            Возврат Ложь;
        КонецЕсли;
    КонецЕсли;
//    Возврат Истина;  //- 11.01.19

    Возврат Ложь;    //+ 11.01.19


КонецФункции
   Вафель
 
10 - 11.01.19 - 13:27
и что даже расширение не стала делать?
 
 Рекламное место пустует
   Кир Пластелинин
 
11 - 11.01.19 - 13:28
(9) а почему бы не поставить "Возврат Ложь;" первой строкой в функции?)
   dft2014
 
12 - 11.01.19 - 13:36
(10) Нет, расширения не используем.
(11) Ну вы и педант...
   Кир Пластелинин
 
13 - 11.01.19 - 13:39
(12) педант? в чем?) уж если пошли таким путем, то на кой фиг выполнять код, результат выполнения которого в итоге не влияет ровным счетом ни на что?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует