Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Реквизиты формы - переменная не определена. 1С 8.3

Реквизиты формы - переменная не определена. 1С 8.3
Я
   Geroy
 
10.01.19 - 17:58
Добрый вечер. В чем причина?

Платформа 8.3.13.1513

Управляемое приложение
УТ 11.1.10.153
Режим совместимости Версия 8.3.5
Код работает !!!

Управляемое приложение
УТ 11.4.6.174
Режим совместимости Версия 8.3.12
Код НЕ работает !!!
Ошибка {(1,1)}: Переменная не определена (НашДок)



&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ДопРеквизит = Новый РеквизитФормы("НашДок", Новый ОписаниеТипов("ДокументОбъект.РеализацияТоваровУслуг"));
                                                                  
    ДобавляемыеРеквизиты         = Новый Массив();
    ДобавляемыеРеквизиты.Добавить(ДопРеквизит);
    ЭтотОбъект.ИзменитьРеквизиты(ДобавляемыеРеквизиты);
    
КонецПроцедуры

&НаСервере
Процедура Команда1НаСервере()
    ТабличнаяЧасть = "Товары";
    ЭтотОбъект.ДокОбъект.Товары.Очистить();
    Выполнить("НашДок."+ТабличнаяЧасть+".Очистить()");
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры
 
 
   Geroy
 
1 - 10.01.19 - 18:00
Вот этот код 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ДопРеквизит = Новый РеквизитФормы("НашДок", Новый ОписаниеТипов("ДокументОбъект.РеализацияТоваровУслуг"));
                                                                  
    ДобавляемыеРеквизиты         = Новый Массив();
    ДобавляемыеРеквизиты.Добавить(ДопРеквизит);
    ИзменитьРеквизиты(ДобавляемыеРеквизиты);
    
КонецПроцедуры

&НаСервере
Процедура Команда1НаСервере()
    ТабличнаяЧасть = "Товары";
    Выполнить("НашДок."+ТабличнаяЧасть+".Очистить()");
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры
   singlych
 
2 - 10.01.19 - 18:02
Он не знает, что ты ему в контекст добавил НашДок. Пиши
Выполнить("ЭтотОбъект.НашДок...
   Geroy
 
3 - 10.01.19 - 21:28
(2) Спасибо, всё хожу вокруг да около

Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует