Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: ВводНового - Копирование

v7: ВводНового - Копирование
Я
   progaoff
 
10.01.19 - 15:54
Процедура ВводНового(Копирование)
    глЗаполнитьШапку(Контекст,Копирование);
    Если Копирование = 1 Тогда
        Сумма = Цена * Количество;глРасчетНалога(Контекст);
        
    НовДок = 1;
    Форма.ДопРасход.Доступность(0);
    Если Копирование = 0 Тогда
        СрокРезервирования = Константа.ОсновнойСрокРезервирования;
        СрокОплаты = СрокРезервирования;
    КонецЕсли;
    Стадия = 0;ВалютаБанковскогоСчета();
    Если Копирование = 1 Тогда
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
            Если ПустоеЗначение(Дефицит) = 0 Тогда
                Дефицит = 0;
            КонецЕсли;    
        КонецЦикла;    
    КонецЕсли;
КонецЕсли;    
КонецПроцедуры// ВводНового()

Делаю элементарное копирование документа, Если Копирование = 1 Тогда
        Сумма = Цена * Количество;глРасчетНалога(Контекст);
Хочу что бы пересчитало налог. в Итоге цена и количество = 0, что не так делаю?
 
 
   uno-group
 
1 - 10.01.19 - 16:00
ВыбратСтроку()
Пока получитьстроку()=1 Цикл
   progaoff
 
2 - 10.01.19 - 16:05
(1) ПриБольшое СПАСИБО)
   Mikeware
 
3 - 10.01.19 - 16:29
жесть.
а зачем в ветке Если Копирование=1 проверки Кси Копирование=0 и Если Копирование=1 ?
   skafandr
 
4 - 10.01.19 - 16:36
(0)
а  Сумма  Цена и Количество точно не в табличной части?
   Злопчинский
 
5 - 10.01.19 - 18:09
в типовой глЗаполнитьШапку второй параметр вообще не имеет отношения к копированию и голосувать туда Копирование смыслп нет..
?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует