Вход | Регистрация


Как данные из запроса вывести в строку?

Как данные из запроса вывести в строку?
Я
   dos
 
09.01.19 - 14:47
Добрый день, помогите плиз начинающиму. Есть запрос, как вывести все данные в строку через запятую.

 запрос = Новый Запрос;
     Запрос.Текст = "ВЫБРАТЬ
                    |    ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления.Сотрудник,
                    |    ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления.ДатаВыхода КАК Начисление
                    |ИЗ
                    |    Документ.ОплатаПраздничныхИВыходныхДнейОрганизаций.Начисления КАК ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления
                    |ГДЕ
                    |    ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления.Ссылка = &Ссылка" ;
     
     Запрос.УстановитьПараметр ("Ссылка", СсылкаНаОбъект);
     Выборка = Запрос.Выполнить().Выбрать ();
 
 
   FIXXXL
 
1 - 09.01.19 - 15:06
(0) Пока Выборка.Следующий() Цикл
///тут собираешь свою строку

КонецЦикла;
   dos
 
2 - 09.01.19 - 15:09
Да это я в курсе, но выводится только первое значение и все. А надо все значения вывести и в строку.
   FIXXXL
 
3 - 09.01.19 - 15:12
(2) показывай код, если ты в курсе
   dos
 
4 - 09.01.19 - 15:17
Функция Печать () Экспорт
    ТабДок = новый ТабличныйДокумент;
    Макет = ПолучитьМакет ("ПриказОРаботеВВыходные");
      Док = Макет.ПолучитьОбласть("Строка");
    ОбластьШапки   = Макет.ПолучитьОбласть("ШапкаДокумента");
    ОбластьДанные  = Макет.ПолучитьОбласть("Строка");
    ОбластьПодвал  = Макет.ПолучитьОбласть("Подвал");
    
    
    ОбластьШапки.Параметры.НазваниеОрганизации = СсылкаНаОбъект.Организация;
    ОбластьШапки.Параметры.ИНН       = СсылкаНаОбъект.Организация.ИНН;
    ОбластьШапки.Параметры.КПП       = СсылкаНаОбъект.Организация.КПП;
    ОбластьШапки.Параметры.ДатаДок   = СсылкаНаОбъект.Дата;
    ОбластьШапки.Параметры.НомерДок  = "Приказ №"+ " " + СсылкаНаОбъект.Номер;
    ТабДок.Вывести(ОбластьШапки);
    
    
    //ОбластьДанные.Параметры.Сотрудник = "В связи с тем, что командировка "+ " " + СсылкаНаОбъект.Ответственный;

    ОбластьДанные.Параметры.НомерДок = "в соответствии с приказом № " + " " + СсылкаНаОбъект.Номер;
    ОбластьДанные.Параметры.ДатаДок = " от " + " " + Формат (СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy")+ "г.";
    //ОбластьДанные.Параметры.Начисление = " приходится на выходные дни " + " ";

     запрос = Новый Запрос;
     Запрос.Текст = "ВЫБРАТЬ
                    |    ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления.Сотрудник,
                    |    ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления.ДатаВыхода КАК Начисление
                    |ИЗ
                    |    Документ.ОплатаПраздничныхИВыходныхДнейОрганизаций.Начисления КАК ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления
                    |ГДЕ
                    |    ОплатаПраздничныхИВыходныхДнейОрганизацийНачисления.Ссылка = &Ссылка" ;
     
     Запрос.УстановитьПараметр ("Ссылка", СсылкаНаОбъект);
     Выборка = Запрос.Выполнить().Выбрать ();
     
          Пока выборка.Следующий()Цикл
        //ОбластьДанные.Параметры.Заполнить(Выборка);

         
         ОбластьДанные.Параметры.Начисление = " приходится на выходные дни " + " " + Формат (Выборка.Начисление, "ДФ=dd.MM.yyyy");
         ОбластьДанные.Параметры.Сотрудник = "В связи с тем, что командировка "+ " " +  Выборка.Сотрудник;
         
         
         ТабДок.Вывести(ОбластьДанные);

     КонецЦикла;
     
     
     
     
    
    
    

             ТабДок.Вывести(Областьданные);
         Возврат ТабДок;
    
    
КонецФункции
   FIXXXL
 
5 - 09.01.19 - 15:28
(4) и где тут "вывести все данные в строку через запятую"?
   FIXXXL
 
6 - 09.01.19 - 15:30
(5) + тебе по ходу надо макет изменить под это дело...

Список тем форума
Рекламное место пустует  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует