Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Подключение сканера ШК к новому документу, не попадаю в событие :(

Подключение сканера ШК к новому документу, не попадаю в событие :(
Я
   АндрейRU
 
07.01.19 - 13:16
Создал новый документ в УТ, 
в форме, модуле документа прописал процедуру:
ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

Но при считывании ШК со сканера не попадаю в неё (Сканер USB эмулятор клавиатуры). Происходит просто ввод ШК в поле как с клавиатуры.

Если параллельно открыть документ в котором есть ввод со сканера, например РМК, то сканер активируется,
и при считывании ШК в моем документе происходит событие ОбработкаОповещения и я попадаю в свою процедуру...
т.е. видимо нужно как то активировать сканер при открытии моего документа ? но как ?

И попутно второй вопрос, На моем документе новом, есть только одно поле для ввода номенклатуры - к нему бы и хотелось подключить только обработчик событий со сканера.., возможно такое ?
 
 
   oslokot
 
1 - 07.01.19 - 13:42
В событиях при открытии и закрытии нужно подключать и отключать оборудование.
Посмотри как сделано в типовом документе, например заказ клиента
   Случайный прохожий
 
2 - 07.01.19 - 13:49
Могу ошибаться, давно со сканерами работал, но насколько помню ШК передавался через процедуру "ОбработкаВнешнегоСобытия". Но оборудование все-равно подключить нужно.
   roman844
 
3 - 07.01.19 - 13:54
Добрый день. Всех с праздниками. ТС, (2) правильно говорит
   АндрейRU
 
4 - 07.01.19 - 14:45
(1) ага, спасибо, разобрался. заказ клиента - в нем посмотрел.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ОбщегоНазначенияУТ.НастроитьПодключаемоеОборудование(ЭтаФорма);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПриОткрытииФормы(Неопределено, ЭтаФорма, "СканерШтрихкода");
КонецПроцедуры

&НаКлиенте
Процедура ПриЗакрытии()
    МенеджерОборудованияКлиент.НачатьОтключениеОборудованиеПриЗакрытииФормы(Неопределено, ЭтаФорма);
КонецПроцедуры
   Chameleon1980
 
5 - 07.01.19 - 14:45
в форме, модуле документа прописал процедуру:
ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

а в события добавил?
   АндрейRU
 
6 - 07.01.19 - 14:47
(2) (3) событие всё таки ОбработкаОповещения происходит.
   АндрейRU
 
7 - 07.01.19 - 14:47
(5) да, конечно
   АндрейRU
 
8 - 07.01.19 - 14:49
Второй вопрос остался, как сделать, чтобы сканер подключался только при выборе одного определенного поля?
а не при открытии всей формы, т.е. если сканер будет включен всегда при открытой форме, это будет мешать, т.к. он используется для других целей,
а нужен только при выборе определенного поля, что бы найти товар в базе.
   АндрейRU
 
9 - 07.01.19 - 14:52
Запутанно наверное описал...
Нужно в документе что бы сканером можно было найти товар, только когда выбрано полле с товаром.
При выборе других полей он работает просто как ввод с клавиатуры, типа ввод партии и т.д. другой текстовой информации
   Chameleon1980
 
10 - 07.01.19 - 14:55
события элеметов форм кури
 
 Рекламное место пустует
   Chameleon1980
 
11 - 07.01.19 - 14:56
хотя не
   Chameleon1980
 
12 - 07.01.19 - 14:57
...Нужно в документе что бы сканером можно было найти товар, только когда выбрано полле с товаром....
элемент формы какой?
формы у/о ?
   АндрейRU
 
13 - 07.01.19 - 15:31
(12) думаю просто в обработчик ОбработкаОповещения
нужно определить какой активный элемент формы.., и далее уже решить что и как с штрихкодом делать..
   АндрейRU
 
14 - 07.01.19 - 15:36
Всем спасибо, вопрос закрыт.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует