Вход | Регистрация



ТиС 7.7. НДС 20%. Новый релиз

ТиС 7.7. НДС 20%. Новый релиз
Я
   es3000
 
29.12.18 - 13:27
База работает на типовой конфигурации "Торговля и склад".

Надеялись, что 1С реализует какие-то доработки в связи с введением новой ставки.
Оказалось, что в последнем релизе 1С сделала доработку, но какую-то совсем простую.
Добавлена обработка, которая по указанной номенклатуре заменит ставку НДС на НДС 20%.

Но мне кажется это неправильно.
Ведь могут выписывать документы как декабрем старого года так и нового года.
То есть ставка должна быть привязана к дате, она должна быть сделана периодическим реквизитом.
А если мы заменим этой 1С-ной обработкой ставку, то всё...

Почему 1С это не учла?
И что теперь делать? Самому в новогоднюю ночь переделывать?
Или я что там неправильно понимаю?
 
 
   VladZ
 
1 - 29.12.18 - 13:28
Ты не поверишь, в  УТ10 такая же фигня.
   VladZ
 
2 - 29.12.18 - 13:29
Видимо, общий смысл такой: вот вам инструмент замены. А у каких номенклатурных позиций вы будете менять ставку - это вам решать.
   hhhh
 
3 - 29.12.18 - 13:38
(0) там сделана привязка. типа если дата меньше 1 января, то ставка 18%
   HawkEye
 
4 - 29.12.18 - 13:38
(0) нет смысла делать ставку у товара периодической... ставку надо делать в виде перечисления основная/льготная...
а писать глобальную функцию которая в зависимости от даты, типа ставки и др. параметров - возвращать правильную ставку.
   lucbak
 
5 - 29.12.18 - 13:38
(0) Если, что то не устраивает - сделай это сам. Делать реквизит периодическим из-за того, что некоторые ... выписывают реализацию (задним число) верх глупости. Работаешь задним числом - просто обязан мучаться.
   lucbak
 
6 - 29.12.18 - 13:40
Вообще - это ставка "по умолчанию", ну установилась 18 пойди да замени на 20
 совсем обленились
   Масянька
 
7 - 29.12.18 - 14:01
(0) А больше ничего не надо.
В номенклатуре заменили и готово.
Выписку задним числом документов не реализовали нигде. И это правильно. Мы живем в настоящем. А прошлое, а тем более будущее, не редактируется.
И по коду проверь - там не много мест (где 18% фигурирует), но есть.
В общем, работай - до Нового года еще 2 (два) дня.
   Aleksey
 
8 - 29.12.18 - 14:04
(7) Почему? В БП реализовано
   es3000
 
9 - 29.12.18 - 14:09
(3) >> там сделана привязка. типа если дата меньше 1 января, то ставка 18%

нету там такой привязки
   Масянька
 
10 - 29.12.18 - 14:09
(8) Не начинай.
Так, как в БП, она реализована везде. А так, как хочет ТС - только золотой шар может.
 
 Рекламное место пустует
   es3000
 
11 - 29.12.18 - 14:11
(5) >> некоторые ... выписывают реализацию (задним число) верх глупости. Работаешь задним числом - просто обязан мучаться.

А если нужно будущим числом.
У нас есть постоянные покупатели, большие накладные.
И эти накладные набивают заранее.
   es3000
 
12 - 29.12.18 - 14:11
(9) >> Вообще - это ставка "по умолчанию", ну установилась 18 пойди да замени на 20

Где заменить?
   Масянька
 
13 - 29.12.18 - 14:13
(12) Чего?! С такой полоской...
Правду говорят - размер не имеет значения.
   Кац
 
14 - 29.12.18 - 14:14
Поделитесь пожалуйста обработочкой из ТиС по замене ставки
   es3000
 
15 - 29.12.18 - 14:15
(10) >> только золотой шар может.
Что такое "золотой шар"?

(12) Да, занимаюсь давно.
Но глубоко некоторых моментов не знаю. Так уж сложилось.
Что-то знаю лучше, что то хуже.
Больше как кодер, а не методист.
   es3000
 
16 - 29.12.18 - 14:16
(14) последний типовой релиз скачать можешь?
   Масянька
 
17 - 29.12.18 - 14:17
(15) 1. "Счастья всем даром и пусть никто не уйдет обиженным" (С)
2. Настройки пользователя.
   Кац
 
18 - 29.12.18 - 14:17
(16) не могу, если только качать из известных источников, но там долго
   es3000
 
19 - 29.12.18 - 14:19
(17) в ТиС-е нету настроек пользователя
   Масянька
 
20 - 29.12.18 - 14:20
(18) Там несколько строчек.
    Спр = СоздатьОбъект("Справочник.Номенклатура");
    Спр.ПорядокКодов();
    
    Спр.ВыбратьЭлементы(0);
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        Если (ФлажокТекСтавкаНДС = 1) Тогда
            Если (Спр.СтавкаНДС.ПорядковыйНомер() = ТекСтавкаНДС.ПорядковыйНомер()) Тогда
                Меняем = 1;
            Иначе
                Меняем = 0;
            КонецЕсли;
        КонецЕсли;
        Если (Меняем = 1) Тогда
            Спр.СтавкаНДС = СтавкаНДС;
            Спр.Записать();
            Состояние("Обрабатана запись справочника ""Номенклатура"" с кодом " + Строковые.стрУдалениеВедущихНулей(Спр.Код));
        КонецЕсли;
    КонецЦикла;
Я писала под себя, думаю - разберешься.
   Кац
 
21 - 29.12.18 - 14:20
(19) есть - пользователи - знач по умолчанию
   Масянька
 
22 - 29.12.18 - 14:21
(19) А если найду?
   es3000
 
23 - 29.12.18 - 14:22
   Кац
 
24 - 29.12.18 - 14:22
(20) спасибо, мне с отборами надо всякими. та обработка из тис-а с отборами же?
   es3000
 
25 - 29.12.18 - 14:22
(21), (22)
нашел, спасибо
   Масянька
 
26 - 29.12.18 - 14:22
(24) Понятия не имею.
Свою - не обновляю.
   Кац
 
27 - 29.12.18 - 14:22
(23) большое спасибо!
   es3000
 
28 - 29.12.18 - 14:24
(24) >> обработка из тис-а с отборами же?

отбор по конкретной номенклатуре или по группе или по всем сразу
   Кац
 
29 - 29.12.18 - 14:24
(23) упс, это установщик, а он на 10 винде не запускается)
может md-шник закините?
   Масянька
 
30 - 29.12.18 - 14:24
(29) Короче, сдавайся :)))))))))))))))))
   es3000
 
31 - 29.12.18 - 14:25
(10) >> Так, как в БП, она реализована везде

В БП этот реквизит вроде как периодический.
Где еще так реализовано?
   es3000
 
32 - 29.12.18 - 14:26
   Кац
 
33 - 29.12.18 - 14:28
(32) благодарю!
 
 
   Кац
 
34 - 29.12.18 - 14:33
(30) Кац не сдается, а предлагает)
(32) Ок, нормальная простая обработка с отбором по группе и в транзакции

Сегодня вечерком пройдусь ей по базе)
   Aleksey
 
35 - 29.12.18 - 14:44
(10) Что именно не начинать?
В БП реализовано что при выписки старых доков задним числом будет подставятся 18%, а если дата в 2019 году и старше - 20%
Разве не этого хочет ТС?
   Владимир1С
 
36 - 29.12.18 - 15:19
(32) Большое спасибо!
   NorthWind
 
37 - 29.12.18 - 15:24
(0) зачем? Вы не поверите, но ставка еще задается в документах. Можно бухам в переходный период включить голову и проставлять ставку 18% при вводе оставшихся поступающих доков 18 года, а спустя месяцок все это забудется как страшный сон и будут все пользоваться ставкой 20%.
   es3000
 
38 - 29.12.18 - 16:19
(35) Да, этого хочу
   es3000
 
39 - 29.12.18 - 16:21
(37) >> Вы не поверите, но ставка еще задается в документах

Вот если бы в вашем ответе не было сарказма "Вы не поверите", то был бы вообще отличный ответ!
Но все-равно спасибо.
   hhhh
 
40 - 29.12.18 - 16:22
ждем новый релиз тогда. Релиз Новогодний.
   Хряк
 
41 - 29.12.18 - 16:28
В процедуре глПересчетТаблЧасти(
поправь немного

пСтавка=Номенклатура.СтавкаНДС;
Если Конт.ДатаДок<"01.01.19" Тогда
   Если пСтавка=Перечисления.СтавкиНДС.НДС20 Тогда
        пСтавка=Перечисления.СтавкиНДС.НДС18;
   КонецЕсли;
Иначе
   Если пСтавка=Перечисления.СтавкиНДС.НДС18 Тогда
        пСтавка=Перечисления.СтавкиНДС.НДС20;
   КонецЕсли;
КонецЕсли;
Если ЕстьНДС = 1 Тогда
    //Конт.СтавкаНДС = Номенклатура.СтавкаНДС;        

    Конт.СтавкаНДС     = пСтавка;        
КонецЕсли;
   es3000
 
42 - 29.12.18 - 17:11
(41) спасибо
   Гад
 
43 - 29.12.18 - 18:25
Деньги уплочены? Ну и идите нак
   Builder
 
44 - 29.12.18 - 18:30
(41) Еще вариант, функция в ГМ и ну и сделать ее вызовы.

Функция глПолучитьСтавкуНДС(ВыбДатаДОк,Номенклатура) Экспорт
    
    Если ВыбДатаДОк>=Дата("01.01.2019") Тогда
        Если Номенклатура.СтавкаНДС = Перечисление.СтавкиНДС.НДС18 Тогда
            // меняем на 20 

            СтавкаНДС     = Перечисление.СтавкиНДС.НДС20;        
        Иначе
            СтавкаНДС     = Номенклатура.СтавкаНДС;        
        КонецЕсли;
    Иначе    
        Если Номенклатура.СтавкаНДС = Перечисление.СтавкиНДС.НДС20 Тогда
            // меняем на 18 

            СтавкаНДС     = Перечисление.СтавкиНДС.НДС18;        
        Иначе
            СтавкаНДС     = Номенклатура.СтавкаНДС;        
        КонецЕсли;
    КонецЕсли;
    Возврат СтавкаНДС;
КонецФункции//глПолучитьСтавкуНДС
   Builder
 
45 - 29.12.18 - 18:32
Есть у меня клиенты на Бух 7.7, вот там все проще - реквизит СтавкаНДС у номенклатуры периодический :)
   GreyK
 
46 - 29.12.18 - 19:49
(45) И клиенты умеют менять "Рабочую дату"!?
   Злопчинский
 
47 - 29.12.18 - 20:20
(0) нет, ты не правильно мыслишь. все что в тис надо - это внести ставку 20% в перечень и заменить в картчоке.
картчки номенклатуры являются СПРАВОЧНИВМИ ДАННЫМИ для заполнения документов. актуальные значения указываются в самих документах. Все состальыне "приязки чегото в справочниках к датам" сделаны (если сделаны) исключительно для удобства работы.
.
и не..уй в январе вносить документы декабря. таковых документов-то если и будет - пару штук. х..н не сломают перевыберут ставку вручную или "Действия\" - изменить спецификацию документа - задать ставку НДС.

у меня в январе декабрьские документы моджет какие и будут типа возврат от покпателя 1-2, да и то сомнительно.
   Злопчинский
 
48 - 29.12.18 - 20:23
(11) "У нас есть постоянные покупатели, большие накладные.
И эти накладные набивают заранее."
- полный е..ий бред. накладные выписываются в момент или накануне отгрузки. для всех остальных действий вполне подходит заявка покупателя. Использование реализаций может быть оправдано если надо сделать резервирование по партиям. да и то если подумать посильнее можно шттано сделать два независимых контура реализаций - одни для резервирования ТЕКУЩИМ чичлом, вторые - по белому для отгрузки.
   HawkEye
 
49 - 29.12.18 - 20:44
(44) возврат товара в 2019 купленного в 2018 должен быть по ставке 18%..
 
 Рекламное место пустует
   Злопчинский
 
50 - 29.12.18 - 21:03
(49) это если настоящий возврат. а с этим - есть заморочки. именно с НПА. а если возврат как частенько "обратная реализация" - то никаких проблем...
   HawkEye
 
51 - 29.12.18 - 21:47
(50) так я же и написал "возврат", а не обратная реализация )))
   Злопчинский
 
52 - 29.12.18 - 21:57
и в чем проблема тогда? там имхо вообще се что надо - правильно заполнить документ, указав суммы ндс и ставка 18%
   hhhh
 
53 - 29.12.18 - 22:00
(52) возврата теперь не бывает с 01.01.19. Теперь этот документ называется Корректировка реализации.
   Злопчинский
 
54 - 29.12.18 - 23:34
(53) в базе это может называться как угодно. навскидку (могу ошибаться) я не знаю в НК/бухучете такого понятия, которое обуславливает "корректировку реализации"
   Злопчинский
 
55 - 29.12.18 - 23:34
(53) "возврата теперь не бывает с 01.01.19." - и где это написано и кто это придумал?
   Aleksey
 
56 - 29.12.18 - 23:59
(55) налоговая в своих рекомендациях
   Aleksey
 
57 - 30.12.18 - 00:18
(55)
С 1 января 2019 года будет введен один универсальный и упрощенный способ применения НДС при возврате товаров. Его суть в следующем: при возврате товаров (независимо от того, является или не является покупатель плательщиком НДС, принял или не принял он на учет товары, возвращена им вся партия или часть товаров) продавец во всех случаях выставляет корректировочный счет-фактуру с указанием налоговой ставки, которая действовала при отгрузке товаров, и регистрирует его в своей книге покупок.

Соответствующие изменения будут внесены в постановление Правительства от 26.12.2011 № 1137,

http://nalogkodeks.ru/primenenie-stavki-nds-pri-vozvrate-tovara-priobretennogo-v-2018-godu/
   zak555
 
58 - 30.12.18 - 00:38
(57) и упрощенцу надо поди декларацию предоставить ?
   Злопчинский
 
59 - 30.12.18 - 00:47
(57) здесь речь о корректировочных СЧФ. какое отношение это имеет к документу, которым будет оформлены не налогове операции, связанные с НДС, а торговые операции? если документ в базе "возврат от покупателя" или документ "корректировка реализации" формируют бух/проводки/движения, соответствующие потребнеостям учета - то мне пофиг как это называется. а для налогвой оформим как надо именно корректировокой налоговых регистров/счф.
   Aleksey
 
60 - 30.12.18 - 03:39
(59) так (53) и говорит о налоговых документа. Что хотят вести норму согласно которому любой возврат должен отражаться документально продавцом через корректировочную фактуру. В независимости что это за возврат, недопоставка или возврат брака/обратная реализация
   Злопчинский
 
61 - 30.12.18 - 06:03
(60) вот насчет "обратной реализации" - есть большие вопросы.
что такое "обратная реализация"? это когда у покупателя нет формальных оснований для возврата. Но товар он вернуть хочет. Два выхода - либо "мошененичаем" и говорим про некачественный и прочее - то есть искуственно создаем условия для обосновнанного _возврата_ либо - если в качестве постановки задачи принять что на такое "мошенничество" мы не идем и

а) - в договоре нет условий про возврат полностью беспроблеимных поставок или их частей - выход один "обратная реализация" (но такого термина НК вроде не знает" - поэтому договор на поставку от покпателя (=нам поставщик) нам, поставщику (=мы покупатель) - то есть обычная поставка межу двумя клиентами с последующим взаимозачетом

или

б) - в договоре есть условие о возможности возврата полностью беспроблемных поставок - тут что делаем? есть у меня сомненяи что налоговая будет хорошо смотреть на такие возвраты - и как их оформлять коректировочными СЧФ (а по бух - сторно? или как) или тоже "обратной реализацией"..?

както вот чтото такое
   hhhh
 
62 - 30.12.18 - 06:59
(61) наоборот, по бух конкретно корректировочными сф. А по тис похрен чем.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует