Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как сравнить 2 массива с условием?

Как сравнить 2 массива с условием?
Я
   Viktoria97
 
28.12.18 - 17:46
Всем привет)
Имеются 2 массива с одинаковым количеством столбцов. Один из столбцов во втором массиве должен быть пустым. А все остальные столбцы в двух массивах должны совпадать. Если эти условия проходят тогда объединить 2 массива в один, если нет значит нет.
Как такое можно провернуть?
 
 
   lodger
 
1 - 28.12.18 - 17:47
откуда в массиве столбцы?
   Ёпрст
 
2 - 28.12.18 - 17:47
у массива нет столбцов
   Вафель
 
3 - 28.12.18 - 17:48
merge join
   IOANNscrp
 
4 - 28.12.18 - 17:48
Массив из структур видимо
   Viktoria97
 
5 - 28.12.18 - 17:53
   lodger
 
6 - 28.12.18 - 17:55
(0) сравниваем количество имена и типы "столбцов" значит? неважно сколько строк и какие данные в них?
   lodger
 
7 - 28.12.18 - 17:57
если бы это была таблица значений, то у тебя была бы коллекция "колонки".
а так... ну погляди в отладчике какие реквизиты и коллекции есть
   Ёпрст
 
8 - 28.12.18 - 18:06
(5) таблицу значений обозвать массивом - оригинально
   Garykom
 
9 - 28.12.18 - 18:07
(0) Я реально не понимаю что вы написали.

>Имеются 2 массива с одинаковым количеством столбцов.
1 столбец может быть? а 10001 столбец? А 9999999999999999991 столбец?

>Один из столбцов во втором массиве должен быть пустым.
Почему один и он всегда один или может быть любой пустым или у меня уже крыша едет причем тут "должен" кому и сколько он должен?

>А все остальные столбцы в двух массивах должны совпадать.
Что с чем совпадать? Совпадать по строкам или целиком. Совпадать внутри одного массива или между разными массивами? Переставлять столбцы местами можно/нужно чтобы "совпадали"?

>Если эти условия проходят тогда объединить 2 массива в один, если нет значит нет.
А теперь самое важное!
Что нахрен значит "объединить"?
Чего с чем и каким образом? Приставить второй массив справа или снизу или сложить/свернуть или что сделать то хотите??????


>Как такое можно провернуть?
Нанять программиста
   IOANNscrp
 
10 - 28.12.18 - 18:17
(9) с последнего в голос
 
 Рекламное место пустует
   exwill
 
11 - 28.12.18 - 19:06
(9) Это загадка. Не кричи ты так.
   lodger
 
12 - 29.12.18 - 10:36
(11) еще и новогодняя!
   Скиурус
 
13 - 29.12.18 - 11:01
й = 0;
Для й = 0 По Массив1.Количество() - 1 Цикл
 Для Каждого Эл Из Массив1[й] Цикл
  Если Эл.Значение <> Массив2[й][Эл.Ключ] Или (Эл.Ключ = "Поле, которое должно быть пустым" И ЗначениеЗаполнено(Массив2[й][Эл.Ключ]) Тогда
   Возврат "Массивы не равны";
  КонецЕсли;
 КонецЦикла;
КонецЦикла;

Возврат "Массивы равны";
   IOANNscrp
 
14 - 29.12.18 - 11:04
(13) халтурите, а объединение, если они равны
   Скиурус
 
15 - 29.12.18 - 11:05
(14) Удочку даю же :)

Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует