Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как одолеть трудность заполнения ТЧ дока в сложных доках?

Как одолеть трудность заполнения ТЧ дока в сложных доках?
Я
   Обработка
 
28.12.18 - 09:27
У меня КА2 каз.

Дали задание доработать.
Заполняю ТЧ дока План закупок.
Оказалось не отражается в ТЧ но в объекте данные есть.
Выяснил что там внутри как-то связано с таблицей значений и как то там через кросстабалицу.

Ни как не могу понять.

Кто осилил такие вещи помогите.
 
 
   dka80
 
1 - 28.12.18 - 09:29
Если обработка заполнения табличных частей, то на форме иногда показывается не табличная часть, а таблица значений. Чтобы она корректно отобразилась, после заполнения табличной части нужно вызвать какой-то встроенный метод документа по обновлению этой таблицы значений
   Обработка
 
2 - 28.12.18 - 09:32
(1) На форме таблиц связан с Объект.Товары
Но отображение все равно нет.
Оказалось он связан ТЗ = ТоварыПоПериодам

Сдал так:
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СтрокаДока = Объект.Товары.Добавить();
        СтрокаДока.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
        СтрокаДока.Упаковка     = ВыборкаДетальныеЗаписи.Номенклатура.ЕдиницаИзмерения;
        СтрокаДока.Количество   = ВыборкаДетальныеЗаписи.Коэффициент * ВыборкаДетальныеЗаписи.ПериодичностьЗамены;
        СтрокаДока.Сумма = ВыборкаДетальныеЗаписи.Цена * СтрокаДока.Количество;
        
        ст = ТоварыПоПериодам.Добавить();
        ЗаполнитьЗначенияСвойств(ст,СтрокаДока);
        ст.Упаковка = СтрокаДока.Упаковка;
        ст.Количество = СтрокаДока.Количество;
        ст.Сумма = СтрокаДока.Сумма;
    КонецЦикла;


Все равно строка оявилась но тольок номенклатура! (((
   IOANNscrp
 
3 - 28.12.18 - 09:35
На часики в конфигураторе, затем открываешь форму, возвращаешься в конфигуратор снова на часики и ищешь обращение/заполнение к элементу ТоварыПоПериодам, где-то должен быть вызов обновление данных из объект товары в ТоварыПоПериодам.
Либо попробовать ТоварыПоПериодам.СоздатьКолонки(), после заполнения.
   Обработка
 
4 - 28.12.18 - 10:57
ппока ничего  не дало
   Вафель
 
5 - 28.12.18 - 11:00
запиши новый документи и посмотри что в тз и чего нет у тебя
   shuhard
 
6 - 28.12.18 - 11:05
(0)[Выяснил что там внутри как-то связано с таблицей значений и как то там через кросстабалицу. ]
иди в дворники, метлой махать
   Обработка
 
7 - 28.12.18 - 11:08
(6) А ты хоть видел что муть в этих доках?
Может глянешь у меня через тимвью и потом уже сам подумаешь в дворники нам вдвоем или нет:
Черт ногу сломит.

И зачем такой огород городить типовикам?
   Вафель
 
8 - 28.12.18 - 11:09
(7) сколько платишь?
   Обработка
 
9 - 28.12.18 - 11:11
(8) 1 тыс руб закину тебе на карту или переводом из казахстана если найдешь сделаешь
   Вафель
 
10 - 28.12.18 - 11:20
(9) стукнись на почту
 
 Рекламное место пустует
   DexterMorgan
 
11 - 28.12.18 - 11:23
(0) Думается там красно-синим по белому все написано, тебе не стыдно такие вопросы задавать?
   runoff_runoff
 
12 - 28.12.18 - 11:25
(3) нет такого метода СоздатьКолонки()
   DexterMorgan
 
13 - 28.12.18 - 11:32
Под рукой ток УТ11.1, но думаю что там тоже самое: в ОбработкеВыбора:

Если ИсточникВыбора.ИмяФормы = "Обработка.ЗагрузкаДанныхИзВнешнихФайлов.Форма.ФормаДляПланов" Тогда
        
Если ВыбранноеЗначение.ОбновитьДополнить = 0 Тогда
        
 ТоварыПоПериодам.Очистить();
 Объект.Товары.Очистить();
        
КонецЕсли; 
        ПолучитьЗагруженныеТоварыИзХранилища(ВыбранноеЗначение.АдресТоваровВХранилище, КэшированныеЗначения);

КонецЕсли;
   DexterMorgan
 
14 - 28.12.18 - 11:32
Все заполнение прописано в "ПолучитьЗагруженныеТоварыИзХранилища", ищется меньше чем за минуту
   ptiz
 
15 - 28.12.18 - 11:41
(2) "На форме таблиц связан с Объект.Товары
Но отображение все равно нет.
Оказалось он связан ТЗ = ТоварыПоПериодам"

Что за поток слов?
В форме две элемента-группы: ГруппаТоварыТаблица и ГруппаТоварыКроссТаблица.
На первой - Товары, на второй - ТоварыПоПериодам. Показывается первая или вторая в зависимости от Объект.КроссТаблица.
   Мелифаро
 
16 - 28.12.18 - 11:51
Не дали человеку бабла подзаработать :)
   Обработка
 
17 - 28.12.18 - 11:55
Уже нашел в чем трабла.

не указвал период.
   DexterMorgan
 
18 - 28.12.18 - 12:05
(17) Прежде чем писать свой велосипед, посмотри как в типовой делают. Я думают ты много чего еще не сделал, по типу:

ЗаполнитьСлужебныеРеквизитыПоНоменклатуреВКоллекции();
ОбновитьСвязанныеРеквизитыОбъекта(Объект, ЭтаФорма);
РассчитатьИтоговыеПоказатели(ЭтаФорма);

и т.д.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует