Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как получить итоги по субконто ?

v7: Как получить итоги по субконто ?
Я
   r1000
 
26.12.18 - 18:21
Добрый день. 7.7 и так не сильно знал, а сейчас вообще забыл. Прошу помощи.
Как получить итоги по субконто ?
Есть счет. На нем 2 субконто. Номенклатура и партия.
Задача в том, чтобы на определенную дату, в цикле, получить развертку по сумовому и количественному остатку в разрезе номенклатуры и партии.
И при получении эти цифр я уже буду их по своему обрабатывать.
пишу вот так, но понимаю что не то пишу:
                      
                            БухИтоги = СоздатьОбъект("БухгалтерскиеИтоги");
                        БухИтоги.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ТаблицаПроводок.СубконтоК1, 1);
                        БухИтоги.ИспользоватьСубконто(ВидыСубконто.ПартияПолучениеГотовойПродукции, , 1);
                        БухИтоги.ВыполнитьЗапрос(,ДатаЗапроса,"43");
                        БухИтоги.ВыбратьСубконто(1);        
                        Пока БухИтоги.ПолучитьСубконто(1) = 1 Цикл
                            БухИтоги.ВыбратьСубконто(2);        
                            Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
                                Цена = ?(БухИтоги.СКД("К") = 0, 0, БухИтоги.СКД("С")/БухИтоги.СКД("К"));
                                Операция.Сумма      = Цена * количество;
                            КонецЦикла;
                        КонецЦикла;
 
 
   r1000
 
1 - 26.12.18 - 18:22
т.е. вопрос в том, чтобы получить остаток стоимости и количественный остаток номенклатуры, по оставшимся партиям
   r1000
 
2 - 26.12.18 - 18:25
На входе у меня есть только номенклатура и вот нужно все оставшиеся партии этой номенклатуры получить и понять остаток этих партий.
   Провинциальный 1сник
 
3 - 26.12.18 - 18:55
На будущее. Забудьте про использование константного номера субконто, вместо него задавайте ВидСубконто.xxx - намного нагляднее и меньше сделаете ошибок.
А по теме. По номенклатуре делаете отбор, а не выборку. То есть, в методе ИспользоватьСубконто поставьте 2, а не 1. И не надо выбирать это субконто, сразу приступайте к выборке по партиям.
   r1000
 
4 - 26.12.18 - 19:37
Сделал вот так. Ругается на число фильтров.
Как задать правильное число фильтров ?
                        БухИтоги = СоздатьОбъект("БухгалтерскиеИтоги");
                        БухИтоги.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ТаблицаПроводок.СубконтоК1 , 2);
                        БухИтоги.ВыполнитьЗапрос(,Операция.Документ.ДатаДок,"43");
                        
                        //БухИтоги.ВыбратьСубконто(1);        

                        //Пока БухИтоги.ПолучитьСубконто(1) = 1 Цикл

                            
                            БухИтоги.ВыбратьСубконто(ВидыСубконто.ПартияПолучениеГотовойПродукции);        
                            Пока БухИтоги.ПолучитьСубконто(ВидыСубконто.ПартияПолучениеГотовойПродукции) = 1 Цикл
   r1000
 
5 - 26.12.18 - 19:37
БухИтоги.ВыбратьСубконто(ВидыСубконто.ПартияПолучениеГотовойПродукции);        
{Глобальный модуль(14655)}: Число фильтров субконто превысило допустимое значение!
   Провинциальный 1сник
 
6 - 26.12.18 - 20:06
(5) Вы забыли  БухИтоги.ИспользоватьСубконто(ВидыСубконто.ПартияПолучениеГотовойПродукции);
   r1000
 
7 - 26.12.18 - 20:38
Да. Спасибо. Получилось.
А как выборку партий отсортировать по дате документа ?
   r1000
 
8 - 26.12.18 - 20:40
Нашел :)
   Злопчинский
 
9 - 27.12.18 - 12:06
если нужно сальдо на дату то лучше бы огрничит бхзапрс слева и справа одинаковой даиотй
   Провинциальный 1сник
 
10 - 28.12.18 - 02:41
(9) Не лучше, выгоды никакой это не дает. Проверял.
 
 Рекламное место пустует
   BruS
 
11 - 28.12.18 - 06:09
БухИтоги = СоздатьОбъект("БухгалтерскиеИтоги");
БухИтоги.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ТаблицаПроводок.СубконтоК1, 2);
БухИтоги.ИспользоватьСубконто(ВидыСубконто.ПартияПолучениеГотовойПродукции, , 1);
БухИтоги.ВыполнитьЗапрос(,ДатаЗапроса,"43");
БухИтоги.ВыбратьСубконто(2);        
Пока БухИтоги.ПолучитьСубконто(2) = 1 Цикл
    Цена = ?(БухИтоги.СКД("К") = 0, 0, БухИтоги.СКД("С")/БухИтоги.СКД("К"));
    Операция.Сумма      = Цена * количество;
КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует