Вход | Регистрация


Не записывает колонку в регистре сведений

Не записывает колонку в регистре сведений
Я
   inkvizitr
 
20.12.18 - 10:19
МенеджерЗаписи = РегистрыСведений.ОсновныеСотрудникиФизическихЛиц.СоздатьНаборЗаписей();
    МенеджерЗаписи.Отбор.ДатаОкончания.Установить("");
    Менеджерзаписи.Прочитать();    
    Для Каждого Запись Из МенеджерЗаписи Цикл
        ДатаКон = '39991231';
        Запись.ДатаОкончания = ДатаКон;
        Менеджерзаписи.Записать();
    КонецЦикла;

валится все дело на записать, что не так
 
 
   inkvizitr
 
1 - 20.12.18 - 10:20
пытаюсь дополнить колонку у существующих записей
   Радим1987
 
2 - 20.12.18 - 10:21
МенеджерЗаписи = РегистрыСведений.ОсновныеСотрудникиФизическихЛиц.СоздатьНаборЗаписей();
    МенеджерЗаписи.Отбор.ДатаОкончания.Установить("");
    Менеджерзаписи.Прочитать();    
    Для Каждого Запись Из МенеджерЗаписи Цикл
    Если Менеджерзаписи.Количество() = 0 Тогда
НоваяСтрока =  Менеджерзаписи.Добавить();
Иначе
НоваяСтрока = Запись;
  
НоваяСтрока .ДатаКон = '39991231';
НоваяСтрока .ДатаОкончания = ДатаКон;
       
    КонецЦикла;

 Менеджерзаписи.Записать();
   inkvizitr
 
3 - 20.12.18 - 10:27
(2) такая же хрень пишет Запись не верна! Значение поля не соответствует установленному отбору
   PuhUfa
 
4 - 20.12.18 - 10:34
(0) ДатаОкончания в РС какой тип?
   inkvizitr
 
5 - 20.12.18 - 10:35
(4) Тип ДАТА
   PuhUfa
 
6 - 20.12.18 - 10:35
(2)
Для Каждого Запись Из МенеджерЗаписи Цикл
   Если Менеджерзаписи.Количество() = 0 Тогда
...
КонецЦикла;

Это сильно -)
   PuhUfa
 
7 - 20.12.18 - 10:36
(5) А почему тогда в отборе ты ставишь строку?
МенеджерЗаписи.Отбор.ДатаОкончания.Установить("");
   inkvizitr
 
8 - 20.12.18 - 10:36
(6) согласен очень сильно, но я чета все перепробовал все вариации и не могу добавить в существующие данные значение в колонку
   inkvizitr
 
9 - 20.12.18 - 10:37
выставлял Дата(1,1,1) я все перепробывал
   inkvizitr
 
10 - 20.12.18 - 10:37
(8) тоже самое, кстати с "" он  так же записи отбирает
 
 Рекламное место пустует
   hhhh
 
11 - 20.12.18 - 10:37
(5) почему отбопр тогда строку делаете МенеджерЗаписи.Отбор.ДатаОкончания.Установить("");  ??
   hhhh
 
12 - 20.12.18 - 10:41
(10) надо две записи делать
МенеджерЗаписи.Отбор.ДатаОкончания.Установить("");

запись удалить

МенеджерЗаписи.Отбор.ДатаОкончания.Установить('39991231');

запись добавить


просто так передвинуть запись из одного отбора в другой через попу не получится наверно.
   PuhUfa
 
13 - 20.12.18 - 10:48
(10) Кстати, да. Я что то и не увидел, что ты меняешь то реквизит по которому у тебя установлен отбор. Так нельзя. (2) Прав
   dmpl
 
14 - 20.12.18 - 10:51
(9) Не надо ставить отбор по незаполненному реквизиту. Набор записей автоматом потрет все записи и заместит их новыми.
   inkvizitr
 
15 - 20.12.18 - 11:04
спасибо всем удалением и добавлением все получилось
   Радим1987
 
16 - 20.12.18 - 11:07
(6) Опечатка
   CaIIIka
 
17 - 20.12.18 - 11:11
Не нужно удалять и добавлять. Можно поменять и дополнить как в (2). Все прекрасно работает, если голову приложить (мет.)
   inkvizitr
 
18 - 20.12.18 - 12:07
(17) хорошо, чуть позже попробую реализовать как вы говорите

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует