Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вычисляемое поле в другом вычисляемом поле

Вычисляемое поле в другом вычисляемом поле
Я
   МаленькийВопросик
 
19.12.18 - 16:58
Собственно ругается, подскажите сабж!

Спасибо!

см. рисунок - поле "количество"


https://www.dropbox.com/sh/ajunfsftz06l8pt/AAAoOzGIN6YXsfTlddSLx6Fca?dl=0
 
 
   МаленькийВопросик
 
1 - 19.12.18 - 17:02
   МаленькийВопросик
 
2 - 19.12.18 - 17:55
апнем тему
   Tonik992
 
3 - 19.12.18 - 18:08
Нельзя использовать в вычисляемых полях другие вычисляемые поля. Точка. Других трактовок нет.
   МаленькийВопросик
 
4 - 19.12.18 - 18:10
(3) подставлять всю байду в вычисления?
   МаленькийВопросик
 
5 - 19.12.18 - 18:10
)))
   Tonik992
 
6 - 19.12.18 - 18:11
Да, именно так. К сожалению.
   Михаил Козлов
 
7 - 19.12.18 - 18:15
(4) Или в Экселе пусть подставляют все, что захочется.
   Tonik992
 
8 - 19.12.18 - 18:16
У вас, кстате, вычисляемое поле очень простое. Поместите его прямиком в текст запроса.
Чем мотивирован выбор в данном случае именно вычисляемого поля?
   МаленькийВопросик
 
9 - 19.12.18 - 18:18
(8) ну это же пример
   Бертыш
 
10 - 19.12.18 - 18:58
(0) Я так лично не возражаю... вычисляй...
Для того чтобы понять рекурсию тебе нужно сначала понять рекурсию
Должно взлетать что то типа 
Функция _Вычислить1(ЧегоЖелаетеБарин)
Возврат _Вычислить1(ВычислитьВыражение(ЧегоЖелаетеБарин));
КонецФункции

Функция _Вычислить(ЧегоЖелаетеБарин)
      Возврат _Вычислить1(ВычислитьВыражение(ЧегоЖелаетеБарин));
КонецФункции
 
 Рекламное место пустует
   Бертыш
 
11 - 19.12.18 - 18:58
Тьфу ты копипастный бес попутал

Функция _Вычислить1(ЧегоЖелаетеБарин)
Возврат ВычислитьВыражение(ЧегоЖелаетеБарин);
КонецФункции

Функция _Вычислить(ЧегоЖелаетеБарин)
      Возврат _Вычислить1(ВычислитьВыражение(ЧегоЖелаетеБарин));
КонецФункции
   Бертыш
 
12 - 19.12.18 - 19:10
А он про СКД что ли?
   Бертыш
 
13 - 19.12.18 - 19:10
Тьху

Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует