Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Почему в 1С+CH-Com1S входящие звонки SIP не проходят, а исходящие проходят?

Почему в 1С+CH-Com1S входящие звонки SIP не проходят, а исходящие проходят?
Я
   kasbox
 
15.12.18 - 12:47
дано:

1С 8.3 (управляемое приложение) + CH-Com1S + sipnet.ru
упрощенный вариант кода для авторизации:

Порт = 5060;
  Если НЕ ПодключитьВнешнююКомпоненту("CH-Com1S.dll", "MyComp", ТипВнешнейКомпоненты.Native) Тогда    
    Сообщить("Не удалось подключить внешнюю компоненту !!!",СтатусСообщения.ОченьВажное);
    Отказ = Истина;
    Возврат;
  КонецЕсли;
  Телефон_1С = Новый("AddIn.MyComp.ServTel");
  ПортСвободен = Телефон_1С.PortIsFree(Порт);
  Если НЕ     ПортСвободен Тогда
    Для Порт = 5060 По 6060 Цикл
      ПортСвободен = Телефон_1С.PortIsFree(Порт);
      Если ПортСвободен Тогда
        Прервать;
      КонецЕсли;
    КонецЦикла;
  КонецЕсли;
  Если НЕ ПортСвободен Тогда
    Сообщить("Не удалось найти свободный локальный порт в диапазоне 5060-6060!", СтатусСообщения.ОченьВажное);
    Возврат;
  КонецЕсли;
  сообщить("порт: "+порт);
  Телефон_1С.Local_port = Порт;
//    сообщить(Телефон_1С.Version); //не разблокировать, т.к. сразу падает программа

  Статус = Телефон_1С.InitEnv();
    Registrar = "sip:sipnet.ru";
    Username = "здесь_мой_id";
    Password = "здесь_мой_пароль";
    Realm = "здесь_мой_id@sipnet.ru";
    Id = "sip:здесь_мой_id@sipnet.ru";
    Статус = Телефон_1С.AddAccount(Id,Registrar,Realm,Username,Password);



процедура набора номера

ИД = Телефон_1С.MakeСall("sip:здесь_id_для_набора@sipnet.ru", 0);



все процедуры &НаКлиенте

на ВнешнееСобытие я повесил вывод сообщений в текстовом виде через запятую.
Как результат ВходящееСобытие генерит следующее после попытки авторизации: "ComponentNative, RegAccountStatus, 401|-1; Account ID=2".

При попытке набрать номер от меня с 1С на обычную программу sip, номер набирается и мы с собеседником можем говорить и слышать друг друга. При наборе ВнешнееСобытие молчит. После того как исходящий вызов закончен ВнешнееСобытие выдает : "ComponentNative, CallIsDisconnected, 0; reason=603 (Declined); duration=0".

Если собеседник звонит мне на 1С (с SipPoint или NetCall), то у меня ВнешнееСобытие молчит, а у собеседника или "номер не найден" или "абонент не зарегистрирован".

Почему звонки от меня проходят, а звонки ко мне нет? Как исправить?
Почему при авторизации выдает "ComponentNative, RegAccountStatus, 401|-1; Account ID=2"? Разве 401 это не ошибка? Тогда почему выдает id? Если все-таки это ошибка, тогда почему проходят исходящие вызовы?
 
 
   mexanik_96
 
1 - 15.12.18 - 15:11
что в логах астериска с "сип дебаг он"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует