Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Таблицу-результат из одного отчета вывести в другом отчете в таблицу в режиме ввода данных

v7: Таблицу-результат из одного отчета вывести в другом отчете в таблицу в режиме ввода данных
Я
   palpetrovich
 
14.12.18 - 18:35
если тупо
Таблица = ТаблицаИзДругогоОтчета;
получаю 
Попытка присвоить значение недоступной для записи переменной (Таблица)

можно это сделать без особенных плясок с бубном?
 
 
   palpetrovich
 
1 - 14.12.18 - 18:44
походу никак ..ну и ладно
   HawkEye
 
2 - 14.12.18 - 20:09
(0) цикл по областям.... но какой смысл?! если знаешь что данные понадобятся для другой таблицы - пихай их сразу в ТЗ и передавай ТЗ......

зы. таблица в РВД - зло ))))
   AliAksA
 
3 - 20.12.18 - 16:21
(0) через глобальную переменную
   Карст
 
4 - 20.12.18 - 16:55
(2) випростонеумеете их готовить (с)
ЗЫ по областям - вот это зло )))
   HawkEye
 
5 - 20.12.18 - 17:04
(4) мы просто отлично умеем их готовить и именно поэтому это зло.
зы. можешь предложить другой вариант поиметь данные из mxl без использования областей, вполне возможно я поменяю свое мнение
   AliAksA
 
6 - 20.12.18 - 17:10
(5) элементарно, Ватсон:

В ГЛОБАЛЬНИКЕ:
Перем глПользователь Экспорт;

В ПЕРВОМ ОТЧЕТЕ:
глПеременная = СоздатьОбъект("Таблица");
глПеременная.ИсходнаяТаблица("ИмяМакета");
// алгоритм вывода в глПеременная


ВО ВТОРОМ ОТЧЕТЕ:
Если ПустоеЗначение(глПеременная) = 0 Тогда
    Если ТипЗначенияСтр(глПеременная) = "Таблица" Тогда
    // обрабатываем глПеременная

    КонецЕсли;
КонецЕсли;
   HawkEye
 
7 - 20.12.18 - 18:02
(6) внимательно читаешь вопрос и пытаешься понять его суть... потом долго думаешь, только потом тянешь свои лапки к клавиатуре, да и то когда есть что сказать....

и на будущее, использование глобальной переменной в подобной ситуации - идиотизм чистой воды, т.к. при наличии больше одного подобного отчета, в своей переменной ты получишь последний..
   AliAksA
 
8 - 20.12.18 - 19:06
(7) идиотизм батенька, то что ты предлагаешь ... мда уж, для оленей: при наличии больше одного отчета глПеременная объявляется списком значений ... хотя тебе это не поможет, умник
   Chameleon1980
 
9 - 20.12.18 - 19:11
тогда уж таблицей с именами внятными
или кто последний тот и папа
   AliAksA
 
10 - 20.12.18 - 19:16
(9) это ???
 
 Рекламное место пустует
   AliAksA
 
11 - 20.12.18 - 19:33
(9) для передачи нескольких таблиц:

В ФОРМИРУЮЩИХ ОТЧЕТАХ:
Если ТипЗначенияСтр(глПеременная) <> "СписокЗначений"  Тогда
    глПеременная = СоздатьОбъект("СписокЗначений");
КонецЕсли;
текТаблица = СоздатьОбъект("Таблица");
текТаблица.ИсходнаяТаблица("ИмяМакета");
// алгоритм вывода данных в таблицу

глПеременная.ДобавитьЗначение(текТаблица, "ИмяТаблицы");

В РЕЗУЛЬТИРУЮЩЕМ ОТЧЕТЕ:
Если ПустоеЗначение(глПеременная) = 0 Тогда
    Если ТипЗначенияСтр(глПеременная) = "СписокЗначений" Тогда
        Для Счетчик = 1 По глПеременная.РазмерСписка() Цикл
            ИмяТаблицы = "";
            текТаблица = глПеременная.ПолучитьЗначение(Счетчик, ИмяТаблицы);
            текТаблица.Показать(ИмяТаблицы);
        КонецЦикла;
    КонецЕсли;
КонецЕсли;
   Chameleon1980
 
12 - 20.12.18 - 20:33
ааа. 7.7 представление жеж.
просто давно забыл про представление
   Chameleon1980
 
13 - 20.12.18 - 20:34
да и в 8 прелставление
просто уже использую по привычке структуру - так привычнее

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует