Вход | Регистрация


Выбор в подборе у дерева основной ветви

Выбор в подборе у дерева основной ветви
Я
   TolstiyBeremenniy
 
13.12.18 - 12:32
На форме подбора есть дерево значений.
Там загружены ветви и под ветви.
При двойном щелчке в ВыбраннаяСтрока, идет номер строки.
Или Элемент.ТекущиеДанные сами значения строки.
Можно ли как то определить какой уровень дерева выбран?
Основная строка ветвей дерева. или одна из её имеющейся подстрок.
под ветвей?


&НаКлиенте
Процедура ДзНоменклатураДокумнетовДляПодбораВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    q=1;
КонецПроцедуры
//
 
 
   TolstiyBeremenniy
 
1 - 13.12.18 - 12:33
(0+) Само дерево значений лежит на форме в виде дерева
значений.
   TolstiyBeremenniy
 
2 - 13.12.18 - 12:54
Почему не могу передать массив структур с клиента на сервер?
Хочу там попробовать получить уровень выбранной ветви!
   TolstiyBeremenniy
 
3 - 13.12.18 - 12:54
(2+)

&НаКлиенте
Процедура ДзНоменклатураДокумнетовДляПодбораВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    //

    Масс   = Новый Массив;
    Структ = Новый Структура;
    //

    //

    Структ.Вставить("ВыбраннаяВетвь", Элемент.ТекущиеДанные);
    Масс.Добавить(Структ);    
    //

    УрВетви = УровеньВетвиДерева(Масс);
КонецПроцедуры
//

&НаСервере
Функция УровеньВетвиДерева(ВыбраннаяВетвь)
    тДерево  = РеквизитФормыВЗначение("ДзНоменклатураДокумнетовДляПодбора");
    
КонецФункции
//

Список тем форума
  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует