Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

как правильно описать заполнение табличной части.?

как правильно описать заполнение табличной части.?
Я
   Филипп Остырко
 
09.12.18 - 17:41
Мне нужно чтобы в документе реализации по команде "показать остатки" поле Товары.Количество заполнялось текущими Остатками из регистра. При запуске не срабатывает, говорит ,что "Количество" не определено. Как ее определить в коде? Спасибо за внимание.

"Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения, ПараметрыВыполнения) Экспорт
        Если ИдентификаторКоманды = "ПоказатьОстатки" Тогда
        Форма = ПараметрыВыполнения.ЭтаФорма;

         ТЧ = Форма.Объект.Товары;
        Для Каждого Строка Из ТЧ Цикл
            Строка.Количество = ПолучитьОстатокТовараИзРегистра(Строка.Номенклатура);                 
        КонецЦикла;      
    КонецЕсли;
КонецПроцедуры"
 
 
   mikecool
 
1 - 09.12.18 - 17:54
а что такое Строка?
   Филипп Остырко
 
2 - 09.12.18 - 17:58
(1) Строка табличной части по-моему, но я не уверен вообще за эту строчку кода:
"  Строка.Количество = ПолучитьОстатокТовараИзРегистра(Строка.Номенклатура); "
   Филипп Остырко
 
3 - 09.12.18 - 18:06
заменю "строка" на ТекущаяСтрока, что дальше?
   mikecool
 
4 - 09.12.18 - 18:07
(2) пока не поймешь, что там, нихрена не получится
   mexanik_96
 
5 - 09.12.18 - 18:10
Форма.Объект.Товары имеет ли реквизит Количество? А тип объекта тот? а зачем так делать на клиенте????
   Филипп Остырко
 
6 - 09.12.18 - 18:13
(5) Количество - реквизит ТЧ Товары . Это я делаю код для внешней обработки
   mikecool
 
7 - 09.12.18 - 18:15
(6) сделай запрос с ТЧ ТОвары + прицепи справа остатки, затем выгрузи в ТЧ или пробегись по результату и заполни
   mexanik_96
 
8 - 09.12.18 - 18:17
(6) код чего обармотка по бсп подключена(заполнение таб частей)? дак посмотри итс как её нужно делать правильно.

а по факту у тебя в команде множественный выбор. и тебе нужно через обход делать!!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует