Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Не добавляется значение в списокзначений на форме

Не добавляется значение в списокзначений на форме
Я
   1сЮлия
 
07.12.18 - 15:28
Добрый день! Добавила форму на форму разместила элемент поле списка.В коде,в процедуре при открытии пишу  //    СписокДеталей = Новый СписокЗначений;

    СписокПомеч = Новый СписокЗначений;

    Для каждого Стр из СправочникОбъект.Состав Цикл
        ДокСертифНом=Документы.СертификацияНоменклатуры.НайтиПоРеквизиту("СерияНоменклатуры",Стр.СерияНоменклатуры);
        Если ДокСертифНом.Пустая() тогда
        ЭлементыФормы.СписокДеталей.Значение.Добавить(Стр.СерияНоменклатуры,,Истина);
        иначе    
            Сообщить("Уже есть документ Сертификация номенклатуры,с такой серией:"+""+Стр.СерияНоменклатуры);
        КонецЕсли;    
    КонецЦикла;
КонецПроцедуры.Запускаю,а на экране список пустой.
 
 
   formista2000
 
1 - 07.12.18 - 15:30
ЭлементыФормы.СписокДеталей.Добавить(Стр.СерияНоменклатуры,,Истина);
   1сЮлия
 
2 - 07.12.18 - 15:41
(ЭлементыФормы.СписокДеталей.Добавить(Стр.СерияНоменклатуры,,Истина);чего то не работает.
   МимохожийОднако
 
3 - 07.12.18 - 15:44
У Отладчика спрашивала?
   ZDenis
 
4 - 07.12.18 - 15:45
(2) Тебе нужен список для выбора какого-то значения? Или что за список значений ты делаешь?
   1сЮлия
 
5 - 07.12.18 - 15:53
Список с пометками
   1сЮлия
 
6 - 07.12.18 - 15:55
Мне нужно,я знаю что можно вызвать окно диалога,но мне нужно вот эти галочки добавить все веделить галочки и все снять
   ZDenis
 
7 - 07.12.18 - 16:19
(6) Все равно немного не ясно.

как теперь понял тебя я - на форме расположен реквизит в виде таблицы с типом "СписокЗначений" и туда ты пытаешься записать значения с галочками. Тогда так:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Список.Добавить(Значение1,"1",Истина);    
    Список.Добавить(Значение2,"2",Истина);
        Список.Добавить(и т.д., Представление, Истина);    
КонецПроцедуры

Где Список - реквизит формы с типом "СписокЗначений" и размещен на форме в виде "Таблицы"
   1сЮлия
 
8 - 07.12.18 - 16:31
Имя ПолеСписка, Список реквизит формы с типом значения СписокЗначений не в виде таблицы я выбирала ,через вставить элемент управления Поле списка
   МимохожийОднако
 
9 - 07.12.18 - 16:33
(8) Список значений для этого поля откуда берешь?
   1сЮлия
 
10 - 07.12.18 - 16:39
СписокДеталей = Новый СписокЗначений;
    СписокПомеч = Новый СписокЗначений;

    Для каждого Стр из СправочникОбъект.Состав Цикл
        ДокСертифНом=Документы.СертификацияНоменклатуры.НайтиПоРеквизиту("СерияНоменклатуры",Стр.СерияНоменклатуры);
        Если ДокСертифНом.Пустая() тогда
        ЭлементыФормы.СписокДеталей.Значение.Добавить(Стр.СерияНоменклатуры,,Истина);
        иначе    
            Сообщить("Уже есть документ Сертификация номенклатуры,с такой серией:"+""+Стр.СерияНоменклатуры);
        КонецЕсли;    
    КонецЦикла;
 
 Рекламное место пустует
   ZDenis
 
11 - 07.12.18 - 16:46
(8) так у тебя не управляемые формы, а обычное приложение?
   1сЮлия
 
12 - 07.12.18 - 16:47
да обычное приложение
   1сЮлия
 
13 - 07.12.18 - 16:50
у меня все работала я вызывала список через ВыборПроизведен = СпДетал.ОтметитьЭлементы("Выберите детали")мне дали задание,чтобы я добавила форму и на этой форме выводился список с пометками ,а также были кнопки поставить все галочка или все снять ;
   ZDenis
 
14 - 07.12.18 - 16:52
(12) Тогда так

Процедура ПриОткрытии()
    ПолеСписка.Добавить(1,1,Истина);
    ПолеСписка.Добавить(2,2,Истина);
КонецПроцедуры
   ZDenis
 
15 - 07.12.18 - 16:53
вот под твой вариант

    Для каждого Стр из СправочникОбъект.Состав Цикл
        ДокСертифНом=Документы.СертификацияНоменклатуры.НайтиПоРеквизиту("СерияНоменклатуры",Стр.СерияНоменклатуры);
        Если ДокСертифНом.Пустая() тогда
        СписокДеталей.Добавить(Стр.СерияНоменклатуры,,Истина);
        иначе    
            Сообщить("Уже есть документ Сертификация номенклатуры,с такой серией:"+""+Стр.СерияНоменклатуры);
        КонецЕсли;    
    КонецЦикла;
   ZDenis
 
16 - 07.12.18 - 16:54
вот это не надо :
СписокДеталей = Новый СписокЗначений;
    СписокПомеч = Новый СписокЗначений;
   1сЮлия
 
17 - 07.12.18 - 16:59
Можно  уточнить в свойствах списка имя ПолеСписка,Данные СписокДеталей,,тип значений СписокЗначений
   1сЮлия
 
18 - 07.12.18 - 17:00
не хочет отображать на экране
   1сЮлия
 
19 - 07.12.18 - 17:01
пустой список,он то показывает список,но он пустой.
   ZDenis
 
20 - 07.12.18 - 17:03
(17) согласно этого в (15) ответ
   ZDenis
 
21 - 07.12.18 - 17:04
(19) А это значит уже просто в цикл у тебя не входит
   ZDenis
 
22 - 07.12.18 - 17:04
Либо ты его где то обнуляешь
   1сЮлия
 
23 - 07.12.18 - 17:10
Нет я уже убрала тот код и тупо
Процедура Приоткрытии()
 СписокДеталей.Добавить(1,1,Истина);
КонецПроцедуры и все равно ничего
   1сЮлия
 
24 - 07.12.18 - 17:10
пустой список.
   Ёпрст
 
25 - 07.12.18 - 17:26
(24) Перем СписокДеталей надеюсь, нет в коде ?
И СписокДеталей - это название реквизита формы у тебя ?
   1сЮлия
 
26 - 10.12.18 - 10:15
да.
   1сЮлия
 
27 - 10.12.18 - 10:29
Нету в кодн
   МимохожийОднако
 
28 - 10.12.18 - 10:33
Встань отладчиком в процедуру, которая формирует список и посмотри, что там. А так можно до посинения гадать.
   ZDenis
 
29 - 10.12.18 - 12:55
(27) Процедура Приоткрытии() прописана на форме, что она при открытии?
   1сЮлия
 
30 - 10.12.18 - 15:28
Вот в этом и была ошибка,спасибо большое!!!


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует