Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Правила обмена Торговля 10 - Розница 2.2.7

Правила обмена Торговля 10 - Розница 2.2.7
Я
   TrudnyiRebenok
 
07.12.18 - 14:06
Создаю правила переноса Установок цен номенклатуры, нестандартные.
Документ, справочники, все ПКО сделал. Проводить док не хочу, а он его проводит. Признак Проведен отключил - проводит. Поставил перед загрузкой РежимЗаписи = "Запись"; - проводит.
Как запретить этой твари делать проводку?
 
 
   Ёпрст
 
1 - 07.12.18 - 14:15
Какой обработкой переносишь?
   Ёпрст
 
2 - 07.12.18 - 14:16
Ну и если вообще не надо проводить, то поставь в Проведен значение нет
   TrudnyiRebenok
 
3 - 07.12.18 - 14:47
Какой обработкой переносишь?

Через план обмена
   TrudnyiRebenok
 
4 - 07.12.18 - 14:47
Ну и если вообще не надо проводить, то поставь в Проведен значение нет

Поставил сразу - нет толку
   Ёпрст
 
5 - 07.12.18 - 14:49
(3) Понятно. В этой обработке нужно поменять кое-что, чтоб она не проводила всегда документ, а переносила движения (если и они переносятся)
   zippygrill
 
6 - 07.12.18 - 14:49
причем тут план обмена ))
   Ёпрст
 
7 - 07.12.18 - 14:54
(6) при том, что выгружается через обработку ОбменДаннымиXML, там чутка другое поведение, нежели через УниверсальнаяобработкаXML

(3) найди в обработке ОбменДаннымиXML место по слову "ОтменитьПроведениеОбъектаВИБ" и поменяй на это :





                        Если НужноЗаписатьОбъект Тогда
                        
                            //// документы которые просто нужно записать - так и записываем

                            //Если РежимЗаписи = РежимЗаписиДокумента.Запись Тогда

                            //    

                            //    ЗаписатьОбъектВИБ(Объект, ТипОбъекта);

                            //    

                            //ИначеЕсли РежимЗаписи = РежимЗаписиДокумента.ОтменаПроведения

                            //    ИЛИ РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда

                            //    

                            //    // проведение убираем всегда...

                            //    ОтменитьПроведениеОбъектаВИБ(Объект, ТипОбъекта);                            

                            //    

                            //КонецЕсли;

                            // документы которые просто нужно записать - так и записываем

                            Если РежимЗаписи = РежимЗаписиДокумента.ОтменаПроведения Тогда
                                // проведение убираем всегда...

                                ОтменитьПроведениеОбъектаВИБ(Объект, ТипОбъекта);                            
                            Иначе
                                ЗаписатьОбъектВИБ(Объект, ТипОбъекта);
                            КонецЕсли;
                            
                        КонецЕсли;

   zippygrill
 
8 - 07.12.18 - 15:03
(7) Ах  мерси

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует