Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Регулярно закрывается 1С

Регулярно закрывается 1С
Я
   satoru
 
07.12.18 - 10:26
Добрый день. Через 1-2 дня работы база вылетает с ошибкой:
Превышен максимально допустимый размер внутреннего файла 'C:\Users\user\AppData\Local\1C\1cv8\15a80b77-5519-469e-9109-370b9ede9359\61fa6fb5-4670-4085-be3b-2e3479e01b20\vrs-cache\cache.1CD'. База находится на 1С Сервере. После очистки кэша все работает, до следующего вылета.

Платформа: 8.3.10.2168
 
 
   Maniac
 
1 - 07.12.18 - 10:27
обнови платформу
   satoru
 
2 - 07.12.18 - 10:34
(1) Т.е. проблема в версии платформы?
   Вафель
 
3 - 07.12.18 - 10:44
Нужно на скл переходить
   satoru
 
4 - 07.12.18 - 10:48
(3) База 1С уже находиться на SQL.
   satoru
 
5 - 07.12.18 - 12:58
Можно хотя бы узнать почему он в кэш загоняет файл 1CD, если база храниться на SQL?
   satoru
 
6 - 07.12.18 - 13:35
up
   shuhard
 
7 - 07.12.18 - 13:36
(5) можно, не забудь поделиться знанием с форумом
   satoru
 
8 - 07.12.18 - 13:39
(7) если сам найду ответ по решению данной проблемы, обязательно отпишусь.
   zva
 
9 - 07.12.18 - 13:51
Возможно в свойствах виндового профиля пользователя стоит ограничение на размер. Может терминальный сервер или профиль перемещаемый...
   RomanYS
 
10 - 07.12.18 - 14:00
а размер этих файлов реально какой на момент возникновения ошибки?
 
 Рекламное место пустует
   timurhv
 
11 - 07.12.18 - 14:02
(0) А сколько файл весит в этот момент?
Я бы грешил (вилами по воде):
1. Кривой код\косяк в самописке\ТИИ прогнать.
2. Если больше 4Гб 1CD, то принудительно сконвертировать на заголовки c 8кб, а не 4. На ИТС есть статья.
   satoru
 
12 - 07.12.18 - 15:34
(11) Можно ссылку на статью?
   satoru
 
13 - 07.12.18 - 15:37
(11) Базу протестировал, ошибок нет. Значить буду ковырять код.
   satoru
 
14 - 08.12.18 - 17:37
Вопрос: нет ли способа выявить, что находиться в кэше? Что то наподобие "Замер производительности".
   RomanYS
 
15 - 08.12.18 - 17:44
(14) ответь на (10)
   satoru
 
16 - 08.12.18 - 17:47
(15) ~5,1 Гб
   satoru
 
17 - 08.12.18 - 18:00
Я так смотрю файл cache.1CD не всегда формируется. Где можно прочитать, что это за файл и зачем он нужен (на сайте ИТС нашел только инструкцию по его удалению и все)?
   RomanYS
 
18 - 08.12.18 - 18:03
(16) у меня самый большой 70Мб. Попробовал переименовать и открыть как файловую базу, не прокатило
   mexanik_96
 
19 - 08.12.18 - 18:07
(14) например то что повторноенеиспользование в ом
   satoru
 
20 - 08.12.18 - 18:14
(19) вы имеете ввиду переменные, которые используются 1 раз и не очищаются?
   RomanYS
 
21 - 08.12.18 - 18:30
(19) сейчас за тестю
   RomanYS
 
22 - 08.12.18 - 19:19
(19) не подтверждается. Повт. исп. оперативку жрёт, cache.1CD не растёт
   satoru
 
23 - 08.12.18 - 19:20
Проблема в обновлении картинок на форме:
использую ПоместитьВоВременноеХранилище() с одинаковым идентификатором заменяя саму картинку.
   mexanik_96
 
24 - 08.12.18 - 19:20
(22) подожди, скинет(или ограничь по озу и добавь нагрузки)
   satoru
 
25 - 08.12.18 - 19:25
(24) Там логическая ошибка в коде: ПоместитьВоВременноеХранилище - помещает картинку в кэш и возвращает ссылку на эту картинку, если я ещё раз использую ПоместитьВоВременноеХранилище с тем же уникальным ИД он создаст новую ссылку, а старую не обновит.
Добавил список значений, где храню все созданные хранилища со ссылками и ИД.
Проблема решена. Всем спасибо за помощь.
   RomanYS
 
26 - 08.12.18 - 19:30
(24) вот такая херь 10 минут выполнялась, память до 4GB отжирал, периодически уменьшалась. cache.1CD не рос.

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
    ТД = ТекущаяДата();
    Для инд = 1 По 1000000 Цикл
        Ц =  ПовтИсп.Рез(ТД, инд);    
    КонецЦикла; 
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    
    Для инд = 1 По 10 Цикл
        ОбработкаПрерыванияПользователя();
        Команда1НаСервере();
        Сообщить(ТекущаяДата());
    КонецЦикла; 
КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует