Вход | Регистрация


вывод печатной формы

вывод печатной формы
Я
   inkvizitr
 
07.12.18 - 09:40
Имеется самописный справочник, в нем так же имеется печатная форма, задача стоит в том, что в форме списка программно подключается команда печати, при ее нажатии открывается не главная форма справочника, и вот у меня возникает вопрос как с помощью этой формы вызвать макет печатной формы, чтобы в печатной форме была подключена подсистема печати(типа предварительный просмотр, кнопочка печать), привожу синтаксис

Модуль менеджера
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт           
    КомандаПечати = КомандыПечати.Добавить();
    КомандаПечати.Идентификатор = "ЖурналПроектов";
    КомандаПечати.Представление = НСтр("ru = 'Журнал проектов'");
    КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
    КомандаПечати.СписокФорм    = "ФормаСписка,ФормаЭлемента";
КонецПроцедуры

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,
            "ЖурналПроектов",
            "Журнал проектов",
            ПечатьЖурналПроектов(МассивОбъектов, ОбъектыПечати),
            ,
            "Справочник.tr_ЖурналПроектов.МакетЖурналДокументов");
КонецПроцедуры    

Так же привожу синтаксис модуля формы списка


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма);
КонецПроцедуры

// СтандартныеПодсистемы.ПодключаемыеКоманды

&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    
    ОткрытьФорму("Справочник.tr_ЖурналПроектов.Форма.ФормаПериод");
    
КонецПроцедуры

В форму с которой нужно произвести печать я прекрасно проваливаюсь, но вот как грамотнее подключиться к функции где расположен алгоритм заполнения печатной формы и вывода ее со всеми плюшками, (в отдельном окне, кнопка просмотр и .т д) вот не пойму как это сделать

Функцию заполнения макета печатной формы, думаю смысла нет приводить здесь
 
 
   inkvizitr
 
1 - 07.12.18 - 09:41
в форму так же добавлено подменю
   inkvizitr
 
2 - 07.12.18 - 09:44
в форму списка

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует