Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1С 8 3 УТП управление отбором в списке документа

1С 8 3 УТП управление отбором в списке документа
Я
   Nysha1210
 
07.12.18 - 00:13
Добрый день. Нужно сделать отбор в форме списка документа по нужным полям при помощо флажка. Это я реализовала, но при отключении флажка нужно вернуться к первоначальному списку документов и интервалу дат. Именно возврат не получается. После сброса Отбора выводится весь список документов (с начала существования программы), настройка периода программно не получается, хотя вроде всё делаю правильно.

ДатаНачала = ЭлементыФормы.Список.СтандартныйПериод.ДатаНачала;
ДатаКонца = ЭлементыФормы.Список.СтандартныйПериод.ДатаОкончания; 

Если ЭлементыФормы.Флажок1.Значение=истина тогда 
ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Установить(Перечисления.СтатусЗаказа.ВРаботе); 
иначе 
ЭлементыФормы.Список.Значение.Отбор.Сбросить(); 
ЭлементыФормы.Список.Значение.Отбор.Дата.Использование=истина;    
ЭлементыФормы.Список.Значение.Отбор.Дата.ВидСравнения=ВидСравнения.ИнтервалВключаяГраницы; 
ЭлементыФормы.Список.Значение.Отбор.Дата.Значение=ЭлементыФормы.Список.Значение.Отбор.Дата.Значение; 
ЭлементыФормы.Список.Значение.Отбор.Дата.ЗначениеС=ДатаНачала; 
ЭлементыФормы.Список.Значение.Отбор.Дата.ЗначениеПо=ДатаКонца; 
ЭлементыФормы.Список.Значение.Отбор.Дата.Установить(); 
КонецЕсли; 

Спасибо. Буду благодарна за помощь)))
 
 
   BeerHelpsMeWin
 
1 - 07.12.18 - 00:17
ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Использование=Ложь?
   Nysha1210
 
2 - 07.12.18 - 00:24
После Иначе?
   Nysha1210
 
3 - 07.12.18 - 00:25
ЭлементыФормы.Список.Значение.Отбор.Сбросить(); - сбрасывает все отборы и период документов тоже ((((
   Nysha1210
 
4 - 07.12.18 - 00:28
Спасибо. Получилось.
РЕШЕНИЕ
    
Если ЭлементыФормы.Флажок1.Значение=истина тогда
         ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Установить(Перечисления.СтатусЗаказа.ВРаботе);
     иначе
        ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Использование=Ложь; 
КонецЕсли;
   Nysha1210
 
5 - 07.12.18 - 00:30
Ещё одно уточнение.
Как построить Отбор по нескольким условиям обновременно, а потом его сбрасывать?
Просто перечислить все отборы по порядку?
   Nysha1210
 
6 - 07.12.18 - 00:48
Множественный отбор по Списку значений не работает. Почему?
    Если ЭлементыФормы.Флажок1.Значение=истина тогда
         СписокОтбора = новый СписокЗначений;
         СписокОтбора.Добавить(Перечисления.СтатусЗаказа.ВРаботе,,,);
         СписокОтбора.Добавить(Перечисления.СтатусЗаказа.Оплачен,,,);
         СписокОтбора.Добавить(Перечисления.СтатусЗаказа.Отправлен,,,);
         ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Установить(СписокОтбора);
        ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Использование=истина;         
    иначе
        ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Использование=Ложь; 
    КонецЕсли;
   Nysha1210
 
7 - 07.12.18 - 15:25
РЕШЕНИЕ 
    Если ЭлементыФормы.Флажок1.Значение=истина тогда
         СписокОтбора = новый СписокЗначений;
         СписокОтбора.Добавить(Перечисления.СтатусЗаказа.ВРаботе,,,);
         СписокОтбора.Добавить(Перечисления.СтатусЗаказа.Оплачен,,,);
         СписокОтбора.Добавить(Перечисления.СтатусЗаказа.Отправлен,,,);
         ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Использование=истина;    
         ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.ВидСравнения = ВидСравнения.ВСписке;         
         ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Значение = СписокОтбора;
    иначе
        ЭлементыФормы.Список.Значение.Отбор.СтатусЗаказа.Использование=Ложь; 
    КонецЕсли;

Как теперь добавить условие - только для проведенных документов?
   Гипервизор
 
8 - 07.12.18 - 15:28
Для чего 2 темы?
   Nysha1210
 
9 - 07.12.18 - 15:49
Немного запуталась((( Сори.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует