Вход | Регистрация



Обновление УТ 10.3, всё поломалось

Обновление УТ 10.3, всё поломалось
Я
   ac13
 
06.12.18 - 13:32
Обновил конфу УТ 10.3 до предпоследнего на текущую дату релиза - 10.3.49.1. В настройках торгового оборудования для каждой ККТ с передачей данных установились одинаковые параметры. Везде один и тот же номер COM-порта. Меняешь у одной кассы, меняется у всех остальных. В итоге ни одна касса не работает. Пробовал обновить обработку ТО, без изменений.
 
 
   ac13
 
1 - 06.12.18 - 13:33
Плюс, в разделе "ККТ с передачей данных" отображаются ВСЕ виды торгового оборудования - кассы, сканеры штрихкодов, эквайринговые терминалы.
   karpik666
 
2 - 06.12.18 - 13:34
(0) а конфигурация типовая, на поддержке? больше похоже, что кто-то допустил ошибку при обновлении
   Convert
 
3 - 06.12.18 - 13:34
(1) Это не Плюс, это большой минус)
   vis_tmp
 
4 - 06.12.18 - 13:35
На сегодня 10.3.49.3 от 04.12.18 последний.
   ac13
 
5 - 06.12.18 - 13:36
(4) да, релиз вышел позавчера.
(3) согласен, это минус )
(2) на поддержке, но не типовая. В плане ТО все модули типовые
   Convert
 
6 - 06.12.18 - 13:40
(5) Ну дообновляй до последнего и посмотри
   ac13
 
7 - 06.12.18 - 13:41
А никто больше не обновлялся? У кого всё нормально?
   Полбатона
 
8 - 06.12.18 - 13:48
>В плане ТО все модули типовые
гыгы.кассы работают по рдп небось
   ac13
 
9 - 06.12.18 - 14:00
(8) да
   ac13
 
10 - 06.12.18 - 14:00
(8) и раньше работали, всё ок было
 
 Рекламное место пустует
   Trotter
 
11 - 06.12.18 - 14:13
наверное вы ещё заходите настраивать по RDP под одним пользователем на одном рабочем месте?)
   Полбатона
 
12 - 06.12.18 - 14:47
покаж процедуру
ТОСервер.ПолучитьИмяКомпьютераТО()
   ac13
 
13 - 06.12.18 - 16:19
(12)
Функция ПолучитьИмяКомпьютераТО() Экспорт

    Если мИмяКомпьютера = Неопределено Тогда
        мИмяКомпьютера = ВРег(ИмяКомпьютера());
    КонецЕсли;

    Возврат мИмяКомпьютера;

КонецФункции
   ac13
 
14 - 06.12.18 - 16:22
С проблемой разобрался, при обновлении задвоилась ТЧ формы обработки "ТОНастройка", глюк с ККМ ушел, только вот всё равно всё работает как-то с трудом. При открытии любой обработки, где есть ПолучитьСерверТО().ПодключитьКлиента(ЭтаФорма);
выполняется проверка подключения всех касс, а не персонально кассы кассира
   Полбатона
 
15 - 06.12.18 - 16:24
дарю
Функция ПолучитьИмяКомпьютераТО() Экспорт

    Если мИмяКомпьютера = Неопределено Тогда
        WSHNetwork = Новый ComОбъект("WScript.Network");
        ИмяПользователяWindows = WSHNetwork.UserName;
        мИмяКомпьютера = ВРег(ИмяКомпьютера()+ИмяПользователяWindows);
    КонецЕсли;

    Возврат мИмяКомпьютера;

КонецФункции// ПолучитьИмяКомпьютераТО()
   Сияющий в темноте
 
16 - 06.12.18 - 17:51
Ну,кто 49.3 ставил?
после 49.1 и 49.2 чего-то не хочется
   ac13
 
17 - 10.12.18 - 11:24
(16) а у вас какие проблемы с 49.1 и 49.2?
   ColonelAp4u
 
18 - 10.12.18 - 11:42
(14) все верно, у меня такая же херня упп пользователи работают на рдп, следовательно пришлось дописать в запрос ТО условие по кассе ккм указанную в настройке пользователя, по другому не решишь, имя компьютера у тебя всегда одно и тоже, если рдп
   karpik666
 
19 - 10.12.18 - 11:44
(18) можно делать и по-другому достаточно убрать подключение кассы при открытии формы, это делается на уровне обработки обслуживания ТО.
   ac13
 
20 - 10.12.18 - 17:12
(18) у меня эта херня оказалась из-за того, что табличная часть в форме настройки задвоилась, проверь, может и у тебя так
   ac13
 
21 - 10.12.18 - 17:21
Но я столкнулся с другим! Видимо из-за того, что прошивка на ТО не обновлена, чеки с новыми модулями не пробивает. До прошивки ТО пришлось оставить старые модули работы с ТО.
   karpik666
 
22 - 10.12.18 - 17:38
(21) весело у вас, а как обновите прошивку надо будет изменения возвращать? правда непонятно, как старое оборудование перестало работать, если в функционале ничего не менялось для старого оборудования. и все зависит от ревизии интерфейса
   ac13
 
23 - 10.12.18 - 18:27
(22) в модулях довольно много изменений, особенно относительно ЕГАИС и налогообложения
   ac13
 
24 - 10.12.18 - 18:27
(22) не совсем перестало функционировать, а частично
   mikecool
 
25 - 10.12.18 - 21:46
(18)я такой фигней в 2006 маялся, вроде, до сих пор фигня осталась )))
   palsergeich
 
26 - 10.12.18 - 22:19
никогда такого не было и вот опять(с)
   Сияющий в темноте
 
27 - 11.12.18 - 00:32
49.3 те же тапки(грабли)с егаис.
в загрузке ккм так и остались на форме серии,а в таблице СерииНоменклатуры.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует