Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Цикл и вертикальная разметка

Цикл и вертикальная разметка
Я
   ParamPamPam
 
06.12.18 - 12:14
Добрый день! Подскажите как реализовать цикл что бы корректно выводился макет
Код:

//первая

    Массив1 = Новый массив(Счетчик); 
    Для сч1 = 0 по Массив1.ВГраница() цикл 
        Массив1.Вставить(0,сч1);    
        ОбластьВТретья.Параметры.Первая         = сч1;            
        ТабДокумент.Вывести(ОбластьВТретья); 
        //вторая

        Счетчик2 = СчетчикФ;
        Массив2 = Новый массив(Счетчик2); 
        Для сч2 = 0 по Массив1.ВГраница() цикл
            Массив2.Вставить(0,сч2);    
            ОбластьВторая.Параметры.Вторая         = сч2;            
            //третья

            Счетчик3 = СчетчикФ;
            Массив3 = Новый массив(Счетчик3); 
            Для сч3 = 0 по Массив3.ВГраница() цикл
                Массив3.Вставить(0,сч3);    
                ОбластьТретья.Параметры.Третья         = сч3;
                ТабДокумент.Вывести(ОбластьТретья);        
            КонецЦикла;                                
            ТабДокумент.Вывести(ОбластьВторая);
        КонецЦикла;
        Если сч1 = Массив1.ВГраница() Тогда
            сч=сч-1;
            ТабДокумент.Вывести(ОбластьВТретья);;
        КонецЕсли;
    КонецЦикла;



http://c.radikal.ru/c32/1812/aa/c0c2742c9d52.jpg

http://a.radikal.ru/a09/1812/c4/6eb8189f50c7.jpg
 
 
   МимохожийОднако
 
1 - 06.12.18 - 12:18
Покажи как хочешь в результате и правильно
   ParamPamPam
 
2 - 06.12.18 - 12:26
   ParamPamPam
 
3 - 06.12.18 - 12:27
(1) Сказали используй Вывести и Присоединить, но пока не понимаю как
   xxTANATORxx
 
4 - 06.12.18 - 12:28
.Присоединить(
   МимохожийОднако
 
5 - 06.12.18 - 12:28
(2) Это правильный вариант? ))
   ParamPamPam
 
6 - 06.12.18 - 12:29
(5) Желаемый)
   МимохожийОднако
 
7 - 06.12.18 - 12:29
(3) Выводишь секцию Вывести(). Остальные секции в этой строке Присоединить()
   МимохожийОднако
 
8 - 06.12.18 - 12:29
(6) Я в шоке..
   Buster007
 
9 - 06.12.18 - 12:29
по-моему у тебя желаемый какой-то кривой))
   МимохожийОднако
 
10 - 06.12.18 - 12:31
Перед началом формирования отчета определись с количеством колонок. Каждая строка обходит все колонки. Первая колонка (секция) Вывести(). Остальные колонки Присоединить()
в яндексе полно примеров про шахматку
 
 Рекламное место пустует
   NorthWind
 
11 - 06.12.18 - 12:46
А чейта никто не посоветовал использовать СКД? :)
   ParamPamPam
 
12 - 06.12.18 - 12:47
(9) в паинте слепил)
   ParamPamPam
 
13 - 06.12.18 - 12:50
(11) Я только 2 неделю занимаюсь разработкой.
Этот макет сделал для понимания принципа.

А итоговый будет такой:
http://b.radikal.ru/b38/1812/e0/4714f611fe3d.jpg
   МимохожийОднако
 
14 - 06.12.18 - 12:52
(13) "Товаааарищ не понимает"
Это не пример отчета. Это макет.
   Builder
 
15 - 06.12.18 - 12:55
(13) Не хватает вертикальной секции для столбцов 1-3.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует