Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Выгрузка во внешний источник: пустая дата выглядит как 1753-01-01 00:00:00.0

Выгрузка во внешний источник: пустая дата выглядит как 1753-01-01 00:00:00.0
Я
   romix
 
05.12.18 - 15:28
Платформа 1С:Предприятие 8.3 (8.3.12.1529) клиент-серверная должна писать во внешний источник данных (SAP) в виде базы MSSQLServer, они жалуются, что пустая дата им приходит как 1753-01-01 00:00:00.0. Назначить полям "Разрешить Null" не удается - лезет еще ошибка. Коллеги, вопрос как правильно выгружать пустую дату во внешний источник, чтобы там не читались 1753 годы?
https://ru.wikipedia.org/wiki/1753_год
https://en.wikipedia.org/wiki/1753
 
 
   kennetmccormick
 
1 - 05.12.18 - 15:40
1753 это дата меньшая 1900 года насколько я помню. для sql пустая дата это 1900 год
   Numerus Mikhail
 
2 - 05.12.18 - 15:43
Зависит от настроек SQL сервера, как я понимаю
https://stackoverflow.com/questions/3310569/what-is-the-significance-of-1-1-1753-in-sql-server
   romix
 
3 - 05.12.18 - 16:19
Вроде бы так работает (в модуле записей):

Процедура ПередЗаписью(Отказ)
    СписокПолейДата = Новый Массив;
    ТипДата = Тип("Дата");
    Для каждого Поле Из Метаданные.ВнешниеИсточникиДанных.Интеграция111.Таблицы.dbo_PPPPPP.Поля Цикл
        Если Поле.Тип.СодержитТип(ТипДата) Тогда
            СписокПолейДата.Добавить(Поле.Имя);
        КонецЕсли; 
    КонецЦикла;
    Для каждого Запись Из ЭтотОбъект Цикл
        Для каждого поле Из СписокПолейДата Цикл
            Если не ЗначениеЗаполнено(Запись[поле]) Тогда
                Запись[поле] = NULL;
            КонецЕсли; 
        КонецЦикла; 
    КонецЦикла; 
КонецПроцедуры


В полях разрешили null

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует