Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

КД. Правила выгрузки.

КД. Правила выгрузки.
Я
   Полька
 
05.12.18 - 10:26
Нужно из ЗУП выгрузить справочник Подразделения. У него есть дополнительное свойство. Выгружать нужно те строки, у которых оно "ИСТИНА".
Пишу правило выгрузки.
если объект.дополнительныесвойства.свойство=ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя","трам-пам-пам") и объект.дополнительныесвойства.значение=ИСТИНА Тогда
    отказ=ИСТИНА;
КонецЕсли;    
ругается на строку справочника, у которой эта галка не стоит.
 Поле объекта не обнаружено (ДополнительныеСвойства)
 
 
   Полька
 
1 - 05.12.18 - 10:28
объект.дополнительныесвойства.значение=ЛОЖЬ
   azt-yur
 
2 - 05.12.18 - 10:32
(0) У вас в справочнике подразделений есть реквизит дополнительныесвойства?
Обычно доп.свойства/реквизиты хранятся в регистре сведений ДополнительныеСведения или табличной части справочника ДополнительныеРеквизиты, вот там их и ищите
   Полька
 
3 - 05.12.18 - 10:34
(2) есть. только заполнен не ну всех.
   Полька
 
4 - 05.12.18 - 10:35
т.е. так сделать не получится? придется через запрос?
   azt-yur
 
5 - 05.12.18 - 10:49
(4) Попробуйте так:
ДопСв = РегистрыСведений.ДополнительныеСведения.Получить(Новый Структура("Объект, Свойство", Объект.Ссылка, ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя","трам-пам-пам"))); 
Если ДопСв.Значение <> Истина Тогда
    Отказ = Истина;
КонецЕсли;
   zippygrill
 
6 - 05.12.18 - 10:56
ЗУП 2.5 или 3.0?
И какая КД?
   Полька
 
7 - 05.12.18 - 10:57
в РС Дополнительные Сведения пусто.
   Полька
 
8 - 05.12.18 - 10:58
ЗУП 3.1
КД 2.1
   zippygrill
 
9 - 05.12.18 - 11:11
(8) Тогда точно загляни у спраочника подразделения - ТЧ ДополнительныеРЕКВИЗИТЫ
Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя","трам-пам-пам");
НайденнаяСтрока = Объект.ДополнительныеРеквизиты.Найти(Свойство, "Свойство");
Если НЕ НайденнаяСтрока = Неопределено Тогда
Отказ = не НайденнаяСтрока.Значение;
Иначе
Отказ = Истина;//Свойство не установлено - значит Ложь

КонецЕсли;
   Полька
 
10 - 05.12.18 - 11:13
(9) они то точно там. я разбираюсь- как в правилах сие написать :)
 
 Рекламное место пустует
   Полька
 
11 - 05.12.18 - 11:29
спасибо. получилось

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует