Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1C Отчетность не создается отчет

1C Отчетность не создается отчет
Я
   I_learn_1c
 
04.12.18 - 16:15
Доброго вечера

Подскажите пожалуйста что может быть? В регламентных отчетах жму Создать, в списке выбираю отчет, например Декларация по УСН и вылетает ошибка.
Отладка показывает что Ссылка=неопределено, но почему - не могу выяснить.

{Обработка.ОбщиеОбъектыРеглОтчетности.Форма.ФормаСозданияОтчета.Форма(1058)}: Значение не является значением объектного типа (ИсточникОтчета)
    ИсточникОтчета = Отчет.Ссылка.ИсточникОтчета;


начиная от этого момента ссылка в ТекДеревоОтчетов.ТекущиеДанные  пустая,  а раньше вроде нигде не всплывает...

&НаКлиенте
Процедура ДеревоОтчетовВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    ТекДеревоОтчетов = Элементы.ДеревоОтчетов;
    
    Если ТекДеревоОтчетов.ТекущиеДанные <> Неопределено
        И НЕ ТекДеревоОтчетов.ТекущиеДанные.ЭтоГруппа Тогда
        
        Если Поле.Имя = "ДеревоОтчетовПометка" И НЕ ЕстьПоставляемыйСписок Тогда
            
            Если ТекДеревоОтчетов.ТекущиеДанные.Пометка = 0 Тогда
                ДобавитьОтчетВИзбранные();
            ИначеЕсли ТекДеревоОтчетов.ТекущиеДанные.Пометка = 1 Тогда
                УдалитьОтчетИзИзбранных(ТекДеревоОтчетов.ТекущиеДанные.ПолучитьИдентификатор());
            КонецЕсли;
            
        Иначе
            
            ОткрытьФормуОтчетаНаКлиенте(ТекДеревоОтчетов.ТекущиеДанные, ПараметрыФормы.Организация,
                                        ПараметрыФормы.ДатаНачалаПериодаОтчета,
                                        ПараметрыФормы.ДатаКонцаПериодаОтчета, , Истина);
            
        КонецЕсли;
        
    КонецЕсли;
 
 
   I_learn_1c
 
1 - 04.12.18 - 16:16
(0) заходит в
ОткрытьФормуОтчетаНаКлиенте(ТекДеревоОтчетов.ТекущиеДанные, ПараметрыФормы.Организация,
                                        ПараметрыФормы.ДатаНачалаПериодаОтчета,
                                        ПараметрыФормы.ДатаКонцаПериодаОтчета, , Истина);
   I_learn_1c
 
2 - 04.12.18 - 17:46
(1) up
   I_learn_1c
 
3 - 05.12.18 - 12:06
(2) вдруг у кого-то такая же проблема - в нашем случае не был заполнен справочник Регламентированные отчеты, неизвестно по какой причине. Заполнили - стало все хорошо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует