Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как добавить в список кнопки выбрать все значения,и отменить выделение всех значений

Как добавить в список  кнопки выбрать все значения,и отменить выделение всех значений
Я
   1сЮлия
 
04.12.18 - 12:01
Доброе утро! Как добавить на форму списка две  кнопки выбрать все значения,и отменить выделение всех значений?
вот код.
СпДетал = Новый СписокЗначений;
СпДеталОтмеч = Новый СписокЗначений;
Для каждого Стр из ЭтотОбъект.Состав Цикл
    СпДетал.Добавить(Стр.СерияНоменклатуры,Стр.СерияНоменклатуры,Истина);
КонецЦикла;
ВыборПроизведен = СпДетал.ОтметитьЭлементы("Выберите детали");
Если ВыборПроизведен Тогда
    Для Каждого эл Из СпДетал Цикл
        Если эл.Пометка Тогда
            Для каждого Стр из ЭтотОбъект.Состав Цикл
                 Док = Документы.СертификацияНоменклатуры.СоздатьДокумент();
                 Док.Номенклатура=Стр.Номенклатура;
                 Док.Дата=ТекущаяДата();
                 Док.Организация=УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяОрганизация"); 
                 Док.СерияНоменклатуры=эл.Значение;
                 Док.Записать();
            КонецЦикла;
         КонецЕсли;
       КонецЦикла;

КонецЕсли;
 
 
   1сЮлия
 
1 - 04.12.18 - 12:18
кАК сделать так чтобы эти кнопки добавилисьна форму списка?
Процедура ОтметитьВсе(Команда)
    Для Каждого Стр Из СпДетал  Цикл
        СпДетал.Пометка = ИСТИНА;
    КонецЦикла;
КонецПроцедуры
Процедура СнятьОтметки(Команда)
     Для Каждого Стр Из СпДетал  Цикл
        СпДетал.Пометка = ЛоЖЬ;
    КонецЦикла;
КонецПроцедуры
   Web00001
 
2 - 04.12.18 - 12:26
Ничего не понятно. Ты спрашиваешь как добавить кнопку на форму?
   1сЮлия
 
3 - 04.12.18 - 12:27
Да,чтобы на форме  списка ещё были две кнопи,как в стандартной веделить все значения и отменить выделения.
   catena
 
4 - 04.12.18 - 12:31
Программно?
   1сЮлия
 
5 - 04.12.18 - 12:46
Да.
   catena
 
6 - 04.12.18 - 12:55
КоманднаяПанель.Кнопки.Добавить("ИмяКнопки",ТипКнопкиКоманднойПанели.Действие,ИмяКнопки,Новый Действие("ПроцедураДействияКнопки"));
   1сЮлия
 
7 - 04.12.18 - 13:13
нет я наверное не правильно объяснияю СпДетал.ОтметитьЭлементы("Выберите детали")это окно диалога,где пользователь может выбирать элемент,как мне в это окно добавить ещё  как правильно выбрать все или отменить все.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует