Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отключить расчет НДФЛ в ЗУП3

Отключить расчет НДФЛ в ЗУП3
Я
   Обфускация
 
04.12.18 - 08:06
Есть такая задача. Как отключить типовыми или нетиповыми способами?
 
 
   SleepyHead
 
1 - 04.12.18 - 08:19
Зачем ЗУП 3, если в ней ведется черный расчет?
   Обфускация
 
2 - 04.12.18 - 08:20
(1)
потому что есть еще одна зуп3 белая, проще синхронизировать
   SleepyHead
 
3 - 04.12.18 - 08:25
(0) Пилите расширение.
   Valerianich
 
4 - 04.12.18 - 08:25
В начислениях поставь, что не облагается НДФЛ.
   SleepyHead
 
5 - 04.12.18 - 08:27
(4) Вот зачем  так? Пусть бы помучались. Люди занимаются глупостями, а это не должно быть просто.
   Обфускация
 
6 - 04.12.18 - 08:54
(4)
где конкретно это ставится, пока не вижу такой настройки
   Обфускация
 
7 - 04.12.18 - 08:56
(6)
а все вижу, но у меня опция "не облагается" недоступная стоит
   Натуральный Йог
 
8 - 04.12.18 - 08:57
(7) В РФ для некоторых видов начислений, согласно законодательству, такая опция недоступна
   Convert
 
9 - 04.12.18 - 08:59
(7) Групповое изменение реквизитов
   Обфускация
 
10 - 04.12.18 - 11:21
В общем решила проблему, разблокировав элементы на форме. Всем спасибо, кто отозвался.

&НаКлиентеНаСервереБезКонтекста
Процедура УстановитьДоступностьКодаДоходаНДФЛ(Форма)
     
    ОбязательноЗаполнять = Форма.КатегорииКодДоходаНДФЛНеЗаполняется.Найти(Форма.Объект.КатегорияНачисленияИлиНеоплаченногоВремени) = Неопределено;
    
    //Форма.Элементы.ОблагаетсяНДФЛЧисло0.Доступность = Форма.КодДоходаНДФЛДоступностьПоКатегории И Не ОбязательноЗаполнять;

    //Форма.Элементы.ОблагаетсяНДФЛЧисло1.Доступность = Форма.КодДоходаНДФЛДоступностьПоКатегории;

    
    Форма.Элементы.ОблагаетсяНДФЛЧисло0.Доступность = истина;
    Форма.Элементы.ОблагаетсяНДФЛЧисло1.Доступность = истина;

    
    //Если ОбязательноЗаполнять Тогда

    //    Форма.ОблагаетсяНДФЛ = 1;

    //КонецЕсли;

    
    //ДоступностьКодаНДФЛ = Форма.ОблагаетсяНДФЛ = 1 И Форма.КодДоходаНДФЛДоступностьПоКатегории;

    
    Форма.Элементы.КодДоходаНДФЛ.Доступность = истина;
    //ДоступностьКодаНДФЛ;

    //Форма.Элементы.КодДоходаНДФЛ.АвтоОтметкаНезаполненного = ДоступностьКодаНДФЛ;

    //Форма.Элементы.КодДоходаНДФЛ.ОтметкаНезаполненного = Не ЗначениеЗаполнено(Форма.Объект.КодДоходаНДФЛ);

    
    Если Форма.ОблагаетсяНДФЛ = 0 Тогда
        Форма.Объект.КодДоходаНДФЛ = Неопределено;
    КонецЕсли;
    
КонецПроцедуры
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует