Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11. 4 Как настроить выборочный перенос данных из УТ в БП?

УТ 11. 4 Как настроить выборочный перенос данных из УТ в БП?
Я
   wms
 
03.12.18 - 16:27
УТ 11. 4 Как настроить выборочный перенос данных из УТ в БП?
Например мне не нужно переносить Физических лиц.

Есть такой ответ:При обмене между конфигурациями иногда возникает потребность, в том чтобы выборочно переносить объекты из Управления торговлей в бух. программу. Для этого нужно зайти в настройки синхронизации в "Управление торговлей", перейти в "Состав отправляемых данных". Далее воспользоваться командой "Отменить регистрацию объекта" либо "Отменить регистрацию всех объектов выбранных типов", предварительно отметив галочкой нужные документы или справочники. Затем выполнить синхронизацию.

А как настроить чтобы физ.лица НИКОГДА не переносились в БП?
 
 
   wms
 
1 - 03.12.18 - 16:27
Синхронизация настроена через универсальный формат.
Конфа УТ 11 на поддержке
   Полбатона
 
2 - 03.12.18 - 16:29
снимай каждый раз объекты с регистрации
   MaxS
 
3 - 03.12.18 - 16:33
В КД2 нужно отредактировать правила регистрации и загрузить в настройки обмена.
   wms
 
4 - 03.12.18 - 16:33
наверно надо добавить расширение и при записи Физ.лица снимать его с регистрации. где они там регистрируются? План обмена "СинхронизацияДанныхЧерезУниверсальныйФормат" ? там стоит запрет авторегистрации для физ.лиц
   Полбатона
 
5 - 03.12.18 - 16:34
(3) ало, это телевидение? там универсальный формат обмена
   wms
 
6 - 03.12.18 - 16:35
(3) а как эти правила выгрузить из УТ 11? пункт загрузить правила там есть, а выгрузить чтобы посмотреть не нашел
   yzimin
 
7 - 03.12.18 - 16:39
(5) Почитай как в ED регистрируются объекты и где пишут правила регистрации)))
   yzimin
 
8 - 03.12.18 - 16:39
(0) Если не хочется каждый раз править правила регистрации, можно в подписке ПередЗаписью прописать
        Источник.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
   Полбатона
 
9 - 03.12.18 - 16:41
(7)  прям в КД2 пишутся, не в КД3??
   wms
 
10 - 03.12.18 - 16:47
(8) спасибо. попробую в этом направлении.
 
 Рекламное место пустует
   MaxS
 
11 - 03.12.18 - 16:50
(9) Да. Правила регистрации в КД2, правила обмена в КД3.
Спорим не зная материал? ;)
   wms
 
12 - 03.12.18 - 17:00
+(10) хотя нет. надо по другому. Физ.лицо может же и по ссылке выгрузиться как реквизит пользователя.
Надо как то без регистрации и снятия модулей с поддержки
   wms
 
13 - 03.12.18 - 17:01
там вроде как можно к обмену подцепить "Менеджер обмена данными" и там поправить.
   MaxS
 
14 - 03.12.18 - 17:05
(12) По ссылке выгружаются только ключевые данные, на их основе не создаётся элемент.
(13) 1С выпиливает этот функционал. В БП 3.0.66 он не работает. В УТ можно попробовать, но для мелких доработок лучше расширение вместо того, чтобы тянуть все правила.
   wms
 
15 - 03.12.18 - 18:28
Доработал УТ.Попробовал 2 способа. Не даляет регистрацию, хотя в отладчике данный код отрабатывает.
В расширении Справочника Физ.Лица добавил код:


//1 способ

&Перед("ПередЗаписью")
Процедура Расш1_ПередЗаписью(Отказ)
    ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");    
КонецПроцедуры

//2 способ


&После("ПриЗаписи")
Процедура Расш1_ПриЗаписи(Отказ)
Узел = ПланыОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат.НайтиПоКоду("ПБ");
Если не Узел.Пустая() Тогда
    ПланыОбмена.УдалитьРегистрациюИзменений(Узел, Ссылка);    
КонецЕсли; 
КонецПроцедуры
   wms
 
16 - 03.12.18 - 18:29
естественно в расширение добавил и план обмена СинхронизацияДанныхЧерезУниверсальныйФормат и справочник Физ.Лица
   wms
 
17 - 03.12.18 - 18:30
Перезаписываю физ.лицо и оно регистрируется для отправки
   MaxS
 
18 - 03.12.18 - 19:41
в процедуре ПОД_Справочник_ФизическиеЛица_Отправка_ПриОбработке
добавить в начале: 
УстановитьИспользованиеПКО(ИспользованиеПКО, Ложь);
Возврат;

Наверное аналогичное добавить для 
Справочник_ФИОФизическихЛиц_Отправка
Справочник_ДокументыФизическихЛиц_Отправка

Выгруженное по ссылкам будет в виде битых ссылок.
   wms
 
19 - 04.12.18 - 15:03
(18) спасибо. сделал так с помощью расширения, оказывается можно и не экспортную процедуру вызывать из общего модуля в расширении:
&Вместо("ПОД_Справочник_ФизическиеЛица_Отправка_ПриОбработке")
Процедура ив_ПОД_Справочник_ФизическиеЛица_Отправка_ПриОбработке(ДанныеИБ, ИспользованиеПКО, КомпонентыОбмена)
    ЗаписьЖурналаРегистрации("ОбменУТ->БП",,,,"Выгрузка физ.лица отменена");
    УстановитьИспользованиеПКО(ИспользованиеПКО, Ложь);
    Возврат;    
КонецПроцедуры


Выгрузил в бухгалтерию. Физлица не создаются, но в документах, там где ответственные много "<Объект не найден> (296:8fb140167e02a9e511e8f7b79372f692)" не красиво. Как бы это убрать?
   wms
 
20 - 04.12.18 - 17:09
ап
   MaxS
 
21 - 05.12.18 - 10:38
(19) Возврат перед  КонецПроцедуры в данном случае не обязателен ;)
Чтобы не выгружать по ссылке - нужно либо доработать все ПКС, либо что-то сделать с ПКС физлиц. Не экспериментировал можно ли подставить другую ссылку - какое-нибудь общее для всех физлицо.
В процедуре перед конвертацией в правилах делал поиск по всем ПКС - в шапке и в табличных частях и удалял это ПКС из ПКО.
   MaxS
 
22 - 05.12.18 - 10:53
(21) 2. + либо что-то сделать с ПКО физлиц
1. - это программное удаление всех ненужных ПКС из всех ПКО.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует