Вход | Регистрация


Работа :: Заказы

Забор файлов по электронной почте из 1С

Забор файлов по электронной почте из 1С
Я
   ProProg
 
30.11.18 - 15:56
Есть справочник контрагенты, вбиты адреса.
Есть почта.

1) проверять почту с этими адресами
2) файлы - вложения закидывать каждый в отдельную папку

времени нет ковырятся, заплачу за реализацию
 
 
   ProProg
 
1 - 30.11.18 - 15:56
должно выполнятся естественно фоновым заданием.
   Aleksey
 
2 - 30.11.18 - 15:59
А 500 000 за выполнения потянешь? Плюс 20% за срочность
   ProProg
 
3 - 30.11.18 - 16:00
(2) за 500 000 я на Мальдивы с телкой сиськами 5 размера поеду.
   МихаилМ
 
4 - 30.11.18 - 16:07
модераторы, перенесите тему в раздел "Работа".
   Fragster
 
5 - 30.11.18 - 16:08
согласовано?
   Aleksey
 
6 - 30.11.18 - 16:09
(3) а зачем мне нищеброды?
   andreymongol82
 
7 - 30.11.18 - 16:14
(3) Согласен за 250 съездить на майорку с телкой с сиськами 4-го размера
   ProProg
 
8 - 30.11.18 - 16:16
(4) зачем? если хочешь можешь и бесплатно написать и сюда опубликовать. Кому то пригодится!
   Aleksey
 
9 - 30.11.18 - 16:20
(8)  в разных типовых разная логика работы с почтой. Что работает в унф не работает в бп. Я уж молчу про то что к разным ящикам по разному подключается. Ибо к Gmail вряд ли по pop 3 подключишься. Так что кому эта подделка нужна?
   Greeen
 
10 - 30.11.18 - 16:21
демпингую, за 100 тр с 1 размером..
 
 Рекламное место пустует
   ProProg
 
11 - 30.11.18 - 16:28
с вашим флудом уже быстрее самому написать...
   ProProg
 
12 - 30.11.18 - 16:36
Дарю миру
   ProProg
 
13 - 30.11.18 - 16:37
Профиль = Новый ИнтернетПочтовыйПрофиль;
        Профиль.АдресСервераSMTP = Объект.УчетнаяЗапись.СерверИсходящейПочты;
        Профиль.АдресСервераPOP3 = Объект.УчетнаяЗапись.СерверВходящейПочты;
        Профиль.ПортSMTP = Объект.УчетнаяЗапись.ПортСервераИсходящейПочты;
        Профиль.ПортPOP3 = Объект.УчетнаяЗапись.ПортСервераВходящейПочты;
        Профиль.АутентификацияSMTP = Объект.УчетнаяЗапись.СпособSMTPАутентификации;
        ПРофиль.АутентификацияPOP3 = Объект.УчетнаяЗапись.СпособPOP3Аутентификации;
        Профиль.Пользователь = Объект.УчетнаяЗапись.ПользовательSMTP;
        Пароли = ОбщегоНазначения.ПрочитатьДанныеИзБезопасногоХранилища(Объект.УчетнаяЗапись, "Пароль, ПарольSMTP");
        Профиль.Пароль = Пароли.Пароль;
        Профиль.ПарольSMTP = Пароли.ПарольSMTP;
        
        Почта = Новый ИнтернетПочта;
        Почта.Подключиться(Профиль, "");
        
        МассивСообщений = Почта.Выбрать(Ложь);    
        Для Каждого Сообщение из МассивСообщений Цикл
            ПараметрыОтбора = Новый Структура;
            ПараметрыОтбора.Вставить("СообщениеОтправитель", Сообщение.Отправитель);
            НайденыСтроки = Объект.ТаблицаПартнеров.НайтиСтроки(ПараметрыОтбора);
            
            Для Каждого ВыборкаПартнер Из НайденыСтроки Цикл
                КаталогДляСохранения = ВыборкаПартнер.КаталогНаЛокальномДиске;
                Для Каждого Вложение из Сообщение.Вложения Цикл
                    //Сообщить(Вложение.Имя);  
                    
                    ПутьДоФайла = КаталогДляСохранения+""+Вложение.Имя;
                    Вложение.Данные.Записать(ПутьДоФайла);
                КонецЦикла;
                
            КонецЦикла;
        КонецЦикла;
        
        Почта.Отключиться();
   ProProg
 
14 - 30.11.18 - 16:45
Так как никто не сделал, я никому не заплатил, написал сам и выложил.

Все кто прочитает, может пожертвовать лишние 100 рублей вот этому человеку

OFF: Нужна помощь ребенку. Осталось собрать 194000 руб
   Aleksey
 
15 - 30.11.18 - 19:42
(14) а сам что? Ты же был готов заплатить за код. Сам написал, вот себе и заплати, а потом полученные деньги перечисли.
   ProProg
 
16 - 02.12.18 - 14:52
Немного переписал код. Тестирую. Что то какая то полная шляпа.
Например я отправил на тест себе письма с вложениями. Проверяю почту - с выдачей сообщений. какая то туфта.
   ProProg
 
17 - 02.12.18 - 14:52
Вот например код

ПараметрыОтбора = Новый Структура;
        ПараметрыОтбора.Вставить("Новые", Истина);
        //ПараметрыОтбора.Вставить("Прочитанные", Ложь);
        Заголовки = Соединение.ПолучитьЗаголовки(ПараметрыОтбора);
        Если Заголовки.Количество() = 0 Тогда
            Сообщить("На сервере нет сообщений!");
            Возврат;
        КонецЕсли;
        
        МассивСообщений = Соединение.Выбрать(Ложь,Заголовки,Истина);    
        Для Каждого Сообщение из МассивСообщений Цикл
            Сообщить(""+Сообщение.Отправитель.Адрес+"   "+Сообщение.Тема+"    "+Сообщение.ДатаОтправления);
   ProProg
 
18 - 02.12.18 - 14:54
Тут с чтением заголовков и отборов.
Смотрю сообщения и тп. фактически в ящике 1 письмо новое.
А выдает 670 сообщений с разными адресами и темами. от 14 года по текущий.

Причем неясно почему только 670, если уже гребет все то у меня там тысячи. Начинаю проверять некоторые, вообще фиг поймешь по какому критерию оно выбрало.
   ДенисЧ
 
19 - 02.12.18 - 14:55
@с выдачей сообщений. какая то туфта.@

Гениалное по соедержанию сообщение.... За Включение моего телепата я потребую 50000 рублей
   ProProg
 
20 - 02.12.18 - 14:58
Отборы пробовал разные. один фиг читает одно и тоже)
   ProProg
 
21 - 02.12.18 - 14:58
(19) а ничего что ниже все пояснения?
   ДенисЧ
 
22 - 02.12.18 - 15:01
(21) ТАк и и ви не заплатили пока ещё за поговорить.... Ни тестового стенда, нит даннных....
   ProProg
 
23 - 02.12.18 - 15:04
Убрал отборы и предварительное получение заголовков) в результате все равно считывает одно и тоже)
Не работают методы 1С...короче.
   ProProg
 
24 - 02.12.18 - 16:15
Все ясно! Работает только с IMAP
   МимохожийОднако
 
25 - 02.12.18 - 17:47
А мужики-то не знали


Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
В секцию Заказы можно добавлять сообщения только после регистрации на форуме.
Если вы уже зарегистрированы, вам нужно войти на форум.
Рекламное место пустует