Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УТ 10.3.49.2 и ЕГАИС

УТ 10.3.49.2 и ЕГАИС
Я
   Scorched
 
29.11.18 - 22:44
Долго не обновлял ут 10.3, но внезапно понадобилась поддержка егаис v3 и обновился до УТ 10.3.49.2
Раньше, при розничной продаже после сканирования ШК алкогольной продукции появлялось окно с предложением сосканировать акцизку. Сейчас окно не вылезает, вываливается в ошибку в модуле ТОСервер
    Если Не ЗначениеЗаполнено(Результат) и ТипШК = "PDF417" Тогда
        Клиент.СШКОбработатьШтрихкод(ШК);
        Возврат Результат;
    КонецЕсли;

Что нужно поправить, чтобы заработало?
Спасибо.
 
 
   Scorched
 
1 - 30.11.18 - 08:35
Ап
   Vadim_37
 
2 - 30.11.18 - 08:39
Текст ошибки бы увидеть
   Vstur
 
3 - 30.11.18 - 12:05
(0) 10.3.49.2 уже отозвали, правда из-за других ошибок
   Scorched
 
4 - 01.12.18 - 15:27
Ну уж если накатил...

Ковыряюсь в коде. Доковырялся до того, что при сканировании акцизки ругается

обработка кодов с datamatrix в документе чек ккм не поддерживается

Нигде по ЕГАИС ут 10.3 инфы нет. Кассир какой то не тот код пикает?
   Scorched
 
5 - 03.12.18 - 10:12
Раньше (10.3.47.3), после считывания штрихкода, в случае алкогольной продукции вываливалось окно сканирования акцизки.
Сейчас (10.3.49.1) после считывания штрихкода не вылезает никакого окна, при сканировании акцизки вываливается ошибка
 Если Не ЗначениеЗаполнено(Результат) и ТипШК = "PDF417" Тогда
        Клиент.СШКОбработатьШтрихкод(ШК);
        Возврат Результат;
    КонецЕсли;

Как оно должно работать? Где посмотреть?
   zippygrill
 
6 - 03.12.18 - 10:14
Имей ввиду - когда сканируешь EAN13 алкоголя, то после вызывается как ты говоришь окно считывания pdf417.
В случае если ты сразу считаешь pdf417 то алгоритм расшифровывает марку, получает код ЕГАИС и по ней ищет соответствие номенклатуры. Нашлось соответствие - подставилось сразу в чек или документ.
   Scorched
 
7 - 03.12.18 - 10:47
То ли обновился криво, но у меня при сканировании pdf417
приходит в этот кусок кода

 Если Не ЗначениеЗаполнено(Результат) и ТипШК = "PDF417" Тогда
        Клиент.СШКОбработатьШтрихкод(ШК);
        Возврат Результат;
    КонецЕсли;

 
При этом процедура СШКОбработатьШтрихкод есть только у формы "ФормаСканированияАкцизнойМарки", которая не вызывается ранее нигде в коде.
   zippygrill
 
8 - 03.12.18 - 10:57
НУ так покажи эту функцию. И смотри сам и пойми что в ней происходит. Может происходит так как я  описал
   Scorched
 
9 - 03.12.18 - 11:32
Это я к чему. Оно у всех так не работает? Кто-то пользуется УТ 10.3 с ЕГАИСом?
   Сияющий в темноте
 
10 - 03.12.18 - 13:38
49.2 просто г.на палочке.
а 49.1 не лучше-эти дармоеды реализацию sha256 в коде 1с написали для подписывания сохраненных файлов Егаис,но с кучей ошибок и тормозов,если файлы хранить,то при обновлении имеем облом.

и,это в 49.2,если хоть что-то работает-это чудо-даже меню Егаис только в интерфейсе розничная торговля достается.
а проверка марок при получении-забыли сканер подцепить,и надо ф7 давить перед каждой маркой.

P.s.когда студенты сдают курсовую,то онп чем-то похожа на 49.2,вроде бы,все есть и что-то работает,но за 49.2 явный незачет.
 
 Рекламное место пустует
   Vstur
 
11 - 05.12.18 - 12:25
49.3 вышла
   zzz7777
 
12 - 07.12.18 - 09:51
Обновился на 49.3. Та же ошибка осталась
   kymar
 
13 - 08.12.18 - 17:52
Такая же проблема:(
   zzz7777
 
14 - 14.12.18 - 10:17
10.49.4 вышел релиз. Кто-нибудь обновился ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует