Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Просмотр сеансов на сервере

Просмотр сеансов на сервере
Я
   satoru
 
29.11.18 - 11:28
Необходимо предоставить только просмотр списка сеансов по всем информационным базам на 1С Сервере для главного бухгалтера.

Платформа 8.3.10.2168
 
 
   ytex
 
1 - 29.11.18 - 11:34
Вроде объявление о работе, тут платные.
   ДенисЧ
 
2 - 29.11.18 - 11:40
А зачем главбуху заниматься работой сисадмина?
   satoru
 
3 - 29.11.18 - 11:44
Она хочет контролировать количество используемых лицензий. Поэтому нужен только просмотр, без возможности добавлять, удалять базы с сервера, завершать сеансы. Нужен только просмотр!
   PR
 
4 - 29.11.18 - 11:46
Пусть активные сеансы смотрит через 1С
   Cyberhawk
 
5 - 29.11.18 - 11:46
Сколько платят за решение вопроса?
   Numerus Mikhail
 
6 - 29.11.18 - 11:47
(3) Ей это не надо
   satoru
 
7 - 29.11.18 - 11:48
(4) нужно все базы сразу (7 баз).
   Полбатона
 
8 - 29.11.18 - 11:49
(3) только после того, как программист будет контролировать сдачу отчетности, корректность учета можно разрешить бухгалтеру смотреть лицензии
   satoru
 
9 - 29.11.18 - 11:51
все понятно, решения нет.
   satoru
 
10 - 29.11.18 - 11:51
Я так понял в консоли сервера настройки прав доступа нет.
 
 Рекламное место пустует
   Полбатона
 
11 - 29.11.18 - 11:51
(9) есть. 5 тыс. руб
   satoru
 
12 - 29.11.18 - 11:53
(11) Демо-версия решения есть?
   Мыш
 
13 - 29.11.18 - 12:07
(11) Подвинься. Расскажу за 4999 руб )
   satoru
 
14 - 29.11.18 - 12:14
(13) я слышу 4999, кто меньше)
В общем если найду информацию опубликую решение. Бесплатно!
   ptiz
 
15 - 29.11.18 - 12:18
(0)
Коннектор = Новый COMОбъект("V83.COMConnector");
СоединениеСАгентом = Коннектор.ConnectAgent(ИмяСервера1С);

И вперед.
   satoru
 
16 - 29.11.18 - 17:21
(15) Спасибо за инфу.
   satoru
 
17 - 29.11.18 - 17:21
И вот процедура как и обещал:


    СтрокаСоединенияСБД = СтрокаСоединенияИнформационнойБазы();    
    ПозицияПоиска = Найти(Врег(СтрокаСоединенияСБД), "SRVR=");
    Если ПозицияПоиска = 0 Тогда
        Предупреждение("База должна быть серверной!");
        Возврат;
    КонецЕсли;
    ПозицияОкончания = СтрНайти(СтрокаСоединенияСБД,""";Ref=""");
    ИмяСервера = Сред(СтрокаСоединенияСБД,7,ПозицияОкончания-7);
    
    Коннектор = Новый COMОбъект("V83.COMConnector");
    СоединениеСАгентом = Коннектор.ConnectAgent(ИмяСервера);
    //получаем кластер

    мКластер = Неопределено;
    Кластеры = СоединениеСАгентом.GetClusters();
    Для Каждого Кластер Из Кластеры Цикл
        мКластер = Кластер;
    КонецЦикла;
    Если мКластер = Неопределено Тогда
        Предупреждение("Не найдено ни одного кластера!");
        Возврат;
    КонецЕсли;
    //

    СоединениеСАгентом.Authenticate(Кластер, , );
    мСеансы = СоединениеСАгентом.GetSessions(Кластер);
    Сеансы.Очистить();
    Лицензии.Очистить();
    Для каждого Сеанс из мСеансы Цикл
        //новый сеанс

        НовыйСеанс = Сеансы.Добавить();
        //заполняем

        НовыйСеанс.Компьютер = Сеанс.Host;
        НовыйСеанс.База = Сеанс.infoBase.Name;
        НовыйСеанс.Пользователь = Сеанс.userName;
        НовыйСеанс.ДатаПодключения = Сеанс.StartedAt;
        НовыйСеанс.ДатаПоследнейАктивности = Сеанс.LastActiveAt;
        НовыйСеанс.Лицензия = Сеанс.License.Series;
    КонецЦикла;
   satoru
 
18 - 29.11.18 - 17:22
Частично вдохновился с этой статьи: http://catalog.mista.ru/public/77671/

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует