Вход | Регистрация


Как передать параметр в процедуру обработчике ожидания

Как передать параметр в процедуру  обработчике ожидания
Я
   gabd_marat
 
28.11.18 - 17:57
Как передать параметр Элемент в процедуру ОболочкаОбработчика(Элемент) обработчике ожидания
&НаКлиенте
Процедура ОПРиСМППриАктивизацииЯчейки(Элемент)

    ПодключитьОбработчикОжидания("ОболочкаОбработчика", 0.1 , Истина);
    
    ОтключитьОбработчикОжидания("ОболочкаОбработчика");
    
КонецПроцедуры

&НаКлиенте
Процедура  ОболочкаОбработчика(Элемент)
    
    Если Элемент.ТекущийЭлемент.Имя = "Сотрудники" Тогда
        ЭтаФорма.Элементы.ПросмотретьИсторию.Доступность = Ложь;
        ЭтаФорма.Элементы.ПросмотретьИсторию.Видимость = Ложь;
    Иначе
        Элементы.ПросмотретьИсторию.Доступность = Истина;
        Элементы.ПросмотретьИсторию.Видимость = Истина;
    КонецЕсли; 
    
КонецПроцедуры
 
 
   lodger
 
1 - 28.11.18 - 18:31
в начале модуля формы
Перем МойКэшированныйФлаг;

&НаКлиенте
Процедура ОПРиСМППриАктивизацииЯчейки(Элемент)

    ПодключитьОбработчикОжидания("ОболочкаОбработчика", 0.1 , Истина);
    МойКэшированныйФлаг = Элемент.ТекущийЭлемент.Имя = "Сотрудники";
КонецПроцедуры

&НаКлиенте
Процедура  ОболочкаОбработчика(Элемент)
    
    Если МойКэшированныйФлаг Тогда
        ЭтаФорма.Элементы.ПросмотретьИсторию.Доступность = Ложь;
        ЭтаФорма.Элементы.ПросмотретьИсторию.Видимость = Ложь;
    Иначе
        Элементы.ПросмотретьИсторию.Доступность = Истина;
        Элементы.ПросмотретьИсторию.Видимость = Истина;
    КонецЕсли; 
    ОтключитьОбработчикОжидания("ОболочкаОбработчика");
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует