Вход | Регистрация


ПриАктивацииЯчейки порождает бесконечный цикл

ПриАктивацииЯчейки порождает бесконечный цикл
Я
   gabd_marat
 
28.11.18 - 17:22
&НаКлиенте
Процедура ОПРиСМППриАктивизацииЯчейки(Элемент)

    Если Элемент.ТекущийЭлемент.Имя = "Сотрудники" Тогда
        ЭтаФорма.Элементы.ПросмотретьИсторию.Доступность = Ложь;
        ЭтаФорма.Элементы.ПросмотретьИсторию.Видимость = Ложь;
    Иначе
        Элементы.ПросмотретьИсторию.Доступность = Истина;
        Элементы.ПросмотретьИсторию.Видимость = Истина;
    КонецЕсли;      
    
КонецПроцедуры
 
 
   Franchiser
 
1 - 28.11.18 - 17:25
Нет тут цикла
   youalex
 
2 - 28.11.18 - 17:25
Обработчик ожидания
   gabd_marat
 
3 - 28.11.18 - 17:26
Не цикл, а бесконечный повтор выполнения кода в теле обработчика
   gabd_marat
 
4 - 28.11.18 - 17:27
(2) А в чем причина такого поведения события?
   Numerus Mikhail
 
5 - 28.11.18 - 17:31
(4) Изменение видимости перерисовывает форму заново, а это уже вызывает срабатывание триггера активации строки
   gabd_marat
 
6 - 28.11.18 - 17:31
(5) Понятно
   gabd_marat
 
7 - 28.11.18 - 18:01
(2) Как работать с обработчиком ожидания?

&НаКлиенте
Процедура ОПРиСМППриАктивизацииЯчейки(Элемент)

    ПодключитьОбработчикОжидания("ОболочкаОбработчика", 0.1 , Истина);
    
    ОтключитьОбработчикОжидания("ОболочкаОбработчика");
    
КонецПроцедуры

&НаКлиенте
Процедура  ОболочкаОбработчика(Элемент)
    
    Если Элемент.ТекущийЭлемент.Имя = "Сотрудники" Тогда
        ЭтаФорма.Элементы.ПросмотретьИсторию.Доступность = Ложь;
        ЭтаФорма.Элементы.ПросмотретьИсторию.Видимость = Ложь;
    Иначе
        Элементы.ПросмотретьИсторию.Доступность = Истина;
        Элементы.ПросмотретьИсторию.Видимость = Истина;
    КонецЕсли; 
    
КонецПроцедуры
   lubitelxml
 
8 - 28.11.18 - 18:04
(7) гугл тебе в помощь
   Eiffil123
 
9 - 28.11.18 - 18:12
а зачем видимость колонки менять? это выглядит совершенно стремно. Не проще для нужных ячеек просто пустой текст показывать или писать серым шрифтом "не применимо"?
   gabd_marat
 
10 - 28.11.18 - 18:15
(9) Это не видимость колонки а видимость кнопки
 
 Рекламное место пустует
   Eiffil123
 
11 - 29.11.18 - 12:17
(10) тогда совет из п (7).

Конечно это не очень хорошо для производительности, т.к. пользователи имеют привычку прокручивать списки стрелками на клавиатуре (вверх и вниз), при этом по каждой новой строке форма будет перерисовываться.
   youalex
 
12 - 29.11.18 - 12:31
(7) ОтключитьОбработчикОжидания - там лишнее

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует