Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Выбрать одинаковые элементы из таблицы значений.

v7: Выбрать одинаковые элементы из таблицы значений.
Я
   progaoff
 
27.11.18 - 17:03
Добрый день, подскажите как из таблицы значений полученную из запроса, выбрать одинаковые элементы.
 
 
   Garykom
 
1 - 27.11.18 - 17:16
Свернуть
   progaoff
 
2 - 27.11.18 - 17:20
(1) если бы не одно НО, смысл этого действия таков, имеем табличную часть, в эту табличную часть добавляются строки с договорами и объектами закрепленными за договором, в договоре может быть несколько разных объектов, вот мне и нужно проставить на против каждого одинакового 1.
   uno-group
 
3 - 27.11.18 - 17:33
Сортировать. Пройти сравнивая соседние значения
   КонецЦикла
 
4 - 27.11.18 - 17:46
Можно использовать индексированную таблицу и группировать
Во вложенной таблице сразу видно кол-во строк будет
   Garykom
 
5 - 27.11.18 - 17:46
(2) Для тех кто в танке:
ТЗ.Свернуть("ИменаКолонокГруппировкиЧерезЗапятую", "ИменаКолонокСуммированияЧерезЗапятую")
   Kigo_Kigo
 
6 - 27.11.18 - 17:47
Тз.Сортировать("Договор+");
Тз.ПолучитьСтрокуПоНомеру(1);
ДоговорТЗ = Тз.Договор;
Тз.Выбратьстроки();

Пока Тз.ПолучитьСтроку() = 1 цикл
Если ДоговорТЗ  = Тз.Договор Тогда
//Тот же договор

Иначе
//Договор Сменился

ДоговорТЗ = Тз.Договор;
КонецЕсли;
КонецЦикла;
   Garykom
 
7 - 27.11.18 - 17:48
Договор1|Объект1|1
Договор1|Объект1|1
Договор2|Объект2|1

После Свернуть("Договор, Объект", "Количество")
Будет
Договор1|Объект1|2
Договор2|Объект2|1
   Kigo_Kigo
 
8 - 27.11.18 - 17:48
(5) Ему не надо сворачивать, ему надо сортировать
   Garykom
 
9 - 27.11.18 - 17:50
(8) "выбрать одинаковые элементы" надо
   Kigo_Kigo
 
10 - 27.11.18 - 17:51
(9) Пусть сам решает как ему надо :)
 
 Рекламное место пустует
   Злопчинский
 
11 - 27.11.18 - 19:51
ТЗсодинаковымиЭлементами = глОтобратьПоКолонке(ТЗисходная,ИмяКолонки,ЗначениеОтбораПоКолонке)
   Злопчинский
 
12 - 27.11.18 - 19:52
то есть в ТЗсодинаковыми элементами получаешь подмножество исходнйо таблицы. А потом уже смотря что тебе надо - можно сворачивать по другим реквизитам итд
   Злопчинский
 
13 - 27.11.18 - 19:52
если использовать ИндекситрованнуюТЗ - то там еще проще-няшнее-кузявее
   Гад
 
14 - 27.11.18 - 19:53
Кароч никак
   Злопчинский
 
15 - 27.11.18 - 20:06
(14) неверный ответ
   Гад
 
16 - 27.11.18 - 20:12
(15) сорь...переформулирую "ну можно так или так но ты тепил не понимаешь кароч никак"
   АгентБезопаснойНацио
 
17 - 27.11.18 - 20:36
(16) вариантов много. Начиная от сортировки прям в запросе, и однопроходного подсчёта, до группировки индексированных таблицы, или построения уникального индекса, получения уникальных значений, и фильтрации.
   Злопчинский
 
18 - 28.11.18 - 00:51
вот как для 77 сделать индекс с уникальными значениями, но при этом пустые значения допускаются неуникальные? - например тупо разрешит в ТиС запись единиц (по всему справочнику) только с уникальными ШК и ьтакже разрешить запись единиц с незаполненными ШК
   Cthulhu
 
19 - 28.11.18 - 01:57
(18): а чо, в 7-ке можно штатно делать и юзать индексы к таблицам данных???
или ты об чом?
   Garykom
 
20 - 28.11.18 - 02:33
(18) А "единиц с незаполненными ШК" может быть несколько для одной номенклатуры?

Короче справочник ШК подчиненный единицам, сам ШК в уникальный код во всем этом доп. справочнике.
   Garykom
 
21 - 28.11.18 - 02:35
(20)+ Конечно это слегка прикольно когда будет тройная подчиненность Номенклатура < ЕдиницыНоменклатуры < ШКЕдиницНоменклатуры, но зато работает как нуна.

Примерно нечто похожее было в одной конфе, но там еще было осложнено Партиями между Номенклатурой и ЕдиницамиНоменклатуры ))
   Cthulhu
 
22 - 28.11.18 - 02:37
(18): barcode+if(isemty(barcode),0,recno)
   Cthulhu
 
23 - 28.11.18 - 02:38
блин наоборот. barcode+if(isemty(barcode),recno,"0")
   Злопчинский
 
24 - 28.11.18 - 02:46
(19) а ты шо, не знал? галочками "сортировка", "отбор", "быстрая обработка движений" и прочими...
в снеговике походу таких "галочек" больше во много раз и раставлятели крыжиков нихрена не понимают нафига это.. (это если злобно)
   Злопчинский
 
25 - 28.11.18 - 02:47
(20) А "единиц с незаполненными ШК" может быть несколько для одной номенклатуры?

в простом варианте реализации привязки штрихкодов и единиц - ДА
   Злопчинский
 
26 - 28.11.18 - 02:48
(20) "Короче справочник ШК подчиненный единицам, сам ШК в уникальный код во всем этом доп. справочнике."
- ну это уже нетиповая конфига... ;-)
   Злопчинский
 
27 - 28.11.18 - 02:50
(21) "Конечно это слегка прикольно когда будет тройная подчиненность Номенклатура < ЕдиницыНоменклатуры < ШКЕдиницНоменклатуры, но зато работает как нуна. "
- примерно так сделано во всяких ВМС. но это только вторая стадия изощренности, вызваная требованиями универсальности и многобразия возможных схем учета
   Злопчинский
 
28 - 28.11.18 - 02:53
   progaoff
 
29 - 03.12.18 - 10:43
(27) может есть вариант по проще?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует