Вход | Регистрация



почему не могу установить ДополнительныеСвойства объектам?

почему не могу установить ДополнительныеСвойства объектам?
Я
   inkvizitr
 
27.11.18 - 15:47
Процедура СписокПриАктивизацииСтроки(Элемент)
МассивСтрок = Элементы.Список.ВыделенныеСтроки;
Если МассивСтрок.Количество() > 1 Тогда
    test(МассивСтрок);       
КонецЕсли;


&НаСервере
Процедура test(МассивСтрок)
                Для каждого Строка Из МассивСтрок Цикл
                               Документ = Строка.Ссылка.ПолучитьОбъект();
                               Документ.ДополнительныеСвойства.Свойство("ГрупповоеПерепроведение", Истина);
                КонецЦикла;    
КонецПроцедуры
 
 
   inkvizitr
 
1 - 27.11.18 - 15:49
т.е. есть документ к примеру поступление, из формы списка выбираю более 2-х записей и хочу им присвоить дополнительные свойства, в строке "Документ = Строка.Ссылка.ПолучитьОбъект();" тип ДокументОбъект
   PR
 
2 - 27.11.18 - 15:49
Что это?
   inkvizitr
 
3 - 27.11.18 - 15:50
Это тестовый пример, для того, чтобы при выделения документов с имитировать групповое перепроведение
   PR
 
4 - 27.11.18 - 15:51
(1) А нахрена ты получаешь объект, устанавливаешь допсвойство объекта и... и всё?
Зашел в магазин, попросил взвесить полкило ливерной и... и ушел
   inkvizitr
 
5 - 27.11.18 - 15:51
т.е. групповое перепроведение выделенных документов одного типа
   PR
 
6 - 27.11.18 - 15:52
(3) Да нет, это у тебя хрень какая-то
При перепроведении объект будет заново получаться
   inkvizitr
 
7 - 27.11.18 - 15:52
(4) а как тогда правельнее?
   Homer
 
8 - 27.11.18 - 15:52
(0)За такой код надо выгонять с работы
   inkvizitr
 
9 - 27.11.18 - 15:53
я в рабочию базу и не пишу, я разбираюсь с доп свойствами
   Ник080808
 
10 - 27.11.18 - 15:54
(0)        Для каждого Строка Из МассивСтрок Цикл
                               Документ = Строка.Ссылка.ПолучитьОбъект();
                               Документ.ДополнительныеСвойства.Свойство("ГрупповоеПерепроведение", Истина);
                Документ.Записать(РежимЗаписи.Проведение);
КонецЦикла; - так разве не работает?
 
 Рекламное место пустует
   inkvizitr
 
11 - 27.11.18 - 15:54
мне нужно, чтобы при выделении в форме списка более двух документов, у документов появился у доп. свойств ГрупповоеПерепроведение", Истина
   PR
 
12 - 27.11.18 - 15:55
(7) Правильнее будет через и
   Ник080808
 
13 - 27.11.18 - 15:56
(9) допсвойства существуют у объекта в пределах его "жизни". То есть в процедуре при записи ты в допсвойтва передаешь некие данные которые можешь получить после записи в обработке проведения и так далее. Но это не реквизит, данные не хранятся в бд.
   inkvizitr
 
14 - 27.11.18 - 15:56
(12) давай еще будем пунктуацию разбирать
   inkvizitr
 
15 - 27.11.18 - 15:58
(13) смотри, я допустим из того примера который привел здесь, поставил точку останова на КонецЦикла, при первой итерации он все равно не присвоил свойство
   inkvizitr
 
16 - 27.11.18 - 15:58
т.е. как бы предел его жизни не закончен был
   Вафель
 
17 - 27.11.18 - 15:59
из списка это никакое не групповое
   Вафель
 
18 - 27.11.18 - 16:00
можно еще команду проведения подменить
   hhhh
 
19 - 27.11.18 - 16:00
(14) Документ.ДополнительныеСвойства.Свойство("ГрупповоеПерепроведение", Истина);   

- это ты читаешь свойство. А тебе наоборот, надо присвоить значение. Открой всё=таки синтакс-помощник.
   inkvizitr
 
20 - 27.11.18 - 16:01
(18) хорошо массовое перепроведение
   inkvizitr
 
21 - 27.11.18 - 16:01
(19) сейчас еще раз открою
   inkvizitr
 
22 - 27.11.18 - 16:02
(19) ДокументОбъект.<Имя документа> (DocumentObject.<Имя документа>)
ДополнительныеСвойства (AdditionalProperties)
Использование:

Только чтение.
Описание:

Тип: Структура.
Может использоваться в тех случаях, когда необходимо хранить некоторые значения, связанные с объектом, на время выполнения некоторых операций, без изменения объекта. Например, при обработке событий в подписке на события.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
   Homer
 
23 - 27.11.18 - 16:04
(22) религия не позволяет поиск сделать в базе по ДополнительныеСвойства и посмотреть как работает метод
   inkvizitr
 
24 - 27.11.18 - 16:05
открой типовую обработку ГрупповоеПерепроведениеДокументов и посмотри
   inkvizitr
 
25 - 27.11.18 - 16:06
(23) вот пример из типовой обработки 
ДокументОбъект.ДополнительныеСвойства.Вставить("ГрупповоеПерепроведение", Истина);
   inkvizitr
 
26 - 27.11.18 - 16:06
(23) в модуле менеджера
   inkvizitr
 
27 - 27.11.18 - 16:06
(8) напиши код за который не выгоняют с работы
   Вафель
 
28 - 27.11.18 - 16:07
тебе нужно команду проведения подменять стандартная никакие доп свойства не устанввливает
   hhhh
 
29 - 27.11.18 - 16:08
(22) ну.

Структура (Structure)
Свойство (Property)
Синтаксис:

Свойство(<Ключ>, <НайденноеЗначение>)
Параметры:

<Ключ> (обязательный)

Тип: Строка.
Ключ для поиска свойства. 
<НайденноеЗначение> (необязательный)

Тип: Произвольный. 
В данный параметр возвращается найденное значение. Если ключа нет в структуре, то возвращается Неопределено.
Возвращаемое значение:

Тип: Булево.
Истина - ключ найден; Ложь в противном случае.
Описание:

Получает значение элемента по указанному имени, а также проверяет, имеется ли указанное свойство.


"Получает значение" !!!
   inkvizitr
 
30 - 27.11.18 - 16:10
(29) блин, точно!!!
   inkvizitr
 
31 - 27.11.18 - 16:10
(29) хорошо а как тогда пишется в эти доп. свойства
   Homer
 
32 - 27.11.18 - 16:11
(31) тебе неоднократно сказали в модули самого документа
   inkvizitr
 
33 - 27.11.18 - 16:14
(32) хорошо, в каком именно? модуле объекта, менеджера, формы?
 
 
   Homer
 
34 - 27.11.18 - 16:21
(33) Поиском в типовой конфигурации посмотри, там все написано понятно.
У меня складывается чувство, что ты не понимаешь для чего используется ДополнительныеСвойства.
   inkvizitr
 
35 - 27.11.18 - 16:23
аа.. все заработало
   inkvizitr
 
36 - 27.11.18 - 16:23
(29) ты гений
   VladZ
 
37 - 27.11.18 - 16:23
(0) "Процедура test(МассивСтрок)" - будешь так делать, к тебе придут "чОрные 1С-ники и сделают больно".
   inkvizitr
 
38 - 27.11.18 - 16:24
(29) блин там же тип структура, вообще я тупил, вместо Свойство надо было Вставить
   inkvizitr
 
39 - 27.11.18 - 16:25
(37) Это все тестовый пример, произошел затуп, для общего понимания, набросал простой тестовый пример, не переживай не приедут
   Ник080808
 
40 - 27.11.18 - 16:25
(38) только тебе это не поможет)
   inkvizitr
 
41 - 27.11.18 - 16:25
(40) почему
   Ник080808
 
42 - 27.11.18 - 16:26
(39) вот ты выделяешь сто строк и нажимаешь провести. Как ты допсвойства поставишь?
   Homer
 
43 - 27.11.18 - 16:27
(42) он при выделении поставит и проведет сразу. Так же все делают
   inkvizitr
 
44 - 27.11.18 - 16:27
(42) да, хороший вопрос
   inkvizitr
 
45 - 27.11.18 - 16:29
(43) тут с проведением немного у меня все сложнее будет, но это щас надо перекурить
   Ник080808
 
46 - 27.11.18 - 16:33
(43) а если выделили не для проведения?)
   Ник080808
 
47 - 27.11.18 - 16:34
(45) в чем суть задачи?
   Homer
 
48 - 27.11.18 - 16:35
(46) так не бывает, выделил значит проводи.
(47) предыдущую его тему посмотри и улыбнись
   inkvizitr
 
49 - 27.11.18 - 16:37
(46) идея такая, есть подписка на событие которая немного модифицирует эти документы, т.е при разовом перепроведении срабатывает стандартное проведение, если 2 и более документов, должна срабатывать подписка на событие, у источника в доп. свойствах должно быть ("ГрупповоеПерепроведение", Истина); там в подписке по этому признаку должно срабатывать условие
 
 Рекламное место пустует
   Ник080808
 
50 - 27.11.18 - 16:38
(48) а я хочу пометить на удаление)))
   Вафель
 
51 - 27.11.18 - 16:40
а как можно у выделенного поставить доп свойство? или выделил и сразу провел? а если просто скролл делаешь?
   Ник080808
 
52 - 27.11.18 - 16:41
(49) ну это не логично: ты выделил один документ. Провел, отработала подписка, выделил два документа, не отработала, потом опять один отработала. Что такое делает подписка?
   inkvizitr
 
53 - 27.11.18 - 16:45
(52) там есть самописный реквизит, который имеет признак булево, смысл в том, что при повторном проведении данный признак меняется, и в логике это есть правильно, но.. при групповом перепроведении не важно как оно осуществляется, через групповую обработку или если даже провести 2а документа одного вида, этот реквизит трогать не стоит
   inkvizitr
 
54 - 27.11.18 - 16:45
в 1с нет такого метода или свойства групповое перепроведение, вот и пытаюсь колхозить
   inkvizitr
 
55 - 27.11.18 - 17:00
буду чего ни будь дальше придумывать
   Ник080808
 
56 - 27.11.18 - 17:01
(53) "смысл в том, что при повторном проведении данный признак меняется, и в логике это есть правильно" - так делай наоборот. В форме документа перед записью проверяешь проведен документ или нет и пиши допсвойство - проведение документа из формы. При проведении анализируй и меняй свой реквизит, ибо все что проведено не из формы документа считается групповым перепроведением)
   inkvizitr
 
57 - 27.11.18 - 17:12
(56) а ты гений


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует