Вход | Регистрация


как можно программно определить, что проводится груповое перепроведение?

как можно программно определить, что проводится груповое перепроведение?
Я
   inkvizitr
 
27.11.18 - 09:09
как можно программно определить, что проводится групповое перепроведение? т.е. беру к примеру, выделяю 5 документов поступления и провожу, не пойму как программно определить, что это как бы массовое перепроведение
 
 
   inkvizitr
 
1 - 27.11.18 - 09:13
или к примеру есть стандартный механизм бсп на эту тему?
   1Сергей
 
2 - 27.11.18 - 09:21
А зачем? чем групповое проведение отличается от обычного?
   АгентБезопаснойНацио
 
3 - 27.11.18 - 09:22
а 4 - уже не массовое?
   inkvizitr
 
4 - 27.11.18 - 09:29
(2) я так понял ничего в платформе такого нету и в бсп тоже, только городить свой алгоритм?
   бегинер
 
5 - 27.11.18 - 09:35
если ВыделенныеСтроки>1 то групповуха=истина
   1Сергей
 
6 - 27.11.18 - 10:28
(4) ещё. раз. Зачем?
   rs_trade
 
7 - 27.11.18 - 10:30
(4) городить похоже ты уже начал. зачем это?
   inkvizitr
 
8 - 27.11.18 - 10:44
у меня есть подписка на событие самописная, смысл в том, что при массовом проведении документов эта подписка не отрабатывала, я нашел в типовой конфе
Функция ГрупповоеПерепроведение(Объект) Экспорт

    Перем Результат;
    
    Если Объект.ДополнительныеСвойства.Свойство("ГрупповоеПерепроведение", Результат) Тогда
        Если Результат <> Ложь Тогда
            Результат = Истина;
        КонецЕсли;
    Иначе
        Результат = Ложь;
    КонецЕсли;

    Возврат Результат;

КонецФункции

вот думаю как задать доп. свойство
   decdmb
 
9 - 27.11.18 - 10:45
Переопределить в форме списка стандартную команду проведения.
В алгоритме групповой обработки в структуру Объекта ДополнительныеСвойства добавлять свой признак и на него ориентироваться в обработке проведения?
   1Сергей
 
10 - 27.11.18 - 10:46
(8) т.е. результат проведения в обычном режиме будет отличатся от результата в групповом. ЕЩЁ. РАЗ. ЗАЧЕМ?
 
 Рекламное место пустует
   inkvizitr
 
11 - 27.11.18 - 10:54
(10) да  будет отличаться, нужно чтобы при групповом перепроведении подписка не отрабатывала
   1Сергей
 
12 - 27.11.18 - 10:59
(11) ну, ты же понимаешь что что-то не так в консерватории?
   Вафель
 
13 - 27.11.18 - 11:08
в бСП юзается
    Если ПроведениеСервер.ГрупповоеПерепроведение(ЭтотОбъект) Тогда

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует