Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Не работает УстановитьИнтервал() в модуле формы журнала документов

v7: Не работает УстановитьИнтервал() в модуле формы журнала документов
Я
   CepeLLlka
 
23.11.18 - 15:39
Уважаемые гуру, подскажите пожалуйста, почему вот это не работает в модуле формы журнала документов..

Процедура ПриУстановкеИнтервала(ДатаНач, ДатаКон)
    Если ДатаНач <= Константа.ДатаЗапретаРедактирования Тогда
        Предупреждение("Вам не разрешён просмотр документов с датой меньше "+Константа.ДатаЗапретаРедактирования, 4);
        УстановитьИнтервал(Константа.ДатаОграниченияПросмотра, ДатаКон, 1)
    КонецЕсли;
КонецПроцедуры

А вот это работает..
Процедура КнопкаУстИнт()
    УстановитьИнтервал(Константа.ДатаОграниченияПросмотра,, 1);    
КонецПроцедуры
 
 
   HawkEye
 
1 - 23.11.18 - 15:52
(0) если прямо вот надо установить начало интервала Константа.ДатаОграниченияПросмотра, то делай через фиктивное закрытие, если надо просто не дать установить закрытый период... статусВозврата(0); возврат; вместо УстановитьИнтервал(Константа.ДатаОграниченияПросмотра, ДатаКон, 1)
   CepeLLlka
 
2 - 23.11.18 - 15:58
(1)Да.. это уже костыли какие-то.. :(
Есть метод.. штатно не работает нифига :( Пичаль
   CepeLLlka
 
3 - 23.11.18 - 16:00
(1)Большое спасибо за подсказки..
Сейчас попробую с закрытием и открытием формы.. Если будет сильного моргать, то буду выводить сообщение о запрете, пусть заново выбирают..

Спасибо!
   Ёпрст
 
4 - 23.11.18 - 16:06
ДатаКон чему хоть равна то ?
   trad
 
5 - 23.11.18 - 16:06
СтатусВозврата(0) - правильный ответ
   CepeLLlka
 
6 - 23.11.18 - 16:08
(4)ДатаКон которую выбрал пользователь при установке интервала интерактивно..
   Ёпрст
 
7 - 23.11.18 - 16:11
Да, тут только ложное закрытие формы спасёт
   CepeLLlka
 
8 - 23.11.18 - 16:12
(7)Есть примеры реализации? А то чёт у меня не вышло вот так сразу с разбега.. :)
   Ёпрст
 
9 - 23.11.18 - 16:12
(5) ну не совсем, если нужно точную границу указать..
   Ёпрст
 
10 - 23.11.18 - 16:14
(8)
Перем НужнаяДата;

Процедура ПриУстановкеИнтервала(ДатаНач, ДатаКон)
    
    НужнаяДата = ТекущаяДата();
    Форма.Закрыть(0);
    
    
КонецПроцедуры
//======================================================================

Процедура ПриЗакрытии()
    Если ПустоеЗначение(НужнаяДата) =0 Тогда
        СтатусВозврата(0);
        УстановитьИнтервал(,НужнаяДата,1);
        НужнаяДата="";
    КонецЕсли;
КонецПроцедуры// ПриЗакрытии
 
 Рекламное место пустует
   Ёпрст
 
11 - 23.11.18 - 16:14
своё условие еще воткнешь и привет
   CepeLLlka
 
12 - 23.11.18 - 16:44
(11)Ну ты жёсткий.. Всё чётко получилось.. Я только ещё в НужнойДате конец периода передавал..

Спасибо тебе большое..

А я думал по другому.. думал нужно одну форму закрыть, а другую открыть с новым отбором.. начал там уже велосипеды мутить :) Спасибо! :)
   Масянька
 
13 - 23.11.18 - 16:50
(12) Он не жесткий... Он шибко умный :)))
   CepeLLlka
 
14 - 23.11.18 - 17:12
(13)Да я это и имел ввиду.. что типа вообще всё знает, профи :)
   HawkEye
 
15 - 23.11.18 - 18:47
(12) оно потому и называется ложное, что форма не закрывается...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует