Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Программное восстановление последовательности в документах 1С

Программное восстановление последовательности в документах 1С
Я
   inkvizitr
 
21.11.18 - 14:46
вот набросал в цикле механизм перепроведения документов, нужные документы у меня хранятся в ТЗ под названием "ТаблицаДокументов", суть всего вопроса состоит в том, что я не знаю как правильно описывать код по восстановление последовательности, могли бы проверить, дать советы и т.п.

    Для каждого Документ Из ТаблицаДокументов Цикл
        Если Документ.ВыбратьДокумент Тогда
            Если ТекстЗапроса <> "" Тогда
                ТекстЗапроса = ТекстЗапроса + "
                |ОБЪЕДИНИТЬ ВСЕ";
            КонецЕсли;         
            ТекстЗапроса = ТекстЗапроса+ "
            |ВЫБРАТЬ
            |    Документ.Ссылка
            |    Документ.Дата,
            |    Документ.Организация,
            |    Документ.Проведен
            |ИЗ 
            |    Документ." + Документ.ИмяДокумента + " КАК Документ
            |ГДЕ
            |    Документ.Проведен
            |    И Документ.Дата МЕЖДУ &ДатаНачало И &ДатаОкончания";
        КонецЕсли;
    КонецЦикла; 
    
    ТекстЗапроса = ТекстЗапроса + "
    |УПОРЯДОЧИТЬ ПО
    |    Ссылка";
    
    Запрос = Новый Запрос(ТекстЗапроса);
    Запрос.УстановитьПараметр("ДатаНачало", ДатаНачало);
    Запрос.УстановитьПараметр("ДатаОкончания", ДатаОкончания);
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
        Момент = Новый МоментВремени(Выборка.Дата, Выборка.Ссылка);
        Отбор = Новый ТаблицаЗначений;
        Отбор.Колонки.Добавить("Организация");
        Отбор.Добавить().Организация = Выборка.Организация;
        Последовательности.ДокументыОрганизаций.Восстановить(Момент, Отбор);
 
        ДокументКоторыйНужноПерепровести = Выборка.Ссылка.ПолучитьОбъект();
        ДокументКоторыйНужноПерепровести.Записать(РежимЗаписиДокумента.Проведение);
    КонецЦикла;
 
 
   inkvizitr
 
1 - 21.11.18 - 14:48
т.е. как говорится перепровести программно могу, а вот с восстановлением последовательностью не работал
   inkvizitr
 
2 - 21.11.18 - 14:59
меня больше всего волнует вот этот момент и на сколько он правильный
        Момент = Новый МоментВремени(Выборка.Дата, Выборка.Ссылка);
        Отбор = Новый ТаблицаЗначений;
        Отбор.Колонки.Добавить("Организация");
        Отбор.Добавить().Организация = Выборка.Организация;
        Последовательности.ДокументыОрганизаций.Восстановить(Момент, Отбор);

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует