Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Условное оформление табличной части по подреквизиту.

УФ. Условное оформление табличной части по подреквизиту.
Я
   IgorK11
 
20.11.18 - 20:30
Документ, табличная часть, в ней реквизит "Реализация" (ссылка на док)
Необходимо подсветить строки с пустыми комментариями "реализации".
На форму Реализация.Комментарий выведен, но в Условном оформлении формы нельзя выбрать подреквизит "Реализация.Комментарий", только "Реализация".

Есть какое-то решение?
 
 
   Tonik992
 
1 - 20.11.18 - 22:49
Если у вас динамический список - то условие оформления надо накладывать именно на него, а не на форму.
Если не динамический список, то вижу вариант решения - вытащить ваш "подреквизит" и сделать его реквизитом ТЗ.
   IgorK11
 
2 - 21.11.18 - 08:45
На самом деле используются 3 реквизита документа, и вытягивать их все дикий дубляж получается, да даже если и комментарий только таскать, глупо. Других вариантов значит нет?

А табличную часть возможно превратить в динамический список оставив весь функционал редактирования?
   IgorK11
 
3 - 21.11.18 - 08:45
Зачем такие ограничения платформы сделали, непонятно.
   IgorK11
 
4 - 21.11.18 - 10:06
И что делать если мне нужно свое условие подсветки задать, например подсветить ТЧ1 строк "реализаций" которые присутствуют в другой ТЧ2 этой формы? Невозможно в принципе?
   IgorK11
 
5 - 26.11.18 - 13:29
Мда, помощи тут на форуме не много...
Опробовав кучу комбинаций пока нашел один вариант:
Имя ТЧ - "Оплаты"
1. В форме->Объект->Реквизиты->Оплаты, ПКМ добавил реквизит "Подсветка" (он будет подсвечиваться красным).
2. Форма->Свойства->УсловноеОформление->добавил: офрмление ..., условие: Объект.Оплаты.Подсветить Равно "Истина".
3. код:
==============================
&НаСервере
Функция ПрочитатьРеквизит(Об, ИмяРекв)
    Возврат Об[ИмяРекв];
КонецФункции

&НаКлиенте
Процедура ОбновитьПодсветку()
    Для Каждого Стр Из Объект.Оплаты Цикл 
        Коммент = ПрочитатьРеквизит(Стр.Реализация,"Комментарий");
        СуммаРеал = ПрочитатьРеквизит(Стр.Реализация,"СуммаДокумента");
        Стр.Подсветить = (Стр.Сумма = 0 И (НЕ ПустаяСтрока(Коммент) И СуммаРеал>0));
    КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ОплатыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
    ОбновитьПодсветку();
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ОбновитьПодсветку();
КонецПроцедуры
==============================

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует