Вход | Регистрация


программно сформировать текст запроса

программно сформировать текст запроса
Я
   inkvizitr
 
20.11.18 - 15:19
За ранее извиняюсь за тему которая наверно уже много раз здесь обсуждалась, но вот гугл и яндекс мне в этом пока не помогли, нужно составить текст запроса, где количество видов документов заранее неизвестно, нужно из этих документов тащить общий у них реквизит ДАТА. Чета не могу составить текст запроса который генерировался бы в цикле, есть у кого хотя бы ссылки на примеры, был бы благодарен

Документы типа реализация, поступления, счет и.т.д
 
 
   asady
 
1 - 20.11.18 - 15:22
(0) ну ты напиши хоть что-нить...
   inkvizitr
 
2 - 20.11.18 - 15:23
все нашел пример, спасибо

ТекстЗапроса = "";
    Для каждого Вид Из Метаданные.Документы Цикл
        Если ТекстЗапроса<>"" Тогда
            ТекстЗапроса=ТекстЗапроса+"
            |ОБЪЕДИНИТЬ ВСЕ";
        КонецЕсли;         
         ТекстЗапроса = ТекстЗапроса+"
         |ВЫБРАТЬ Ссылка
         |ИЗ Документ."+Вид.Имя;
     КонецЦикла; 
     Запрос = Новый Запрос(ТекстЗапроса);
     Выборка = Запрос.Выполнить().Выбрать();
     Пока Выборка.Следующий() Цикл
         Сообщить(Выборка.Ссылка);
     КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует